dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
From: "Christian König" <ckoenig.leichtzumerken@gmail.com>
To: "Joe Perches" <joe@perches.com>, "Arnd Bergmann" <arnd@arndb.de>,
	"Alex Deucher" <alexander.deucher@amd.com>,
	"Christian König" <christian.koenig@amd.com>,
	"David (ChunMing) Zhou" <David1.Zhou@amd.com>,
	"David Airlie" <airlied@linux.ie>,
	"Daniel Vetter" <daniel@ffwll.ch>,
	"Hawking Zhang" <Hawking.Zhang@amd.com>,
	"John Clements" <john.clements@amd.com>
Cc: Guchun Chen <guchun.chen@amd.com>, Tao Zhou <tao.zhou1@amd.com>,
	linux-kernel@vger.kernel.org, amd-gfx@lists.freedesktop.org,
	dri-devel@lists.freedesktop.org, Dennis Li <Dennis.Li@amd.com>
Subject: Re: [PATCH] drm/amdgpu: allocate large structures dynamically
Date: Thu, 7 May 2020 08:42:51 +0200	[thread overview]
Message-ID: <845a2e12-538c-fb6d-db80-78e8adf1413f@gmail.com> (raw)
In-Reply-To: <006e29037a9314fb286a5d6d84905bce99cef6c7.camel@perches.com>

Am 06.05.20 um 21:01 schrieb Joe Perches:
> On Tue, 2020-05-05 at 16:01 +0200, Arnd Bergmann wrote:
>> After the structure was padded to 1024 bytes, it is no longer
>> suitable for being a local variable, as the function surpasses
>> the warning limit for 32-bit architectures:
>>
>> drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c:587:5: error: stack frame size of 1072 bytes in function 'amdgpu_ras_feature_enable' [-Werror,-Wframe-larger-than=]
>> int amdgpu_ras_feature_enable(struct amdgpu_device *adev,
>>      ^
>>
>> Use kzalloc() instead to get it from the heap.
> []
>> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
> []
>> @@ -588,19 +588,23 @@ int amdgpu_ras_feature_enable(struct amdgpu_device *adev,
>>   		struct ras_common_if *head, bool enable)
>>   {
>>   	struct amdgpu_ras *con = amdgpu_ras_get_context(adev);
>> -	union ta_ras_cmd_input info;
>> +	union ta_ras_cmd_input *info;
>>   	int ret;
>>   
>>   	if (!con)
>>   		return -EINVAL;
>>   
>> +        info = kzalloc(sizeof(union ta_ras_cmd_input), GFP_KERNEL);
> Spaces were used for indentation here not a tab.
> It might be useful to run your proposed patches through checkpatch
>
> Is this an actual bug fix as the previous use didn't
> zero unused info members?
>
>> +	if (!info)
>> +		return -ENOMEM;
>> +
>>   	if (!enable) {
>> -		info.disable_features = (struct ta_ras_disable_features_input) {
>> +		info->disable_features = (struct ta_ras_disable_features_input) {
>>   			.block_id =  amdgpu_ras_block_to_ta(head->block),
>>   			.error_type = amdgpu_ras_error_to_ta(head->type),
>>   		};
>>   	} else {
>> -		info.enable_features = (struct ta_ras_enable_features_input) {
>> +		info->enable_features = (struct ta_ras_enable_features_input) {
>>   			.block_id =  amdgpu_ras_block_to_ta(head->block),
>>   			.error_type = amdgpu_ras_error_to_ta(head->type),
>>   		};
>> @@ -609,26 +613,33 @@ int amdgpu_ras_feature_enable(struct amdgpu_device *adev,
>>   	/* Do not enable if it is not allowed. */
>>   	WARN_ON(enable && !amdgpu_ras_is_feature_allowed(adev, head));
>>   	/* Are we alerady in that state we are going to set? */
>> -	if (!(!!enable ^ !!amdgpu_ras_is_feature_enabled(adev, head)))
>> -		return 0;
>> +	if (!(!!enable ^ !!amdgpu_ras_is_feature_enabled(adev, head))) {
> And trivia:
>
> The !! uses with bool seem unnecessary and it's probably better
> to make amdgpu_ras_is_feature_enabled to return bool.
>
> Maybe something like:
> ---
>   drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c | 12 ++++++------
>   1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
> index 538895cfd862..05c4eaf0ddfa 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
> @@ -526,16 +526,16 @@ void amdgpu_ras_parse_status_code(struct amdgpu_device* adev,
>   }
>   
>   /* feature ctl begin */
> -static int amdgpu_ras_is_feature_allowed(struct amdgpu_device *adev,
> -		struct ras_common_if *head)
> +static bool amdgpu_ras_is_feature_allowed(struct amdgpu_device *adev,
> +					  struct ras_common_if *head)
>   {
>   	struct amdgpu_ras *con = amdgpu_ras_get_context(adev);
>   
>   	return con->hw_supported & BIT(head->block);
>   }
>   
> -static int amdgpu_ras_is_feature_enabled(struct amdgpu_device *adev,
> -		struct ras_common_if *head)
> +static bool amdgpu_ras_is_feature_enabled(struct amdgpu_device *adev,
> +					  struct ras_common_if *head)
>   {
>   	struct amdgpu_ras *con = amdgpu_ras_get_context(adev);
>   
> @@ -560,7 +560,7 @@ static int __amdgpu_ras_feature_enable(struct amdgpu_device *adev,
>   	 */
>   	if (!amdgpu_ras_is_feature_allowed(adev, head))
>   		return 0;
> -	if (!(!!enable ^ !!amdgpu_ras_is_feature_enabled(adev, head)))
> +	if (!(enable ^ amdgpu_ras_is_feature_enabled(adev, head)))

And while we are at improving coding style I think that writing this as 
"if (enabled == amdgpu_ras_is_feature_enabled(adev, head))" would be 
much more readable.

Christian.

>   		return 0;
>   
>   	if (enable) {
> @@ -609,7 +609,7 @@ int amdgpu_ras_feature_enable(struct amdgpu_device *adev,
>   	/* Do not enable if it is not allowed. */
>   	WARN_ON(enable && !amdgpu_ras_is_feature_allowed(adev, head));
>   	/* Are we alerady in that state we are going to set? */
> -	if (!(!!enable ^ !!amdgpu_ras_is_feature_enabled(adev, head)))
> +	if (!(enable ^ amdgpu_ras_is_feature_enabled(adev, head)))
>   		return 0;
>   
>   	if (!amdgpu_ras_intr_triggered()) {
>
>
>
> _______________________________________________
> amd-gfx mailing list
> amd-gfx@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/amd-gfx

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2020-05-07  6:42 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-05 14:01 [PATCH] drm/amdgpu: allocate large structures dynamically Arnd Bergmann
2020-05-05 14:07 ` Christian König
2020-05-05 15:34   ` Alex Deucher
2020-05-06 19:01 ` Joe Perches
2020-05-07  6:42   ` Christian König [this message]
2020-05-07  6:55     ` Joe Perches

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=845a2e12-538c-fb6d-db80-78e8adf1413f@gmail.com \
    --to=ckoenig.leichtzumerken@gmail.com \
    --cc=David1.Zhou@amd.com \
    --cc=Dennis.Li@amd.com \
    --cc=Hawking.Zhang@amd.com \
    --cc=airlied@linux.ie \
    --cc=alexander.deucher@amd.com \
    --cc=amd-gfx@lists.freedesktop.org \
    --cc=arnd@arndb.de \
    --cc=christian.koenig@amd.com \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=guchun.chen@amd.com \
    --cc=joe@perches.com \
    --cc=john.clements@amd.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tao.zhou1@amd.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).