archive mirror
 help / color / mirror / Atom feed
* unpacking error
@ 2019-10-28  0:11 lyle.ziegelmiller
  2019-10-28 10:14 ` Philip Oakley
  0 siblings, 1 reply; 6+ messages in thread
From: lyle.ziegelmiller @ 2019-10-28  0:11 UTC (permalink / raw)
  To: 'git bug report'


I almost always get this error when pushing from my PC to the bare
repository on my laptop. I'm running Cygwin on Windows 10. I've tried
everything! chmod -R 777, chown -R <my user id>, etc.

A few more details: I have a Git repository on my PC, and from that, I've
cloned a bare repository on my laptop, which I then used to clone a regular
repository on my laptop. The error occurs when I attempt to push changes on
my PC into the bare repository on my laptop.

If I delete the old bare repository on my laptop, I'm able to create a new
bare repository on my laptop from my pc, but then as soon as I try to push
to it, I get this error again. I've tried disabling the anti-virus, etc.
I've spent hours Googling solutions. Nothing works! Many others have had
this same issue. I never had this type of problem with SVN.

It would be nice if Git would say what's failing when this happens, and it
would be nice to get this bug fixed. It happens with all my git
repositories. I don't think it's a network issue or I wouldn't be able to
create a new repository on my laptop from my PC, as that would encounter the
same permissions issues.

The two machines are connected with an ethernet cable. I've done everything
I can to make sure all the Windows permissions are set correctly, etc.

$ git push
Counting objects: 3, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 331 bytes | 331.00 KiB/s, done.
Total 3 (delta 2), reused 0 (delta 0)
remote: fatal: not a git repository: '.'
error: remote unpack failed: unpack-objects abnormal exit To
 ! [remote rejected] timestamp_testing -> timestamp_testing (unpacker error)
error: failed to push some refs to

$ git --version
git version 2.17.0

System Information
      Time of this report: 10/27/2019, 16:53:09
             Machine name: LJZ-DELLPC
               Machine Id: {39BC0826-743F-4ECA-AFBE-66A14FBE533C}
         Operating System: Windows 10 Pro 64-bit (10.0, Build 17134)
                 Language: English (Regional Setting: English)
      System Manufacturer: Dell Inc.
             System Model: Inspiron 3650
                     BIOS: BIOS Date: 06/17/16 21:14:07 Ver: 05.0000B (type:
                Processor: Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz (4 CPUs),
                   Memory: 8192MB RAM
      Available OS Memory: 8096MB RAM
                Page File: 8076MB used, 7243MB available
              Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, with HDCP Microsoft Graphics Hybrid:
Not Supported
           DxDiag Version: 10.00.17134.0001 64bit Unicode


Lyle Ziegelmiller

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2020-01-18 18:07 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-28  0:11 unpacking error lyle.ziegelmiller
2019-10-28 10:14 ` Philip Oakley
2019-10-29  4:47   ` lyle.ziegelmiller
     [not found]     ` <001a01d5a256$5e64d010$1b2e7030$>
2019-11-24 14:53       ` FW: " Philip Oakley
2019-12-25 18:49       ` lyle.ziegelmiller
     [not found]         ` <>
2020-01-18 18:07           ` lyle.ziegelmiller

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).