git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Duy Nguyen <pclouds@gmail.com>
To: Rohit Ashiwal via GitGitGadget <gitgitgadget@gmail.com>
Cc: Git Mailing List <git@vger.kernel.org>,
	Junio C Hamano <gitster@pobox.com>,
	Rohit Ashiwal <rohit.ashiwal265@gmail.com>
Subject: Re: [PATCH v3 1/1] t3600: use test_path_is_* functions
Date: Wed, 27 Feb 2019 17:12:24 +0700	[thread overview]
Message-ID: <CACsJy8BYeLvB7BSM_Jt4vwfGsEBuhaCZfzGPOHe=B=7cvnRwrg@mail.gmail.com> (raw)
In-Reply-To: <bfeba25c885484093bf8307294935f8baa6b155b.1551221334.git.gitgitgadget@gmail.com>

On Wed, Feb 27, 2019 at 5:49 AM Rohit Ashiwal via GitGitGadget
<gitgitgadget@gmail.com> wrote:
>
> From: Rohit Ashiwal <rohit.ashiwal265@gmail.com>
>
> Replace `test -(d|f|e)` calls in t3600-rm.sh
>
> Previously we were using `test -(d|f|e)` to verify
> the presence of a directory/file, but we already
> have helper functions, viz, `test_path_is_dir`,
> `test_path_is_file` and `test_path_is_missing`
> with better functionality.
>
> These helper functions make code more readable
> and informative to someone new to code, also
> these functions have better error messages
>
> Signed-off-by: Rohit Ashiwal <rohit.ashiwal265@gmail.com>
> ---
>  t/t3600-rm.sh | 138 +++++++++++++++++++++++++-------------------------
>  1 file changed, 69 insertions(+), 69 deletions(-)
>
> diff --git a/t/t3600-rm.sh b/t/t3600-rm.sh
> index 04e5d42bd3..ad638490ac 100755
> --- a/t/t3600-rm.sh
> +++ b/t/t3600-rm.sh
> @@ -83,7 +83,7 @@ test_expect_success \
>
>  test_expect_success \
>      'Post-check that bar does not exist and is not in index after "git rm -f bar"' \
> -    '! [ -f bar ] && test_must_fail git ls-files --error-unmatch bar'
> +    'test_path_is_missing bar && test_must_fail git ls-files --error-unmatch bar'

This line should be broken down in two. It was reasonably short
before, but now getting long and two checks in one line seem easy to
miss.

I was a bit worried that the "test ! something" could be incorrectly
converted because for example, "test ! -d foo" is not always the same
as "test_path_is_missing". If "foo" is intended to be a file, then the
conversion is wrong.

But I don't think you made any wrong conversion here. All these
negative "test" are preceded by "git rm" so the expectation is always
"test ! -e".
-- 
Duy

  reply	other threads:[~2019-02-27 10:12 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-02-26 13:42 [PATCH 0/1] [GSoC][PATCH] tests: replace test -(d|f) with test_path_is_(dir|file) Rohit Ashiwal via GitGitGadget
2019-02-26 13:42 ` [PATCH 1/1] tests: replace `test -(d|f)` " Rohit Ashiwal via GitGitGadget
2019-02-26 14:04   ` Duy Nguyen
2019-02-26 16:10     ` Do test-path_is_{file,dir,exists} make sense anymore with -x? Ævar Arnfjörð Bjarmason
2019-02-26 17:04       ` SZEDER Gábor
2019-02-26 17:43         ` Jeff King
2019-02-26 19:39           ` SZEDER Gábor
2019-02-26 21:01             ` Jeff King
2019-03-03 16:04               ` SZEDER Gábor
2019-03-05  4:55                 ` Jeff King
2019-03-04 14:36               ` SZEDER Gábor
2019-03-05  4:58                 ` Jeff King
2019-02-26 17:48         ` Matthieu Moy
2019-02-26 18:24           ` Jeff King
2019-02-26 17:35       ` Jeff King
2019-02-26 19:58         ` Johannes Schindelin
2019-02-26 21:02           ` Jeff King
2019-02-27 10:01       ` Duy Nguyen
2019-03-01  2:52       ` Junio C Hamano
2019-02-26 16:01   ` [PATCH 1/1] tests: replace `test -(d|f)` with test_path_is_(dir|file) Johannes Schindelin
2019-02-26 16:30   ` Martin Ågren
2019-02-26 18:29     ` Rohit Ashiwal
2019-02-26 19:52       ` Johannes Schindelin
2019-02-26 20:01         ` Rohit Ashiwal
2019-02-27  5:49           ` Martin Ågren
2019-02-26 14:26 ` [PATCH v2 0/1] [GSoC][PATCH] t3600: use test_path_is_dir and test_path_is_file Rohit Ashiwal via GitGitGadget
2019-02-26 14:26   ` [PATCH v2 1/1] " Rohit Ashiwal via GitGitGadget
2019-02-26 16:37     ` SZEDER Gábor
2019-02-26 18:40       ` Rohit Ashiwal
2019-02-26 20:02         ` Johannes Schindelin
2019-02-26 20:05           ` Rohit Ashiwal
2019-02-26 22:48   ` [PATCH v3 0/1] [GSoC][PATCH] t3600: use test_path_is_* helper functions Rohit Ashiwal via GitGitGadget
2019-02-26 22:48     ` [PATCH v3 1/1] t3600: use test_path_is_* functions Rohit Ashiwal via GitGitGadget
2019-02-27 10:12       ` Duy Nguyen [this message]
2019-02-28 10:26     ` [PATCH v4 0/1] [GSoC][PATCH] t3600: use test_path_is_* helper functions Rohit Ashiwal via GitGitGadget
2019-02-28 10:26       ` [PATCH v4 1/1] t3600: use test_path_is_* functions Rohit Ashiwal via GitGitGadget
2019-02-28 19:02         ` [GSoC] acknowledging mistakes Rohit Ashiwal
2019-03-01  2:51           ` Junio C Hamano
2019-03-01 13:13             ` Feeling confused a little bit Rohit Ashiwal
2019-03-02  4:24               ` Rafael Ascensão
2019-03-02 14:46               ` Thomas Gummerer
2019-03-02 16:21                 ` [GSoC] Thanking Rohit Ashiwal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CACsJy8BYeLvB7BSM_Jt4vwfGsEBuhaCZfzGPOHe=B=7cvnRwrg@mail.gmail.com' \
    --to=pclouds@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitgitgadget@gmail.com \
    --cc=gitster@pobox.com \
    --cc=rohit.ashiwal265@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).