git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Ævar Arnfjörð Bjarmason" <avarab@gmail.com>
To: git@vger.kernel.org
Cc: "Junio C Hamano" <gitster@pobox.com>, "Jeff King" <peff@peff.net>,
	"Enzo Matsumiya" <ematsumiya@suse.de>,
	"Eric Sunshine" <sunshine@sunshineco.com>,
	"Ævar Arnfjörð Bjarmason" <avarab@gmail.com>
Subject: [PATCH 0/3] run-command.h: rename "env_array" to "env"
Date: Wed,  6 Apr 2022 12:42:42 +0200	[thread overview]
Message-ID: <cover-0.3-00000000000-20220406T104134Z-avarab@gmail.com> (raw)
In-Reply-To: <Ybtb6Shdj56ACdub@coredump.intra.peff.net>

On Thu, Dec 16 2021, Jeff King wrote:

> On Thu, Dec 16, 2021 at 12:51:55PM +0100, Ævar Arnfjörð Bjarmason wrote:
>
>> Or maybe you're not interested in either case, which is also fine. It's
>> really not needed for anything other than to resolve the minor oddity
>> that we have two "struct strvec"'s, "args" and "env_array". It's just a
>> bit odd to have one with "_array" in the name, which is only because the
>> now-removed "env" was taken at the time.
>
> Yeah, FWIW I absolutely hated "env_array" when I added it, but didn't
> want to do the transition all at once, so needed another name. So I
> would be happy to see it become "env" now. ;)

Perhaps this follow-up to 832ec72c3e1 (Merge branch 'ab/run-command',
2021-12-15) will warm Jeff's heart if/when he returns from his git
sabbatical :)

Junio: We're in the RC period, but perhaps this change if we're ever
going to make it would be good to make around that time of patch
slowdown. I.e. for the first batch after release.

I've been holding onto this since around December, but when I checked
there was always 1-2 series that was adding new use of "env_array",
resolving that conflict didn't seem worth the hassle.

Right now this doesn't conflict with anything in "seen". The
scary-at-first diffstat is almost entirely in 2/3, and everything
except a two-line change in that commit is made by the coccinelle rule
added in 1/3.

So this series for reviewing is really:

 * A trivial coccinelle rule in 1/3
 * The trivial 2 line change in run-command.h in 2/3 that isn't made
   by that rule
 * Subsequent trivial cleanup in 3/3 changing s/env_array/env/g in
   comments & variable names

Ævar Arnfjörð Bjarmason (3):
  cocci: add a rename of "struct child_process"'s "env_array" to "env"
  run-command API: rename "env_array" to "env"
  run-command API users: use "env" not "env_array" in comments & names

 add-patch.c                          |  2 +-
 branch.c                             |  2 +-
 builtin/difftool.c                   |  6 ++--
 builtin/receive-pack.c               | 32 ++++++++++----------
 builtin/stash.c                      | 16 +++++-----
 builtin/submodule--helper.c          | 44 ++++++++++++++--------------
 builtin/worktree.c                   |  8 ++---
 connect.c                            |  9 +++---
 connected.c                          |  2 +-
 contrib/coccinelle/run_command.cocci | 11 +++++++
 daemon.c                             | 14 ++++-----
 editor.c                             |  2 +-
 hook.c                               |  2 +-
 http-backend.c                       |  4 +--
 object-file.c                        |  2 +-
 pager.c                              |  4 +--
 promisor-remote.c                    |  2 +-
 run-command.c                        | 19 ++++++------
 run-command.h                        | 14 ++++-----
 sequencer.c                          | 18 ++++++------
 submodule.c                          | 38 ++++++++++++------------
 submodule.h                          |  4 +--
 t/helper/test-run-command.c          |  2 +-
 trailer.c                            |  2 +-
 transport-helper.c                   |  2 +-
 wt-status.c                          |  2 +-
 26 files changed, 138 insertions(+), 125 deletions(-)
 create mode 100644 contrib/coccinelle/run_command.cocci

-- 
2.36.0.rc0.849.g2d5b5d9ab01


  parent reply	other threads:[~2022-04-06 14:26 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-16  2:32 What's cooking in git.git (Dec 2021, #04; Wed, 15) Junio C Hamano
2021-12-16 11:51 ` ab/run-command (was: What's cooking in git.git (Dec 2021, #04; Wed, 15)) Ævar Arnfjörð Bjarmason
2021-12-16 15:31   ` Jeff King
2021-12-16 15:38     ` Ævar Arnfjörð Bjarmason
2021-12-16 19:11       ` ab/run-command Junio C Hamano
2022-04-06 10:42     ` Ævar Arnfjörð Bjarmason [this message]
2022-04-06 10:42       ` [PATCH 1/3] cocci: add a rename of "struct child_process"'s "env_array" to "env" Ævar Arnfjörð Bjarmason
2022-04-06 10:42       ` [PATCH 2/3] run-command API: rename " Ævar Arnfjörð Bjarmason
2022-04-06 10:42       ` [PATCH 3/3] run-command API users: use "env" not "env_array" in comments & names Ævar Arnfjörð Bjarmason
2022-04-07 12:09       ` [PATCH 0/3] run-command.h: rename "env_array" to "env" Johannes Schindelin
2022-04-07 16:48         ` Junio C Hamano
2022-04-07 17:52           ` Junio C Hamano
2022-05-20  7:24       ` [PATCH v2 0/4] " Ævar Arnfjörð Bjarmason
2022-05-20  7:24         ` [PATCH v2 1/4] cocci: add a rename of "struct child_process"'s " Ævar Arnfjörð Bjarmason
2022-05-20  7:24         ` [PATCH v2 2/4] run-command API: rename " Ævar Arnfjörð Bjarmason
2022-05-20  7:24         ` [PATCH v2 3/4] cocci: remove env_array -> env migration Ævar Arnfjörð Bjarmason
2022-05-20  7:24         ` [PATCH v2 4/4] run-command API users: use "env" not "env_array" in comments & names Ævar Arnfjörð Bjarmason
2022-05-20 16:27         ` [PATCH v2 0/4] run-command.h: rename "env_array" to "env" Junio C Hamano
2022-05-21 11:09           ` Ævar Arnfjörð Bjarmason
2022-06-02  9:09         ` [PATCH v3 0/2] " Ævar Arnfjörð Bjarmason
2022-06-02  9:09           ` [PATCH v3 1/2] run-command API: " Ævar Arnfjörð Bjarmason
2022-06-03  0:37             ` Junio C Hamano
2022-06-02  9:09           ` [PATCH v3 2/2] run-command API users: use "env" not "env_array" in comments & names Ævar Arnfjörð Bjarmason
2021-12-16 23:46 ` ab/make-dependency (was: What's cooking in git.git (Dec 2021, #04; Wed, 15)) Ævar Arnfjörð Bjarmason
2021-12-21  1:34 ` What's cooking in git.git (Dec 2021, #04; Wed, 15) Aleen 徐沛文
2021-12-21  7:30   ` Christian Couder

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover-0.3-00000000000-20220406T104134Z-avarab@gmail.com \
    --to=avarab@gmail.com \
    --cc=ematsumiya@suse.de \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=peff@peff.net \
    --cc=sunshine@sunshineco.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).