kernel-hardening.lists.openwall.com archive mirror
 help / color / mirror / Atom feed
From: Jason Cooper <jason@lakedaemon.net>
To: Kees Cook <keescook@chromium.org>
Cc: "Roberts, William C" <william.c.roberts@intel.com>,
	Yann Droneaud <ydroneaud@opteya.com>,
	Linux-MM <linux-mm@kvack.org>,
	LKML <linux-kernel@vger.kernel.org>,
	"kernel-hardening@lists.openwall.com"
	<kernel-hardening@lists.openwall.com>,
	Russell King - ARM Linux <linux@arm.linux.org.uk>,
	Andrew Morton <akpm@linux-foundation.org>,
	Theodore Ts'o <tytso@mit.edu>, Arnd Bergmann <arnd@arndb.de>,
	Greg KH <gregkh@linuxfoundation.org>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	Ralf Baechle <ralf@linux-mips.org>,
	"benh@kernel.crashing.org" <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	"David S. Miller" <davem@davemloft.net>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, "H. Peter Anvin" <hpa@zytor.com>,
	"x86@kernel.org" <x86@kernel.org>,
	Al Viro <viro@zeniv.linux.org.uk>,
	Nick Kralevich <nnk@google.com>,
	Jeffrey Vander Stoep <jeffv@google.com>,
	Daniel Cashman <dcashman@android.com>
Subject: [kernel-hardening] Re: [PATCH v2 1/7] random: Simplify API for random address requests
Date: Mon, 1 Aug 2016 23:17:23 +0000	[thread overview]
Message-ID: <20160801231723.GG4541@io.lakedaemon.net> (raw)
In-Reply-To: <CAGXu5jJVM=LXA10z06zVcFDSbf8s72HcOPRc_nUeuU7W=-3JWg@mail.gmail.com>

Hi Kees,

On Mon, Aug 01, 2016 at 12:47:59PM -0700, Kees Cook wrote:
> On Sun, Jul 31, 2016 at 1:56 PM, Jason Cooper <jason@lakedaemon.net> wrote:
> > On Sun, Jul 31, 2016 at 09:46:53AM -0700, Kees Cook wrote:
> >> On Sat, Jul 30, 2016 at 8:42 AM, Jason Cooper <jason@lakedaemon.net> wrote:
> >> > To date, all callers of randomize_range() have set the length to 0, and
> >> > check for a zero return value.  For the current callers, the only way
> >> > to get zero returned is if end <= start.  Since they are all adding a
> >> > constant to the start address, this is unnecessary.
> >> >
> >> > We can remove a bunch of needless checks by simplifying the API to do
> >> > just what everyone wants, return an address between [start, start +
> >> > range).
> >> >
> >> > While we're here, s/get_random_int/get_random_long/.  No current call
> >> > site is adversely affected by get_random_int(), since all current range
> >> > requests are < UINT_MAX.  However, we should match caller expectations
> >> > to avoid coming up short (ha!) in the future.
> >> >
> >> > All current callers to randomize_range() chose to use the start address
> >> > if randomize_range() failed.  Therefore, we simplify things by just
> >> > returning the start address on error.
> >> >
> >> > randomize_range() will be removed once all callers have been converted
> >> > over to randomize_addr().
> >> >
> >> > Signed-off-by: Jason Cooper <jason@lakedaemon.net>
> >> > ---
> >> > Changes from v1:
> >> >  - Explicitly mention page_aligned start assumption (Yann Droneaud)
> >> >  - pick random pages vice random addresses (Yann Droneaud)
> >> >  - catch range=0 last
> >> >
> >> >  drivers/char/random.c  | 28 ++++++++++++++++++++++++++++
> >> >  include/linux/random.h |  1 +
> >> >  2 files changed, 29 insertions(+)
> >> >
> >> > diff --git a/drivers/char/random.c b/drivers/char/random.c
> >> > index 0158d3bff7e5..3bedf69546d6 100644
> >> > --- a/drivers/char/random.c
> >> > +++ b/drivers/char/random.c
> >> > @@ -1840,6 +1840,34 @@ randomize_range(unsigned long start, unsigned long end, unsigned long len)
> >> >         return PAGE_ALIGN(get_random_int() % range + start);
> >> >  }
> >> >
> >> > +/**
> >> > + * randomize_addr - Generate a random, page aligned address
> >> > + * @start:     The smallest acceptable address the caller will take.
> >> > + * @range:     The size of the area, starting at @start, within which the
> >> > + *             random address must fall.
> >> > + *
> >> > + * If @start + @range would overflow, @range is capped.
> >> > + *
> >> > + * NOTE: Historical use of randomize_range, which this replaces, presumed that
> >> > + * @start was already page aligned.  This assumption still holds.
> >> > + *
> >> > + * Return: A page aligned address within [start, start + range).  On error,
> >> > + * @start is returned.
> >> > + */
> >> > +unsigned long
> >> > +randomize_addr(unsigned long start, unsigned long range)
> >>
> >> Since we're changing other things about this, let's try to document
> >> its behavior in its name too and call this "randomize_page" instead.
> >
> > Ack.  Definitely more accurate.
> >
> >> If it requires a page-aligned value, we should probably also BUG_ON
> >> it, or adjust the start too.
> >
> > merf.  So, this whole series started from a suggested cleanup by William
> > to s/get_random_int/get_random_long/.
> >
> > The current users have all been stable the way they are for a long time.
> > Like pre-git long.  So, if this is just a cleanup for those callers, I
> > don't think we need to do more than we already are.
> >
> > However, if the intent is for this function to see wider use, then by
> > all means, we need to handle start != PAGE_ALIGN(start).
> >
> > Do you have any new call sites in mind?
> 
> I have no new call sites in mind, but it seems safe to add a BUG_ON to
> verify we don't gain callers that don't follow the correct
> expectations. (Or maybe WARN and return start.)

No, I think BUG_ON is appropriate.  afaict, the only time this will be
encountered is during the development process.

thx,

Jason.

  reply	other threads:[~2016-08-01 23:17 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-07-28 20:47 [kernel-hardening] [PATCH 0/7] char/random: Simplify random address requests Jason Cooper
2016-07-28 20:47 ` [kernel-hardening] [PATCH 1/7] random: Simplify API for " Jason Cooper
2016-07-29  8:59   ` [kernel-hardening] " Yann Droneaud
2016-07-29 18:20     ` Jason Cooper
2016-07-28 20:47 ` [kernel-hardening] [PATCH 2/7] x86: Use simpler " Jason Cooper
2016-07-28 20:47 ` [kernel-hardening] [PATCH 3/7] ARM: " Jason Cooper
2016-07-28 20:47 ` [kernel-hardening] [PATCH 4/7] arm64: " Jason Cooper
2016-07-29 13:48   ` [kernel-hardening] " Will Deacon
2016-07-28 20:47 ` [kernel-hardening] [PATCH 5/7] tile: " Jason Cooper
2016-07-28 20:47 ` [kernel-hardening] [PATCH 6/7] unicore32: " Jason Cooper
2016-07-28 20:47 ` [kernel-hardening] [PATCH 7/7] random: Remove unused randomize_range() Jason Cooper
2016-07-30 15:42 ` [kernel-hardening] [PATCH v2 0/7] char/random: Simplify random address requests Jason Cooper
2016-07-30 15:42   ` [kernel-hardening] [PATCH v2 1/7] random: Simplify API for " Jason Cooper
2016-07-31 16:46     ` [kernel-hardening] " Kees Cook
2016-07-31 20:56       ` Jason Cooper
2016-08-01 19:47         ` Kees Cook
2016-08-01 23:17           ` Jason Cooper [this message]
2016-08-02  3:35             ` Michael Ellerman
2016-08-03 18:42               ` Jason Cooper
2016-07-30 15:42   ` [kernel-hardening] [PATCH v2 2/7] x86: Use simpler " Jason Cooper
2016-07-30 15:42   ` [kernel-hardening] [PATCH v2 3/7] ARM: " Jason Cooper
2016-07-30 15:42   ` [kernel-hardening] [PATCH v2 4/7] arm64: " Jason Cooper
2016-07-30 15:42   ` [kernel-hardening] [PATCH v2 5/7] tile: " Jason Cooper
2016-07-30 15:42   ` [kernel-hardening] [PATCH v2 6/7] unicore32: " Jason Cooper
2016-07-30 15:42   ` [kernel-hardening] [PATCH v2 7/7] random: Remove unused randomize_range() Jason Cooper
2016-08-03 23:39 ` [kernel-hardening] [PATCH v3 0/7] char/random: Simplify random address requests Jason Cooper
2016-08-03 23:39   ` [kernel-hardening] [PATCH v3 1/7] random: Simplify API for " Jason Cooper
2016-08-04 12:47     ` [kernel-hardening] " Yann Droneaud
2016-08-03 23:39   ` [kernel-hardening] [PATCH v3 2/7] x86: Use simpler " Jason Cooper
2016-08-03 23:39   ` [kernel-hardening] [PATCH v3 3/7] ARM: " Jason Cooper
2016-08-03 23:39   ` [kernel-hardening] [PATCH v3 4/7] arm64: " Jason Cooper
2016-08-03 23:39   ` [kernel-hardening] [PATCH v3 5/7] tile: " Jason Cooper
2016-08-03 23:39   ` [kernel-hardening] [PATCH v3 6/7] unicore32: " Jason Cooper
2016-08-03 23:39   ` [kernel-hardening] [PATCH v3 7/7] random: Remove unused randomize_range() Jason Cooper
2016-08-03 23:48     ` [kernel-hardening] " Andrew Morton
2016-08-04  0:19       ` Jason Cooper
2016-08-04  2:41   ` [kernel-hardening] Re: [PATCH v3 0/7] char/random: Simplify random address requests Kees Cook

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160801231723.GG4541@io.lakedaemon.net \
    --to=jason@lakedaemon.net \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=catalin.marinas@arm.com \
    --cc=davem@davemloft.net \
    --cc=dcashman@android.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hpa@zytor.com \
    --cc=jeffv@google.com \
    --cc=keescook@chromium.org \
    --cc=kernel-hardening@lists.openwall.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux@arm.linux.org.uk \
    --cc=mingo@redhat.com \
    --cc=mpe@ellerman.id.au \
    --cc=nnk@google.com \
    --cc=paulus@samba.org \
    --cc=ralf@linux-mips.org \
    --cc=tglx@linutronix.de \
    --cc=tytso@mit.edu \
    --cc=viro@zeniv.linux.org.uk \
    --cc=will.deacon@arm.com \
    --cc=william.c.roberts@intel.com \
    --cc=x86@kernel.org \
    --cc=ydroneaud@opteya.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).