kernel-janitors.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] memstick: r592: Change the name of the 'pci_driver' structure to be consistent
@ 2021-08-21 21:17 Christophe JAILLET
  2021-08-24 14:56 ` Ulf Hansson
  0 siblings, 1 reply; 2+ messages in thread
From: Christophe JAILLET @ 2021-08-21 21:17 UTC (permalink / raw)
  To: maximlevitsky, oakad, ulf.hansson
  Cc: linux-mmc, linux-kernel, kernel-janitors, Christophe JAILLET

This driver is all about r592.

Axe the reference to r852 in the 'pci_driver' structure name. This is
likely a copy/paste typo left as is when the driver has been created.

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
 drivers/memstick/host/r592.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/memstick/host/r592.c b/drivers/memstick/host/r592.c
index 7ed984360349..e79a0218c492 100644
--- a/drivers/memstick/host/r592.c
+++ b/drivers/memstick/host/r592.c
@@ -876,7 +876,7 @@ static SIMPLE_DEV_PM_OPS(r592_pm_ops, r592_suspend, r592_resume);
 
 MODULE_DEVICE_TABLE(pci, r592_pci_id_tbl);
 
-static struct pci_driver r852_pci_driver = {
+static struct pci_driver r592_pci_driver = {
 	.name		= DRV_NAME,
 	.id_table	= r592_pci_id_tbl,
 	.probe		= r592_probe,
@@ -884,7 +884,7 @@ static struct pci_driver r852_pci_driver = {
 	.driver.pm	= &r592_pm_ops,
 };
 
-module_pci_driver(r852_pci_driver);
+module_pci_driver(r592_pci_driver);
 
 module_param_named(enable_dma, r592_enable_dma, bool, S_IRUGO);
 MODULE_PARM_DESC(enable_dma, "Enable usage of the DMA (default)");
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] memstick: r592: Change the name of the 'pci_driver' structure to be consistent
  2021-08-21 21:17 [PATCH] memstick: r592: Change the name of the 'pci_driver' structure to be consistent Christophe JAILLET
@ 2021-08-24 14:56 ` Ulf Hansson
  0 siblings, 0 replies; 2+ messages in thread
From: Ulf Hansson @ 2021-08-24 14:56 UTC (permalink / raw)
  To: Christophe JAILLET
  Cc: Maxim Levitsky, Alex Dubov, linux-mmc, Linux Kernel Mailing List,
	kernel-janitors

On Sat, 21 Aug 2021 at 23:17, Christophe JAILLET
<christophe.jaillet@wanadoo.fr> wrote:
>
> This driver is all about r592.
>
> Axe the reference to r852 in the 'pci_driver' structure name. This is
> likely a copy/paste typo left as is when the driver has been created.
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>

Applied for next, thanks!

Kind regards
Uffe


> ---
>  drivers/memstick/host/r592.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/memstick/host/r592.c b/drivers/memstick/host/r592.c
> index 7ed984360349..e79a0218c492 100644
> --- a/drivers/memstick/host/r592.c
> +++ b/drivers/memstick/host/r592.c
> @@ -876,7 +876,7 @@ static SIMPLE_DEV_PM_OPS(r592_pm_ops, r592_suspend, r592_resume);
>
>  MODULE_DEVICE_TABLE(pci, r592_pci_id_tbl);
>
> -static struct pci_driver r852_pci_driver = {
> +static struct pci_driver r592_pci_driver = {
>         .name           = DRV_NAME,
>         .id_table       = r592_pci_id_tbl,
>         .probe          = r592_probe,
> @@ -884,7 +884,7 @@ static struct pci_driver r852_pci_driver = {
>         .driver.pm      = &r592_pm_ops,
>  };
>
> -module_pci_driver(r852_pci_driver);
> +module_pci_driver(r592_pci_driver);
>
>  module_param_named(enable_dma, r592_enable_dma, bool, S_IRUGO);
>  MODULE_PARM_DESC(enable_dma, "Enable usage of the DMA (default)");
> --
> 2.30.2
>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-08-24 14:57 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-21 21:17 [PATCH] memstick: r592: Change the name of the 'pci_driver' structure to be consistent Christophe JAILLET
2021-08-24 14:56 ` Ulf Hansson

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).