Kernel Newbies archive on lore.kernel.org
 help / color / Atom feed
* Unable to manually bind driver
@ 2020-07-22 18:23 Isaac
  0 siblings, 0 replies; only message in thread
From: Isaac @ 2020-07-22 18:23 UTC (permalink / raw)
  To: kernelnewbies

[-- Attachment #1.1: Type: text/plain, Size: 1082 bytes --]

Hello everyone,
I'm currently going through the task 05 of the eudalypta challenge. I
thought my implementation didn't work, so I tried testing a a person's
solution on github
<https://github.com/agelastic/eudyptula/tree/master/task5>. However, I am
still unable to manually bind the USB device to my driver. Here are the
steps I did.

1) Use* lsusb -t *to find the bus and port USB device was connected on. It
was *1-3*.
2) Went to *sys/bus/usb/devices* and found that *1-3 *was bound to
*drivers/usb* using *tree*.
3) Used *echo 1-3 > unbind* to unbind it.
4) Went to *devices* folder and checked if it was still bound. It was not.
5) Went to the directory of my own driver, named *hello_driver*.
6) Tried to do *echo 1-3 > bind* but got the error message *echo: write
error: No such device*.

These instructions are based on LWN.net Manual driver binding and unbinding
<https://lwn.net/Articles/143397/>. One suspicion I have is that this
simple USB driver doesn't support the USB device I am plugging in (a USB
flash drive). I actually have no idea.

Many thanks for your help.

[-- Attachment #1.2: Type: text/html, Size: 1395 bytes --]

[-- Attachment #2: Type: text/plain, Size: 170 bytes --]

_______________________________________________
Kernelnewbies mailing list
Kernelnewbies@kernelnewbies.org
https://lists.kernelnewbies.org/mailman/listinfo/kernelnewbies

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-22 18:23 Unable to manually bind driver Isaac

Kernel Newbies archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/kernelnewbies/0 kernelnewbies/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 kernelnewbies kernelnewbies/ https://lore.kernel.org/kernelnewbies \
		kernelnewbies@kernelnewbies.org
	public-inbox-index kernelnewbies

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernelnewbies.kernelnewbies


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git