kvm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling
@ 2021-03-15 15:33 Andre Przywara
  2021-03-15 15:33 ` [PATCH kvmtool v3 01/22] ioport: Remove ioport__setup_arch() Andre Przywara
                   ` (23 more replies)
  0 siblings, 24 replies; 28+ messages in thread
From: Andre Przywara @ 2021-03-15 15:33 UTC (permalink / raw)
  To: Will Deacon, Julien Thierry
  Cc: Alexandru Elisei, kvm, kvmarm, Marc Zyngier, Sami Mujawar

Hi,

this version is addressing Alexandru's comments, fixing mostly minor
issues in the naming scheme. The biggest change is to keep the
ioport__read/ioport_write wrappers for the serial device.
For more details see the changelog below.
==============

At the moment we use two separate code paths to handle exits for
KVM_EXIT_IO (ioport.c) and KVM_EXIT_MMIO (mmio.c), even though they
are semantically very similar. Because the trap handler callback routine
is different, devices need to decide on one conduit or need to provide
different handler functions for both of them.

This is not only unnecessary code duplication, but makes switching
devices from I/O port to MMIO a tedious task, even though there is no
real difference between the two, especially on ARM and PowerPC.

For ARM we aim at providing a flexible memory layout, and also have
trouble with the UART and RTC device overlapping with the PCI I/O area,
so it seems indicated to tackle this once and for all.

The first three patches do some cleanup, to simplify things later.

Patch 04/22 lays the groundwork, by extending mmio.c to be able to also
register I/O port trap handlers, using the same callback prototype as
we use for MMIO.

The next 14 patches then convert devices that use the I/O port
interface over to the new joint interface. This requires to rework
the trap handler routine to adhere to the same prototype as the existing
MMIO handlers. For most devices this is done in two steps: a first to
introduce the reworked handler routine, and a second to switch to the new
joint registration routine. For some devices the first step is trivial,
so it's done in one patch.

Patch 19/22 then retires the old I/O port interface, by removing ioport.c
and friends.
Patch 20/22 uses the opportunity to clean up the memory map description,
also declares a new region (from 16MB on), where the final two patches
switch the UART and the RTC device to. They are now registered
on the MMIO "bus", when running on ARM or arm64. This moves them away
from the first 64KB, so they are not in the PCI I/O area anymore.

Please have a look and comment!

Cheers,
Andre

Changelog v2 .. v3:
- use _io as function prefix for x86 I/O port devices
- retain ioport__{read,write}8() wrappers for serial device
- fix memory map ASCII art
- fix serial base declaration
- minor nit fixes
- add Reviewed-by: tags

Changelog v1 .. v2:
- rework memory map definition
- add explicit debug output for debug I/O port
- add explicit check for MMIO coalescing on I/O ports
- drop usage of ioport__{read,write}8() from serial
- drop explicit I/O port cleanup routine (to mimic MMIO operation)
- add comment for IOTRAP_BUS_MASK
- minor cleanups / formatting changes


Andre Przywara (22):
  ioport: Remove ioport__setup_arch()
  hw/serial: Use device abstraction for FDT generator function
  ioport: Retire .generate_fdt_node functionality
  mmio: Extend handling to include ioport emulation
  hw/i8042: Clean up data types
  hw/i8042: Refactor trap handler
  hw/i8042: Switch to new trap handlers
  x86/ioport: Refactor trap handlers
  x86/ioport: Switch to new trap handlers
  hw/rtc: Refactor trap handlers
  hw/rtc: Switch to new trap handler
  hw/vesa: Switch trap handling to use MMIO handler
  hw/serial: Refactor trap handler
  hw/serial: Switch to new trap handlers
  vfio: Refactor ioport trap handler
  vfio: Switch to new ioport trap handlers
  virtio: Switch trap handling to use MMIO handler
  pci: Switch trap handling to use MMIO handler
  Remove ioport specific routines
  arm: Reorganise and document memory map
  hw/serial: ARM/arm64: Use MMIO at higher addresses
  hw/rtc: ARM/arm64: Use MMIO at higher addresses

 Makefile                          |   1 -
 arm/include/arm-common/kvm-arch.h |  47 ++++--
 arm/ioport.c                      |   5 -
 hw/i8042.c                        |  94 +++++-------
 hw/rtc.c                          |  91 ++++++------
 hw/serial.c                       | 126 +++++++++++-----
 hw/vesa.c                         |  19 +--
 include/kvm/i8042.h               |   1 -
 include/kvm/ioport.h              |  32 ----
 include/kvm/kvm.h                 |  49 ++++++-
 ioport.c                          | 235 ------------------------------
 mips/kvm.c                        |   5 -
 mmio.c                            |  65 +++++++--
 pci.c                             |  82 +++--------
 powerpc/ioport.c                  |   6 -
 vfio/core.c                       |  50 ++++---
 virtio/pci.c                      |  46 ++----
 x86/ioport.c                      | 108 +++++++-------
 18 files changed, 421 insertions(+), 641 deletions(-)
 delete mode 100644 ioport.c

-- 
2.17.5


^ permalink raw reply	[flat|nested] 28+ messages in thread

end of thread, other threads:[~2021-03-18 10:05 UTC | newest]

Thread overview: 28+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-03-15 15:33 [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 01/22] ioport: Remove ioport__setup_arch() Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 02/22] hw/serial: Use device abstraction for FDT generator function Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 03/22] ioport: Retire .generate_fdt_node functionality Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 04/22] mmio: Extend handling to include ioport emulation Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 05/22] hw/i8042: Clean up data types Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 06/22] hw/i8042: Refactor trap handler Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 07/22] hw/i8042: Switch to new trap handlers Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 08/22] x86/ioport: Refactor " Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 09/22] x86/ioport: Switch to new " Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 10/22] hw/rtc: Refactor " Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 11/22] hw/rtc: Switch to new trap handler Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 12/22] hw/vesa: Switch trap handling to use MMIO handler Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 13/22] hw/serial: Refactor trap handler Andre Przywara
2021-03-16 15:40   ` Alexandru Elisei
2021-03-15 15:33 ` [PATCH kvmtool v3 14/22] hw/serial: Switch to new trap handlers Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 15/22] vfio: Refactor ioport trap handler Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 16/22] vfio: Switch to new ioport trap handlers Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 17/22] virtio: Switch trap handling to use MMIO handler Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 18/22] pci: " Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 19/22] Remove ioport specific routines Andre Przywara
2021-03-15 15:33 ` [PATCH kvmtool v3 20/22] arm: Reorganise and document memory map Andre Przywara
2021-03-17 15:17   ` Alexandru Elisei
2021-03-15 15:33 ` [PATCH kvmtool v3 21/22] hw/serial: ARM/arm64: Use MMIO at higher addresses Andre Przywara
2021-03-17 16:17   ` Alexandru Elisei
2021-03-15 15:33 ` [PATCH kvmtool v3 22/22] hw/rtc: " Andre Przywara
2021-03-17 17:44 ` [PATCH kvmtool v3 00/22] Unify I/O port and MMIO trap handling Alexandru Elisei
2021-03-18 10:04 ` Will Deacon

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).