kvm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [kvm-unit-tests PATCH] s390x/cpumodel: give each test a unique output line
@ 2021-12-01 16:09 Christian Borntraeger
  2021-12-02  8:13 ` Thomas Huth
  0 siblings, 1 reply; 2+ messages in thread
From: Christian Borntraeger @ 2021-12-01 16:09 UTC (permalink / raw)
  To: kvm, Claudio Imbrenda, Janosch Frank, Thomas Huth; +Cc: Christian Borntraeger

Until now we had multiple tests running under the same prefix. This can
result in multiple identical lines like
SKIP: cpumodel: dependency: facility 5 not present
SKIP: cpumodel: dependency: facility 5 not present

Make this unique by adding a proper prefix.

Signed-off-by: Christian Borntraeger <borntraeger@linux.ibm.com>
---
 s390x/cpumodel.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/s390x/cpumodel.c b/s390x/cpumodel.c
index 67bb6543f4a8..12bc82c1d0ec 100644
--- a/s390x/cpumodel.c
+++ b/s390x/cpumodel.c
@@ -116,14 +116,15 @@ int main(void)
 
 	report_prefix_push("dependency");
 	for (i = 0; i < ARRAY_SIZE(dep); i++) {
+		report_prefix_pushf("%d implies %d", dep[i].facility, dep[i].implied);
 		if (test_facility(dep[i].facility)) {
 			report_xfail(dep[i].expected_tcg_fail && vm_is_tcg(),
 				     test_facility(dep[i].implied),
-				     "%d implies %d",
-				     dep[i].facility, dep[i].implied);
+				     "but not available");
 		} else {
 			report_skip("facility %d not present", dep[i].facility);
 		}
+		report_prefix_pop();
 	}
 	report_prefix_pop();
 
-- 
2.31.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [kvm-unit-tests PATCH] s390x/cpumodel: give each test a unique output line
  2021-12-01 16:09 [kvm-unit-tests PATCH] s390x/cpumodel: give each test a unique output line Christian Borntraeger
@ 2021-12-02  8:13 ` Thomas Huth
  0 siblings, 0 replies; 2+ messages in thread
From: Thomas Huth @ 2021-12-02  8:13 UTC (permalink / raw)
  To: Christian Borntraeger, kvm, Claudio Imbrenda, Janosch Frank

On 01/12/2021 17.09, Christian Borntraeger wrote:
> Until now we had multiple tests running under the same prefix. This can
> result in multiple identical lines like
> SKIP: cpumodel: dependency: facility 5 not present
> SKIP: cpumodel: dependency: facility 5 not present
> 
> Make this unique by adding a proper prefix.
> 
> Signed-off-by: Christian Borntraeger <borntraeger@linux.ibm.com>
> ---
>   s390x/cpumodel.c | 5 +++--
>   1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/s390x/cpumodel.c b/s390x/cpumodel.c
> index 67bb6543f4a8..12bc82c1d0ec 100644
> --- a/s390x/cpumodel.c
> +++ b/s390x/cpumodel.c
> @@ -116,14 +116,15 @@ int main(void)
>   
>   	report_prefix_push("dependency");
>   	for (i = 0; i < ARRAY_SIZE(dep); i++) {
> +		report_prefix_pushf("%d implies %d", dep[i].facility, dep[i].implied);
>   		if (test_facility(dep[i].facility)) {
>   			report_xfail(dep[i].expected_tcg_fail && vm_is_tcg(),
>   				     test_facility(dep[i].implied),
> -				     "%d implies %d",
> -				     dep[i].facility, dep[i].implied);
> +				     "but not available");

<bikeshedding>
Maybe rather something like "implication not correct" or so?
</bikeshedding>

>   		} else {
>   			report_skip("facility %d not present", dep[i].facility);
>   		}
> +		report_prefix_pop();
>   	}
>   	report_prefix_pop();
>   
> 

Reviewed-by: Thomas Huth <thuth@redhat.com>


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-12-02  8:13 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-01 16:09 [kvm-unit-tests PATCH] s390x/cpumodel: give each test a unique output line Christian Borntraeger
2021-12-02  8:13 ` Thomas Huth

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).