linux-arch.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-08-04 11:47:48 to 2020-08-18 15:07:46 UTC [more...]

Flushing transparent hugepages
 2020-08-18 15:07 UTC 

[PATCH v4 0/6] mm: introduce memfd_secret system call to create "secret" memory areas
 2020-08-18 14:15 UTC  (7+ messages)
` [PATCH v4 1/6] mm: add definition of PMD_PAGE_ORDER
` [PATCH v4 2/6] mmap: make mlock_future_check() global
` [PATCH v4 3/6] mm: introduce memfd_secret system call to create "secret" memory areas
` [PATCH v4 4/6] arch, mm: wire up memfd_secret system call were relevant
` [PATCH v4 5/6] mm: secretmem: use PMD-size pages to amortize direct map fragmentation
` [PATCH v4 6/6] mm: secretmem: add ability to reserve memory at boot

[PATCH] bitops, kcsan: Partially revert instrumentation for non-atomic bitops
 2020-08-18  8:34 UTC  (2+ messages)

[PATCH 1/2] lockdep: improve current->(hard|soft)irqs_enabled synchronisation with actual irq state
 2020-08-18  7:22 UTC  (5+ messages)

[PATCH v5 00/36] Warn on orphan section placement
 2020-08-17 22:06 UTC  (14+ messages)
` [PATCH v5 06/36] x86/boot: Remove run-time relocations from head_{32,64}.S
` [PATCH v5 13/36] vmlinux.lds.h: add PGO and AutoFDO input sections
` [PATCH v5 23/36] arm/build: Explicitly keep .ARM.attributes sections

remove the last set_fs() in common code, and remove it for x86 and powerpc
 2020-08-17 15:47 UTC  (17+ messages)
` [PATCH 01/11] mem: remove duplicate ops for /dev/zero and /dev/null
` [PATCH 02/11] fs: don't allow kernel reads and writes without iter ops
` [PATCH 03/11] fs: don't allow splice read/write without explicit ops
` [PATCH 04/11] uaccess: add infrastructure for kernel builds with set_fs()
` [PATCH 05/11] test_bitmap: skip user bitmap tests for !CONFIG_SET_FS
` [PATCH 06/11] lkdtm: disable set_fs-based "
` [PATCH 07/11] x86: move PAGE_OFFSET, TASK_SIZE & friends to page_{32,64}_types.h
` [PATCH 08/11] x86: make TASK_SIZE_MAX usable from assembly code
` [PATCH 09/11] x86: remove address space overrides using set_fs()
` [PATCH 10/11] powerpc: use non-set_fs based maccess routines
` [PATCH 11/11] powerpc: remove address space overrides using set_fs()

[PATCH v4 0/8] huge vmalloc mappings
 2020-08-17 13:23 UTC  (10+ messages)
` [PATCH v4 1/8] mm/vmalloc: fix vmalloc_to_page for huge vmap mappings
` [PATCH v4 2/8] mm: apply_to_pte_range warn and fail if a large pte is encountered
` [PATCH v4 3/8] mm/vmalloc: rename vmap_*_range vmap_pages_*_range
` [PATCH v4 4/8] lib/ioremap: rename ioremap_*_range to vmap_*_range
` [PATCH v4 5/8] mm: HUGE_VMAP arch support cleanup
` [PATCH v4 6/8] mm: Move vmap_range from lib/ioremap.c to mm/vmalloc.c
` [PATCH v4 7/8] mm/vmalloc: add vmap_range_noflush variant
` [PATCH v4 8/8] mm/vmalloc: Hugepage vmalloc mappings

[TECH TOPIC] Planning code obsolescence
 2020-08-16 12:53 UTC  (8+ messages)
  ` [Ksummit-discuss] "

[RFC/RFT PATCH 0/6] Unify NUMA implementation between ARM64 & RISC-V
 2020-08-14 23:21 UTC  (9+ messages)
` [RFC/RFT PATCH 1/6] numa: Move numa implementation to common code
` [RFC/RFT PATCH 2/6] arm64, numa: Change the numa init function name to be generic
` [RFC/RFT PATCH 3/6] arm64, numa: Move pcibus_to_node definition to generic numa code
` [RFC/RFT PATCH 4/6] riscv: Separate memory init from paging init
` [RFC/RFT PATCH 5/6] riscv: Add support pte_protnone and pmd_protnone if CONFIG_NUMA_BALANCING
` [RFC/RFT PATCH 6/6] riscv: Add numa support for riscv64 platform

[PATCH 0/8] kcsan: Compound read-write instrumentation
 2020-08-14 12:34 UTC  (8+ messages)
` [PATCH 8/8] locking/atomics: Use read-write instrumentation for atomic RMWs

[PATCH v20 00/12] Landlock LSM
 2020-08-13 20:29 UTC  (7+ messages)
` [PATCH v20 05/12] LSM: Infrastructure management of the superblock
` [PATCH v20 08/12] landlock: Add syscall implementations

[PATCH v7 00/26] arm64: Memory Tagging Extension user-space support
 2020-08-13 14:01 UTC  (18+ messages)
` [PATCH v7 18/29] arm64: mte: Allow user control of the tag check mode via prctl()
` [PATCH v7 22/29] arm64: mte: ptrace: Add PTRACE_{PEEK,POKE}MTETAGS support
` [PATCH v7 29/29] arm64: mte: Add Memory Tagging Extension documentation

INFO: task hung in pipe_release (2)
 2020-08-13  3:57 UTC 

[PATCH 1/2 v3] rseq/membarrier: add MEMBARRIER_CMD_PRIVATE_EXPEDITED_RSEQ
 2020-08-12 19:44 UTC 

[PATCH v3 0/8] huge vmalloc mappings
 2020-08-12 16:18 UTC  (19+ messages)
` [PATCH v3 1/8] mm/vmalloc: fix vmalloc_to_page for huge vmap mappings
` [PATCH v3 2/8] mm: apply_to_pte_range warn and fail if a large pte is encountered
` [PATCH v3 3/8] mm/vmalloc: rename vmap_*_range vmap_pages_*_range
` [PATCH v3 4/8] lib/ioremap: rename ioremap_*_range to vmap_*_range
` [PATCH v3 5/8] mm: HUGE_VMAP arch support cleanup
` [PATCH v3 6/8] mm: Move vmap_range from lib/ioremap.c to mm/vmalloc.c
` [PATCH v3 7/8] mm/vmalloc: add vmap_range_noflush variant
` [PATCH v3 8/8] mm/vmalloc: Hugepage vmalloc mappings

Dear Friend,
 2020-08-11 19:52 UTC 

[RFC][PATCHSET] regset ->get() rework
 2020-08-11 18:35 UTC  (5+ messages)
` [PATCH 01/41] introduction of regset ->get() wrappers, switching ELF coredumps to those
  ` [PATCH 33/41] hexagon: switch to ->get2()

[PATCH 00/24] Use asm-generic for mmu_context no-op functions
 2020-08-11 18:34 UTC  (4+ messages)
` [PATCH 07/24] hexagon: use asm-generic/mmu_context.h for no-op implementations

[PATCH] sections.h: dereference_function_descriptor() returns void pointer
 2020-08-11 10:30 UTC 

[git pull] fdpic coredump stuff
 2020-08-07 20:39 UTC  (2+ messages)

[PATCH 4/7] dyndbg: split struct _ddebug in 2, creating _ddebug_callsite
 2020-08-07 20:09 UTC 

[git pull] regset work
 2020-08-07 17:48 UTC  (2+ messages)

improve compat handling for the i386 u64 alignment quirk v2
 2020-08-07  9:38 UTC  (10+ messages)
` [PATCH 3/3] quota: simplify the quotactl compat handling

[PATCH v8 0/8] powerpc: switch VDSO to C implementation
 2020-08-07  2:44 UTC  (11+ messages)
` [PATCH v8 5/8] powerpc/vdso: Prepare for switching VDSO to generic "

[PATCH 04/22] kbuild: lto: fix recordmcount
 2020-08-06 22:09 UTC  (11+ messages)
  ` [RFC][PATCH] objtool,x86_64: Replace recordmcount with objtool

[GIT PULL] csky updates for v5.9-rc1
 2020-08-06 17:20 UTC  (3+ messages)

[PATCH v3 0/6] mm: introduce memfd_secret system call to create "secret" memory areas
 2020-08-06 11:14 UTC  (9+ messages)
` [PATCH v3 1/6] mm: add definition of PMD_PAGE_ORDER
` [PATCH v3 3/6] mm: introduce memfd_secret system call to create "secret" memory areas

[PATCH v10 0/5] powerpc: switch VDSO to C implementation
 2020-08-06  5:46 UTC  (18+ messages)
` [PATCH v10 1/5] powerpc/processor: Move cpu_relax() into asm/vdso/processor.h
` [PATCH v10 2/5] powerpc/vdso: Prepare for switching VDSO to generic C implementation
` [PATCH v10 3/5] powerpc/vdso: Save and restore TOC pointer on PPC64
` [PATCH v10 4/5] powerpc/vdso: Switch VDSO to generic C implementation
` [PATCH v10 5/5] powerpc/vdso: Provide __kernel_clock_gettime64() on vdso32

[PATCH v2 00/17] memblock: seasonal cleaning^w cleanup
 2020-08-05 17:11 UTC  (24+ messages)
` [PATCH v2 01/17] KVM: PPC: Book3S HV: simplify kvm_cma_reserve()
` [PATCH v2 02/17] dma-contiguous: simplify cma_early_percent_memory()
` [PATCH v2 11/17] arch, mm: replace for_each_memblock() with for_each_mem_pfn_range()
` [PATCH v2 12/17] arch, drivers: replace for_each_membock() with for_each_mem_range()
` [PATCH v2 13/17] x86/setup: simplify initrd relocation and reservation
` [PATCH v2 14/17] x86/setup: simplify reserve_crashkernel()
` [PATCH v2 15/17] memblock: remove unused memblock_mem_size()
` [PATCH v2 16/17] memblock: implement for_each_reserved_mem_region() using __next_mem_region()
` [PATCH v2 17/17] memblock: use separate iterators for memory and reserved regions

[PATCH v6 0/5] kunit: create a centralized executor to dispatch all KUnit tests
 2020-08-05  6:01 UTC  (10+ messages)
` [PATCH v6 1/5] vmlinux.lds.h: add linker section for KUnit test suites
` [PATCH v6 2/5] kunit: test: create a single centralized executor for all tests
` [PATCH v6 3/5] init: main: add KUnit to kernel init
` [PATCH v6 4/5] kunit: test: add test plan to KUnit TAP format
` [PATCH v6 5/5] Documentation: kunit: add a brief blurb about kunit_test_suite

RE:PERSONAL LETTER FROM MRS RASHIA AMIRA
 2019-10-07 18:22 UTC 

[PATCH v5 00/12] kunit: create a centralized executor to dispatch all KUnit tests
 2020-08-04 20:18 UTC  (22+ messages)
` [PATCH v5 01/12] vmlinux.lds.h: add linker section for KUnit test suites
` [PATCH v5 07/12] kunit: test: create a single centralized executor for all tests
` [PATCH v5 09/12] kunit: test: add test plan to KUnit TAP format
` [PATCH v5 10/12] kunit: Add 'kunit_shutdown' option

[PATCH v3 0/2] prctl.2 man page updates for Linux 5.6
 2020-08-04 12:52 UTC  (6+ messages)

[PATCH v9 0/5] powerpc: switch VDSO to C implementation
 2020-08-04 11:47 UTC  (10+ messages)
` [PATCH v9 1/5] powerpc/processor: Move cpu_relax() into asm/vdso/processor.h
` [PATCH v9 2/5] powerpc/vdso: Prepare for switching VDSO to generic C implementation
` [PATCH v9 3/5] powerpc/vdso: Save and restore TOC pointer on PPC64
` [PATCH v9 4/5] powerpc/vdso: Switch VDSO to generic C implementation
` [PATCH v9 5/5] powerpc/vdso: Provide __kernel_clock_gettime64() on vdso32


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).