linux-arch.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-08-18 15:07:46 to 2020-08-21 20:14:25 UTC [more...]

[PATCH v6 00/12] huge vmalloc mappings
 2020-08-21 20:14 UTC  (17+ messages)
` [PATCH v6 01/12] mm/vmalloc: fix vmalloc_to_page for huge vmap mappings
` [PATCH v6 02/12] mm: apply_to_pte_range warn and fail if a large pte is encountered
` [PATCH v6 03/12] mm/vmalloc: rename vmap_*_range vmap_pages_*_range
` [PATCH v6 04/12] mm/ioremap: rename ioremap_*_range to vmap_*_range
` [PATCH v6 05/12] mm: HUGE_VMAP arch support cleanup
` [PATCH v6 06/12] powerpc: inline huge vmap supported functions
` [PATCH v6 07/12] arm64: "
` [PATCH v6 08/12] x86: "
` [PATCH v6 09/12] mm: Move vmap_range from mm/ioremap.c to mm/vmalloc.c
` [PATCH v6 10/12] mm/vmalloc: add vmap_range_noflush variant
` [PATCH v6 11/12] mm/vmalloc: Hugepage vmalloc mappings
` [PATCH v6 12/12] powerpc/64s/radix: Enable huge "

[PATCH v6 00/29] Warn on orphan section placement
 2020-08-21 20:01 UTC  (31+ messages)
` [PATCH v6 01/29] vmlinux.lds.h: Create COMMON_DISCARDS
` [PATCH v6 02/29] vmlinux.lds.h: Add .gnu.version* to COMMON_DISCARDS
` [PATCH v6 03/29] vmlinux.lds.h: Avoid KASAN and KCSAN's unwanted sections
` [PATCH v6 04/29] vmlinux.lds.h: Split ELF_DETAILS from STABS_DEBUG
` [PATCH v6 05/29] vmlinux.lds.h: Add .symtab, .strtab, and .shstrtab to ELF_DETAILS
` [PATCH v6 06/29] vmlinux.lds.h: add PGO and AutoFDO input sections
` [PATCH v6 07/29] efi/libstub: Disable -mbranch-protection
` [PATCH v6 08/29] arm64/mm: Remove needless section quotes
` [PATCH v6 09/29] arm64/kernel: Remove needless Call Frame Information annotations
` [PATCH v6 10/29] arm64/build: Remove .eh_frame* sections due to unwind tables
` [PATCH v6 11/29] arm64/build: Use common DISCARDS in linker script
` [PATCH v6 12/29] arm64/build: Add missing DWARF sections
` [PATCH v6 13/29] arm64/build: Assert for unwanted sections
` [PATCH v6 14/29] arm64/build: Warn on orphan section placement
` [PATCH v6 15/29] arm/build: Refactor linker script headers
` [PATCH v6 16/29] arm/build: Explicitly keep .ARM.attributes sections
` [PATCH v6 17/29] arm/build: Add missing sections
` [PATCH v6 18/29] arm/build: Assert for unwanted sections
` [PATCH v6 19/29] arm/build: Warn on orphan section placement
` [PATCH v6 20/29] arm/boot: Handle all sections explicitly
` [PATCH v6 21/29] arm/boot: Warn on orphan section placement
` [PATCH v6 22/29] x86/asm: Avoid generating unused kprobe sections
` [PATCH v6 23/29] x86/build: Enforce an empty .got.plt section
` [PATCH v6 24/29] x86/build: Assert for unwanted sections
` [PATCH v6 25/29] x86/build: Warn on orphan section placement
` [PATCH v6 26/29] x86/boot/compressed: Reorganize zero-size section asserts
` [PATCH v6 27/29] x86/boot/compressed: Remove, discard, or assert for unwanted sections
` [PATCH v6 28/29] x86/boot/compressed: Add missing debugging sections to output
` [PATCH v6 29/29] x86/boot/compressed: Warn on orphan section placement

[PATCH v5 00/36] Warn on orphan section placement
 2020-08-21 19:18 UTC  (18+ messages)
` [PATCH v5 13/36] vmlinux.lds.h: add PGO and AutoFDO input sections
` [PATCH v5 29/36] x86/build: Enforce an empty .got.plt section
` [PATCH v5 32/36] x86/boot/compressed: Reorganize zero-size section asserts

[PATCH v4 00/17] Warn on orphan section placement
 2020-08-21 17:36 UTC  (3+ messages)

[PATCHv2] PCI: Add pci_iounmap
 2020-08-21 16:58 UTC 

[PATCH 0/3] add fault injection to user memory access functions
 2020-08-21 13:31 UTC  (7+ messages)
` [PATCH 1/3] lib, include/linux: add usercopy failure capability
` [PATCH 2/3] lib, uaccess: add failure injection to usercopy functions
` [PATCH 3/3] x86: add failure injection to get/put/clear_user

[PATCH v5 0/8] huge vmalloc mappings
 2020-08-21 12:43 UTC  (21+ messages)
` [PATCH v5 1/8] mm/vmalloc: fix vmalloc_to_page for huge vmap mappings
` [PATCH v5 2/8] mm: apply_to_pte_range warn and fail if a large pte is encountered
` [PATCH v5 3/8] mm/vmalloc: rename vmap_*_range vmap_pages_*_range
` [PATCH v5 4/8] lib/ioremap: rename ioremap_*_range to vmap_*_range
` [PATCH v5 5/8] mm: HUGE_VMAP arch support cleanup
` [PATCH v5 6/8] mm: Move vmap_range from lib/ioremap.c to mm/vmalloc.c
` [PATCH v5 7/8] mm/vmalloc: add vmap_range_noflush variant
` [PATCH v5 8/8] mm/vmalloc: Hugepage vmalloc mappings

[PATCH v2 00/13] mm/debug_vm_pgtable fixes
 2020-08-21  8:51 UTC 

[REGRESSION] x86/entry: Tracer no longer has opportunity to change the syscall number at entry via orig_ax
 2020-08-21  0:35 UTC  (5+ messages)

[PATCHv2] PCI: Add pci_iounmap
 2020-08-20 21:55 UTC  (2+ messages)

[PATCH 1/2 v3] rseq/membarrier: add MEMBARRIER_CMD_PRIVATE_EXPEDITED_RSEQ
 2020-08-20 17:42 UTC  (2+ messages)

[PATCH v7 29/29] arm64: mte: Add Memory Tagging Extension documentation
 2020-08-20 17:27 UTC  (13+ messages)

[PATCH v4 0/6] mm: introduce memfd_secret system call to create "secret" memory areas
 2020-08-20 15:52 UTC  (11+ messages)
` [PATCH v4 6/6] mm: secretmem: add ability to reserve memory at boot

[RFC/RFT PATCH 0/6] Unify NUMA implementation between ARM64 & RISC-V
 2020-08-20  3:20 UTC  (5+ messages)
` [RFC/RFT PATCH 1/6] numa: Move numa implementation to common code

[PATCH] PCI: Add pci_iounmap
 2020-08-19 21:46 UTC  (3+ messages)

[PATCH v3 00/17] memblock: seasonal cleaning^w cleanup
 2020-08-19 20:48 UTC  (21+ messages)
` [PATCH v3 01/17] KVM: PPC: Book3S HV: simplify kvm_cma_reserve()
` [PATCH v3 02/17] dma-contiguous: simplify cma_early_percent_memory()
` [PATCH v3 03/17] arm, xtensa: simplify initialization of high memory pages
` [PATCH v3 04/17] arm64: numa: simplify dummy_numa_init()
` [PATCH v3 05/17] h8300, nds32, openrisc: simplify detection of memory extents
` [PATCH v3 06/17] riscv: drop unneeded node initialization
` [PATCH v3 07/17] mircoblaze: drop unneeded NUMA and sparsemem initializations
` [PATCH v3 08/17] memblock: make for_each_memblock_type() iterator private
` [PATCH v3 09/17] memblock: make memblock_debug and related functionality private
` [PATCH v3 10/17] memblock: reduce number of parameters in for_each_mem_range()
` [PATCH v3 11/17] arch, mm: replace for_each_memblock() with for_each_mem_pfn_range()
` [PATCH v3 12/17] arch, drivers: replace for_each_membock() with for_each_mem_range()
` [PATCH v3 13/17] x86/setup: simplify initrd relocation and reservation
` [PATCH v3 14/17] x86/setup: simplify reserve_crashkernel()
` [PATCH v3 15/17] memblock: remove unused memblock_mem_size()
` [PATCH v3 16/17] memblock: implement for_each_reserved_mem_region() using __next_mem_region()
` [PATCH v3 17/17] memblock: use separate iterators for memory and reserved regions

[PATCH v2 00/11] Introduce kernel_clone(), kill _do_fork()
 2020-08-19 20:02 UTC  (14+ messages)
` [PATCH v2 01/11] fork: introduce kernel_clone()
` [PATCH v2 02/11] h8300: switch to kernel_clone()
` [PATCH v2 03/11] ia64: "
` [PATCH v2 04/11] m68k: "
` [PATCH v2 05/11] nios2: "
` [PATCH v2 06/11] sparc: "
` [PATCH v2 07/11] x86: "
` [PATCH v2 08/11] kprobes: "
` [PATCH v2 09/11] kgdbts: "
` [PATCH v2 10/11] tracing: "
` [PATCH v2 11/11] sched: remove _do_fork()

[PATCH 00/11] Introduce kernel_clone(), kill _do_fork()
 2020-08-19 16:24 UTC  (25+ messages)
` [PATCH 01/11] fork: introduce kernel_clone()
` [PATCH 02/11] h8300: switch to kernel_clone()
` [PATCH 03/11] ia64: "
` [PATCH 04/11] m68k: "
` [PATCH 05/11] nios2: "
` [PATCH 06/11] sparc: "
` [PATCH 07/11] x86: "
` [PATCH 08/11] kprobes: "
` [PATCH 09/11] kgdbts: "
` [PATCH 10/11] tracing: "
` [PATCH 11/11] sched: remove _do_fork()

[PATCH 1/2] lockdep: improve current->(hard|soft)irqs_enabled synchronisation with actual irq state
 2020-08-19 15:39 UTC  (10+ messages)

remove the last set_fs() in common code, and remove it for x86 and powerpc
 2020-08-19  7:22 UTC  (31+ messages)
` [PATCH 01/11] mem: remove duplicate ops for /dev/zero and /dev/null
` [PATCH 02/11] fs: don't allow kernel reads and writes without iter ops
` [PATCH 03/11] fs: don't allow splice read/write without explicit ops
` [PATCH 04/11] uaccess: add infrastructure for kernel builds with set_fs()
` [PATCH 05/11] test_bitmap: skip user bitmap tests for !CONFIG_SET_FS
` [PATCH 06/11] lkdtm: disable set_fs-based "
` [PATCH 07/11] x86: move PAGE_OFFSET, TASK_SIZE & friends to page_{32,64}_types.h
` [PATCH 08/11] x86: make TASK_SIZE_MAX usable from assembly code
` [PATCH 09/11] x86: remove address space overrides using set_fs()
        ` iter and normal ops on /dev/zero & co, was Re: remove the last set_fs() in common code, and remove it for x86 and powerpc

Hello
 2020-08-19  3:58 UTC 

[PATCH] bitops, kcsan: Partially revert instrumentation for non-atomic bitops
 2020-08-18 16:26 UTC  (3+ messages)

Flushing transparent hugepages
 2020-08-18 16:08 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).