linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH V2 0/8] ARM: cpuidle: Unify the ARM64/ARM DT approach
@ 2015-03-18 18:46 Daniel Lezcano
  2015-03-18 18:46 ` [PATCH V2 1/8] ARM: cpuidle: Remove duplicate header inclusion Daniel Lezcano
                   ` (7 more replies)
  0 siblings, 8 replies; 18+ messages in thread
From: Daniel Lezcano @ 2015-03-18 18:46 UTC (permalink / raw)
  To: linux-arm-kernel

There is a big number of cpuidle drivers for the ARM architecture.

These drivers have been cleaned up and grouped into the drivers/cpuidle
directory to keep track of the changes more easily and ensure the code
is following the same scheme across the drivers.

That had the benefit of simplifying the code and factor out a lot of common
parts. Beside that, as the drivers belong to the 'drivers' directory, we had
to split the arch specific bits and the generic code in order to keep
everything self contained. The platform driver paradigm was used for this
purpose.

Unfortunately, this approach is now no longer accepted and a different solution
must be provided to reach the same goal: one example is the Qualcomm cpuidle
driver upstreaming attempt.

In the meantime, ARM64 developed a generic cpuidle driver based on DT definition.

The DT definition provides an 'enable-method' to specify one of the cpu
operations (PSCI, ...).

This patchset unify this driver with ARM32, using the same DT definition.

Thanks with this patchset we can use the 'enable-method' to specify a cpu
operations, hence get rid of the platform driver approach and go further in the
cpuidle driver flexibility via the DT.

Changelog:

 V2:
	* Fixed some nits in the comments
	* Added a patch to change the name of the functions
	* Added per cpu device registration patch

Daniel Lezcano (8):
  ARM: cpuidle: Remove duplicate header inclusion
  ARM: cpuidle: Add a cpuidle ops structure to be used for DT
  ARM64: cpuidle: Replace cpu_suspend by the common ARM/ARM64 function
  ARM64: cpuidle: Rename cpu_init_idle to a common function name
  ARM64: cpuidle: Remove arm64 reference
  ARM: cpuidle: Enable the ARM64 driver for both ARM32/ARM64
  ARM: cpuidle: Register per cpuidle device
  ARM: cpuidle: Change function name to be consistent with x86

 arch/arm/include/asm/cpuidle.h                     | 21 ++++++
 arch/arm/kernel/cpuidle.c                          | 74 ++++++++++++++++++-
 arch/arm/mach-davinci/cpuidle.c                    |  1 -
 arch/arm/mach-imx/cpuidle-imx6q.c                  |  1 -
 arch/arm/mach-imx/cpuidle-imx6sl.c                 |  1 -
 arch/arm/mach-imx/cpuidle-imx6sx.c                 |  1 -
 arch/arm/mach-omap2/cpuidle44xx.c                  |  1 -
 arch/arm/mach-s3c64xx/cpuidle.c                    |  2 +-
 arch/arm/mach-tegra/cpuidle-tegra20.c              |  1 -
 arch/arm/mach-tegra/cpuidle-tegra30.c              |  1 -
 arch/arm64/include/asm/cpuidle.h                   |  9 ++-
 arch/arm64/kernel/cpuidle.c                        |  2 +-
 drivers/cpuidle/Kconfig                            |  7 +-
 drivers/cpuidle/Kconfig.arm                        | 10 +++
 drivers/cpuidle/Kconfig.arm64                      | 13 ----
 drivers/cpuidle/Makefile                           |  5 +-
 drivers/cpuidle/{cpuidle-arm64.c => cpuidle-arm.c} | 83 ++++++++++++++++------
 drivers/cpuidle/cpuidle-at91.c                     |  1 -
 drivers/cpuidle/cpuidle-exynos.c                   |  1 -
 drivers/cpuidle/cpuidle-kirkwood.c                 |  1 -
 drivers/cpuidle/cpuidle-ux500.c                    |  1 -
 drivers/cpuidle/cpuidle-zynq.c                     |  1 -
 include/asm-generic/vmlinux.lds.h                  |  2 +
 23 files changed, 178 insertions(+), 62 deletions(-)
 delete mode 100644 drivers/cpuidle/Kconfig.arm64
 rename drivers/cpuidle/{cpuidle-arm64.c => cpuidle-arm.c} (56%)

-- 
1.9.1

^ permalink raw reply	[flat|nested] 18+ messages in thread

end of thread, other threads:[~2015-03-21 20:56 UTC | newest]

Thread overview: 18+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-03-18 18:46 [PATCH V2 0/8] ARM: cpuidle: Unify the ARM64/ARM DT approach Daniel Lezcano
2015-03-18 18:46 ` [PATCH V2 1/8] ARM: cpuidle: Remove duplicate header inclusion Daniel Lezcano
2015-03-18 18:46 ` [PATCH V2 2/8] ARM: cpuidle: Add a cpuidle ops structure to be used for DT Daniel Lezcano
2015-03-18 18:46 ` [PATCH V2 3/8] ARM64: cpuidle: Replace cpu_suspend by the common ARM/ARM64 function Daniel Lezcano
2015-03-21 20:56   ` Lorenzo Pieralisi
2015-03-18 18:46 ` [PATCH V2 4/8] ARM64: cpuidle: Rename cpu_init_idle to a common function name Daniel Lezcano
2015-03-18 18:46 ` [PATCH V2 5/8] ARM64: cpuidle: Remove arm64 reference Daniel Lezcano
2015-03-18 18:46 ` [PATCH V2 6/8] ARM: cpuidle: Enable the ARM64 driver for both ARM32/ARM64 Daniel Lezcano
2015-03-18 18:46 ` [PATCH V2 7/8] ARM: cpuidle: Register per cpuidle device Daniel Lezcano
2015-03-19 11:08   ` Lorenzo Pieralisi
2015-03-19 11:27     ` Daniel Lezcano
2015-03-19 11:38       ` Lorenzo Pieralisi
2015-03-19 11:44         ` Daniel Lezcano
2015-03-19 15:31   ` Lina Iyer
2015-03-19 15:33     ` Daniel Lezcano
2015-03-19 15:42       ` Lina Iyer
2015-03-19 17:11         ` Daniel Lezcano
2015-03-18 18:46 ` [PATCH V2 8/8] ARM: cpuidle: Change function name to be consistent with x86 Daniel Lezcano

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).