linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v8 0/6] stm32 clocksource driver rework
@ 2017-11-14  8:52 Benjamin Gaignard
  2017-11-14  8:52 ` [PATCH v8 1/6] clocksource: timer_of: rename timer_of_exit to timer_of_cleanup Benjamin Gaignard
                   ` (7 more replies)
  0 siblings, 8 replies; 21+ messages in thread
From: Benjamin Gaignard @ 2017-11-14  8:52 UTC (permalink / raw)
  To: linux-arm-kernel

version 8:
 - rebased on timers/core
 - change timer_of_exit() name to timer_of_cleanup()
 - update stm32 clocksource driver to use this function

version 7:
 - reword "clocksource: stm32: only use 32 bits timers" commit message
   to give more details about why 16 bits are problematics.

version 6:
 - add dedicated patch min delta change
 - rework commit messages, I hope it will be better now
 - change new function name from timer_of_deinit to timer_of_exit
 - make stm32_clock_event_set_next_event() safer like done in other
   drivers

version 6:
- add timer_of_deinit function in core
- rework failure cases in probe function

version 5:
- rebase on top of timer/core branch
- rework commit message of the first patch

version 4:
- split patch in 3 parts
  - convert code to timer_of
  - only use 32 bits timers
  - add clocksource support

version 3:
- fix comments done by Daniel
- use timer_of helper functions

version 2:
- fix uninitialized variable

Benjamin Gaignard (6):
  clocksource: timer_of: rename timer_of_exit to timer_of_cleanup
  clocksource: stm32: convert driver to timer_of
  clocksource: stm32: increase min delta value
  clocksource: stm32: only use 32 bits timers
  clocksource: stm32: add clocksource support
  arm: dts: stm32: remove useless clocksource nodes

 arch/arm/boot/dts/stm32f429.dtsi  |  32 -----
 arch/arm/boot/dts/stm32f746.dtsi  |  32 -----
 drivers/clocksource/Kconfig       |   1 +
 drivers/clocksource/timer-of.c    |   9 +-
 drivers/clocksource/timer-of.h    |   2 +-
 drivers/clocksource/timer-stm32.c | 242 ++++++++++++++++++++------------------
 6 files changed, 138 insertions(+), 180 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 21+ messages in thread

end of thread, other threads:[~2017-12-08  9:31 UTC | newest]

Thread overview: 21+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-11-14  8:52 [PATCH v8 0/6] stm32 clocksource driver rework Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 1/6] clocksource: timer_of: rename timer_of_exit to timer_of_cleanup Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 2/6] clocksource: stm32: convert driver to timer_of Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 3/6] clocksource: stm32: increase min delta value Benjamin Gaignard
2017-12-08  9:28   ` Daniel Lezcano
2017-11-14  8:52 ` [PATCH v8 4/6] clocksource: stm32: only use 32 bits timers Benjamin Gaignard
2017-12-07 15:27   ` Daniel Lezcano
2017-12-07 16:33     ` Benjamin Gaignard
2017-12-07 16:49       ` Daniel Lezcano
2017-12-07 20:36         ` Benjamin Gaignard
2017-12-08  7:52           ` Daniel Lezcano
2017-12-08  8:34   ` Daniel Lezcano
2017-12-08  9:25     ` Benjamin Gaignard
2017-12-08  9:29       ` Daniel Lezcano
2017-12-08  9:31         ` Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 5/6] clocksource: stm32: add clocksource support Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 6/6] arm: dts: stm32: remove useless clocksource nodes Benjamin Gaignard
2017-11-27 10:44 ` [PATCH v8 0/6] stm32 clocksource driver rework Benjamin Gaignard
2017-12-05 10:12 ` Alexandre Torgue
2017-12-05 10:15   ` Daniel Lezcano
2017-12-05 10:16     ` Alexandre Torgue

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).