linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Catalin Marinas <catalin.marinas@arm.com>
To: Andrey Konovalov <andreyknvl@google.com>
Cc: linux-arm-kernel@lists.infradead.org,
	Marco Elver <elver@google.com>,
	Elena Petrova <lenaptr@google.com>,
	Kevin Brodsky <kevin.brodsky@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	Branislav Rankov <Branislav.Rankov@arm.com>,
	kasan-dev@googlegroups.com, linux-kernel@vger.kernel.org,
	linux-mm@kvack.org, Alexander Potapenko <glider@google.com>,
	Evgenii Stepanov <eugenis@google.com>,
	Andrey Ryabinin <aryabinin@virtuozzo.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Vincenzo Frascino <vincenzo.frascino@arm.com>,
	Dmitry Vyukov <dvyukov@google.com>
Subject: Re: [PATCH v2 22/37] arm64: mte: Add in-kernel MTE helpers
Date: Thu, 17 Sep 2020 14:46:53 +0100	[thread overview]
Message-ID: <20200917134653.GB10662@gaia> (raw)
In-Reply-To: <4ac1ed624dd1b0851d8cf2861b4f4aac4d2dbc83.1600204505.git.andreyknvl@google.com>

On Tue, Sep 15, 2020 at 11:16:04PM +0200, Andrey Konovalov wrote:
> diff --git a/arch/arm64/include/asm/mte-helpers.h b/arch/arm64/include/asm/mte-helpers.h
> new file mode 100644
> index 000000000000..5dc2d443851b
> --- /dev/null
> +++ b/arch/arm64/include/asm/mte-helpers.h
> @@ -0,0 +1,48 @@
> +/* SPDX-License-Identifier: GPL-2.0 */
> +/*
> + * Copyright (C) 2020 ARM Ltd.
> + */
> +#ifndef __ASM_MTE_ASM_H
> +#define __ASM_MTE_ASM_H
> +
> +#define __MTE_PREAMBLE		".arch armv8.5-a\n.arch_extension memtag\n"

Because of how the .arch overrides a previous .arch, we should follow
the ARM64_ASM_PREAMBLE introduced in commit 1764c3edc668 ("arm64: use a
common .arch preamble for inline assembly"). The above should be
something like:

#define __MTE_PREAMBLE	ARM64_ASM_PREAMBLE ".arch_extension memtag"

with the ARM64_ASM_PREAMBLE adjusted to armv8.5-a if available.

> +#define MTE_GRANULE_SIZE	UL(16)
> +#define MTE_GRANULE_MASK	(~(MTE_GRANULE_SIZE - 1))
> +#define MTE_TAG_SHIFT		56
> +#define MTE_TAG_SIZE		4
> +#define MTE_TAG_MASK		GENMASK((MTE_TAG_SHIFT + (MTE_TAG_SIZE - 1)), MTE_TAG_SHIFT)
> +#define MTE_TAG_MAX		(MTE_TAG_MASK >> MTE_TAG_SHIFT)

In v1 I suggested we keep those definitions in mte-def.h (or
mte-hwdef.h) so that they can be included in cache.h. Anything else
should go in mte.h, I don't see the point of two headers for various MTE
function prototypes.

> +
> +#ifndef __ASSEMBLY__
> +
> +#include <linux/types.h>
> +
> +#ifdef CONFIG_ARM64_MTE
> +
> +#define mte_get_ptr_tag(ptr)	((u8)(((u64)(ptr)) >> MTE_TAG_SHIFT))

I wonder whether this could also be an inline function that takes a void
*ptr.

> diff --git a/arch/arm64/kernel/mte.c b/arch/arm64/kernel/mte.c
> index 52a0638ed967..e238ffde2679 100644
> --- a/arch/arm64/kernel/mte.c
> +++ b/arch/arm64/kernel/mte.c
> @@ -72,6 +74,52 @@ int memcmp_pages(struct page *page1, struct page *page2)
>  	return ret;
>  }
>  
> +u8 mte_get_mem_tag(void *addr)
> +{
> +	if (system_supports_mte())
> +		asm volatile(ALTERNATIVE("ldr %0, [%0]",
> +					 __MTE_PREAMBLE "ldg %0, [%0]",
> +					 ARM64_MTE)
> +			     : "+r" (addr));

This doesn't do what you think it does. LDG indeed reads the tag from
memory but LDR loads the actual data at that address. Instead of the
first LDR, you may want something like "mov %0, #0xf << 56" (and use
some macros to avoid the hard-coded 56).

> +
> +	return 0xF0 | mte_get_ptr_tag(addr);
> +}
> +
> +u8 mte_get_random_tag(void)
> +{
> +	u8 tag = 0xF;
> +	u64 addr = 0;
> +
> +	if (system_supports_mte()) {
> +		asm volatile(ALTERNATIVE("add %0, %0, %0",
> +					 __MTE_PREAMBLE "irg %0, %0",
> +					 ARM64_MTE)
> +			     : "+r" (addr));

What was the intention here? The first ADD doubles the pointer value and
gets a tag out of it (possibly doubled as well, depends on the carry
from bit 55). Better use something like "orr %0, %0, #0xf << 56".

> +
> +		tag = mte_get_ptr_tag(addr);
> +	}
> +
> +	return 0xF0 | tag;

This function return seems inconsistent with the previous one. I'd
prefer the return line to be the same in both.

> +}
> +
> +void *mte_set_mem_tag_range(void *addr, size_t size, u8 tag)
> +{
> +	void *ptr = addr;
> +
> +	if ((!system_supports_mte()) || (size == 0))
> +		return addr;
> +
> +	/* Make sure that size is aligned. */
> +	WARN_ON(size & (MTE_GRANULE_SIZE - 1));
> +
> +	tag = 0xF0 | (tag & 0xF);

No point in tag & 0xf, the top nibble doesn't matter as you or 0xf0 in.

> +	ptr = (void *)__tag_set(ptr, tag);
> +
> +	mte_assign_mem_tag_range(ptr, size);
> +
> +	return ptr;
> +}
> +
>  static void update_sctlr_el1_tcf0(u64 tcf0)
>  {
>  	/* ISB required for the kernel uaccess routines */
> diff --git a/arch/arm64/lib/mte.S b/arch/arm64/lib/mte.S
> index 03ca6d8b8670..cc2c3a378c00 100644
> --- a/arch/arm64/lib/mte.S
> +++ b/arch/arm64/lib/mte.S
> @@ -149,3 +149,20 @@ SYM_FUNC_START(mte_restore_page_tags)
>  
>  	ret
>  SYM_FUNC_END(mte_restore_page_tags)
> +
> +/*
> + * Assign allocation tags for a region of memory based on the pointer tag
> + *   x0 - source pointer
> + *   x1 - size
> + *
> + * Note: size must be non-zero and MTE_GRANULE_SIZE aligned
> + */
> +SYM_FUNC_START(mte_assign_mem_tag_range)
> +	/* if (src == NULL) return; */
> +	cbz	x0, 2f
> +1:	stg	x0, [x0]
> +	add	x0, x0, #MTE_GRANULE_SIZE
> +	sub	x1, x1, #MTE_GRANULE_SIZE
> +	cbnz	x1, 1b
> +2:	ret
> +SYM_FUNC_END(mte_assign_mem_tag_range)

I thought Vincenzo agreed to my comments on the previous version w.r.t.
the fist cbz and the last cbnz:

https://lore.kernel.org/linux-arm-kernel/921c4ed0-b5b5-bc01-5418-c52d80f1af59@arm.com/

-- 
Catalin

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2020-09-17 13:48 UTC|newest]

Thread overview: 90+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-15 21:15 [PATCH v2 00/37] kasan: add hardware tag-based mode for arm64 Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 01/37] kasan: KASAN_VMALLOC depends on KASAN_GENERIC Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 02/37] kasan: group vmalloc code Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 03/37] kasan: shadow declarations only for software modes Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 04/37] kasan: rename (un)poison_shadow to (un)poison_memory Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 05/37] kasan: rename KASAN_SHADOW_* to KASAN_GRANULE_* Andrey Konovalov
2020-09-18  8:04   ` Alexander Potapenko
2020-09-18 10:42     ` Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 06/37] kasan: only build init.c for software modes Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 07/37] kasan: split out shadow.c from common.c Andrey Konovalov
2020-09-18  8:17   ` Alexander Potapenko
2020-09-18 10:39     ` Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 08/37] kasan: rename generic/tags_report.c files Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 09/37] kasan: don't duplicate config dependencies Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 10/37] kasan: hide invalid free check implementation Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 11/37] kasan: decode stack frame only with KASAN_STACK_ENABLE Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 12/37] kasan, arm64: only init shadow for software modes Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-15 21:15 ` [PATCH v2 13/37] kasan, arm64: only use kasan_depth " Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-15 21:15 ` [PATCH v2 14/37] kasan: rename addr_has_shadow to addr_has_metadata Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 15/37] kasan: rename print_shadow_for_address to print_memory_metadata Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 16/37] kasan: kasan_non_canonical_hook only for software modes Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 17/37] kasan: rename SHADOW layout macros to META Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 18/37] kasan: separate metadata_fetch_row for each mode Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 19/37] kasan: don't allow SW_TAGS with ARM64_MTE Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 20/37] kasan: rename tags.c to tags_sw.c Andrey Konovalov
2020-09-18  9:41   ` Alexander Potapenko
2020-09-18  9:44     ` Alexander Potapenko
2020-09-18  9:46       ` Alexander Potapenko
2020-09-18 10:42         ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 21/37] kasan: introduce CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-09-18 12:32   ` Marco Elver
2020-09-18 15:06     ` Andrey Konovalov
2020-09-18 15:36       ` Marco Elver
2020-09-18 15:45         ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 22/37] arm64: mte: Add in-kernel MTE helpers Andrey Konovalov
2020-09-17 13:46   ` Catalin Marinas [this message]
2020-09-17 14:21     ` Vincenzo Frascino
2020-09-18  9:36       ` Catalin Marinas
2020-09-22 10:16         ` Vincenzo Frascino
2020-09-17 16:17     ` Vincenzo Frascino
2020-09-17 17:07       ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 23/37] arm64: kasan: Add arch layer for memory tagging helpers Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-18 13:00   ` Marco Elver
2020-09-18 14:56     ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 24/37] arm64: mte: Add in-kernel tag fault handler Andrey Konovalov
2020-09-17 14:03   ` Catalin Marinas
2020-09-17 14:24     ` Vincenzo Frascino
2020-09-17 14:59   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 25/37] arm64: kasan: Enable in-kernel MTE Andrey Konovalov
2020-09-17 16:35   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 26/37] arm64: mte: Convert gcr_user into an exclude mask Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 27/37] arm64: mte: Switch GCR_EL1 in kernel entry and exit Andrey Konovalov
2020-09-17 16:52   ` Catalin Marinas
2020-09-17 16:58     ` Catalin Marinas
2020-09-17 18:47     ` Vincenzo Frascino
2020-09-18  9:39       ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 28/37] arm64: kasan: Enable TBI EL1 Andrey Konovalov
2020-09-17 16:54   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 29/37] arm64: kasan: Align allocations for HW_TAGS Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 30/37] kasan: define KASAN_GRANULE_SIZE " Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 31/37] kasan, x86, s390: update undef CONFIG_KASAN Andrey Konovalov
2020-09-18 10:52   ` Marco Elver
2020-09-18 15:07     ` Andrey Konovalov
2020-09-24 21:35       ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 32/37] kasan, arm64: expand CONFIG_KASAN checks Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 33/37] kasan, arm64: implement HW_TAGS runtime Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-18 10:46   ` Marco Elver
2020-09-18 12:28     ` Andrey Konovalov
2020-09-18 12:52   ` Marco Elver
2020-09-18 15:00     ` Andrey Konovalov
2020-09-18 15:19   ` Marco Elver
2020-09-18 15:52     ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 34/37] kasan, arm64: print report from tag fault handler Andrey Konovalov
2020-09-17 17:04   ` Catalin Marinas
2020-09-18 12:26     ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 35/37] kasan, slub: reset tags when accessing metadata Andrey Konovalov
2020-09-18 14:44   ` Marco Elver
2020-09-18 14:55     ` Andrey Konovalov
2020-09-18 15:29       ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 36/37] kasan, arm64: enable CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-09-17 17:04   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 37/37] kasan: add documentation for hardware tag-based mode Andrey Konovalov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200917134653.GB10662@gaia \
    --to=catalin.marinas@arm.com \
    --cc=Branislav.Rankov@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=andreyknvl@google.com \
    --cc=aryabinin@virtuozzo.com \
    --cc=dvyukov@google.com \
    --cc=elver@google.com \
    --cc=eugenis@google.com \
    --cc=glider@google.com \
    --cc=kasan-dev@googlegroups.com \
    --cc=kevin.brodsky@arm.com \
    --cc=lenaptr@google.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=vincenzo.frascino@arm.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).