linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Andrey Konovalov <andreyknvl@google.com>
To: Marco Elver <elver@google.com>
Cc: Linux ARM <linux-arm-kernel@lists.infradead.org>,
	Branislav Rankov <Branislav.Rankov@arm.com>,
	Elena Petrova <lenaptr@google.com>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Kevin Brodsky <kevin.brodsky@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	LKML <linux-kernel@vger.kernel.org>,
	kasan-dev <kasan-dev@googlegroups.com>,
	Linux Memory Management List <linux-mm@kvack.org>,
	Alexander Potapenko <glider@google.com>,
	Evgenii Stepanov <eugenis@google.com>,
	Andrey Ryabinin <aryabinin@virtuozzo.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Vincenzo Frascino <vincenzo.frascino@arm.com>,
	Dmitry Vyukov <dvyukov@google.com>
Subject: Re: [PATCH v2 21/37] kasan: introduce CONFIG_KASAN_HW_TAGS
Date: Fri, 18 Sep 2020 17:06:21 +0200	[thread overview]
Message-ID: <CAAeHK+wF_tkBqHd7ESSa5jOy50AW1WfzSAM-qNf_+iMkLwptTQ@mail.gmail.com> (raw)
In-Reply-To: <20200918123249.GC2384246@elver.google.com>

On Fri, Sep 18, 2020 at 2:32 PM Marco Elver <elver@google.com> wrote:
>
> On Tue, Sep 15, 2020 at 11:16PM +0200, Andrey Konovalov wrote:
> > This patch adds a configuration option for a new KASAN mode called
> > hardware tag-based KASAN. This mode uses the memory tagging approach
> > like the software tag-based mode, but relies on arm64 Memory Tagging
> > Extension feature for tag management and access checking.
> >
> > Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
> > Signed-off-by: Vincenzo Frascino <vincenzo.frascino@arm.com>
> > ---
> > Change-Id: I246c2def9fffa6563278db1bddfbe742ca7bdefe
> > ---
> >  lib/Kconfig.kasan | 56 +++++++++++++++++++++++++++++++++--------------
> >  1 file changed, 39 insertions(+), 17 deletions(-)
> >
> > diff --git a/lib/Kconfig.kasan b/lib/Kconfig.kasan
> > index b4cf6c519d71..17c9ecfaecb9 100644
> > --- a/lib/Kconfig.kasan
> > +++ b/lib/Kconfig.kasan
> > @@ -6,7 +6,10 @@ config HAVE_ARCH_KASAN
> >  config HAVE_ARCH_KASAN_SW_TAGS
> >       bool
> >
> > -config       HAVE_ARCH_KASAN_VMALLOC
> > +config HAVE_ARCH_KASAN_HW_TAGS
> > +     bool
> > +
> > +config HAVE_ARCH_KASAN_VMALLOC
> >       bool
> >
> >  config CC_HAS_KASAN_GENERIC
> > @@ -20,10 +23,11 @@ config CC_HAS_WORKING_NOSANITIZE_ADDRESS
> >
> >  menuconfig KASAN
> >       bool "KASAN: runtime memory debugger"
> > -     depends on (HAVE_ARCH_KASAN && CC_HAS_KASAN_GENERIC) || \
> > -                (HAVE_ARCH_KASAN_SW_TAGS && CC_HAS_KASAN_SW_TAGS)
> > +     depends on (((HAVE_ARCH_KASAN && CC_HAS_KASAN_GENERIC) || \
> > +                  (HAVE_ARCH_KASAN_SW_TAGS && CC_HAS_KASAN_SW_TAGS)) && \
> > +                 CC_HAS_WORKING_NOSANITIZE_ADDRESS) || \
> > +                HAVE_ARCH_KASAN_HW_TAGS
> >       depends on (SLUB && SYSFS) || (SLAB && !DEBUG_SLAB)
> > -     depends on CC_HAS_WORKING_NOSANITIZE_ADDRESS
> >       select SLUB_DEBUG if SLUB
>
> Is SLUB_DEBUG necessary with HW_TAGS?

I'll check and drop it if it's unnecessary.

> >       select CONSTRUCTORS
> >       select STACKDEPOT
> > @@ -38,13 +42,18 @@ choice
> >       prompt "KASAN mode"
> >       default KASAN_GENERIC
> >       help
> > -       KASAN has two modes: generic KASAN (similar to userspace ASan,
> > -       x86_64/arm64/xtensa, enabled with CONFIG_KASAN_GENERIC) and
> > -       software tag-based KASAN (a version based on software memory
> > -       tagging, arm64 only, similar to userspace HWASan, enabled with
> > -       CONFIG_KASAN_SW_TAGS).
> > +       KASAN has three modes:
> > +       1. generic KASAN (similar to userspace ASan,
> > +          x86_64/arm64/xtensa, enabled with CONFIG_KASAN_GENERIC),
> > +       2. software tag-based KASAN (arm64 only, based on software
> > +          memory tagging (similar to userspace HWASan), enabled with
> > +          CONFIG_KASAN_SW_TAGS), and
> > +       3. hardware tag-based KASAN (arm64 only, based on hardware
> > +          memory tagging, enabled with CONFIG_KASAN_HW_TAGS).
> >
> > -       Both generic and tag-based KASAN are strictly debugging features.
> > +       All KASAN modes are strictly debugging features.
> > +
> > +       For better error detection enable CONFIG_STACKTRACE.
>
> I don't think CONFIG_STACKTRACE improves error detection, right? It only
> makes the reports more readable

Yes, will fix.

> >
> >  config KASAN_GENERIC
> >       bool "Generic mode"
> > @@ -61,8 +70,6 @@ config KASAN_GENERIC
> >         and introduces an overhead of ~x1.5 for the rest of the allocations.
> >         The performance slowdown is ~x3.
> >
> > -       For better error detection enable CONFIG_STACKTRACE.
> > -
> >         Currently CONFIG_KASAN_GENERIC doesn't work with CONFIG_DEBUG_SLAB
> >         (the resulting kernel does not boot).
> >
> > @@ -72,9 +79,11 @@ config KASAN_SW_TAGS
> >       help
> >         Enables software tag-based KASAN mode.
> >
> > -       This mode requires Top Byte Ignore support by the CPU and therefore
> > -       is only supported for arm64. This mode requires Clang version 7.0.0
> > -       or later.
> > +       This mode require software memory tagging support in the form of
> > +       HWASan-like compiler instrumentation.
> > +
> > +       Currently this mode is only implemented for arm64 CPUs and relies on
> > +       Top Byte Ignore. This mode requires Clang version 7.0.0 or later.
> >
> >         This mode consumes about 1/16th of available memory at kernel start
> >         and introduces an overhead of ~20% for the rest of the allocations.
> > @@ -82,15 +91,27 @@ config KASAN_SW_TAGS
> >         casting and comparison, as it embeds tags into the top byte of each
> >         pointer.
> >
> > -       For better error detection enable CONFIG_STACKTRACE.
> > -
> >         Currently CONFIG_KASAN_SW_TAGS doesn't work with CONFIG_DEBUG_SLAB
> >         (the resulting kernel does not boot).
> >
> > +config KASAN_HW_TAGS
> > +     bool "Hardware tag-based mode"
> > +     depends on HAVE_ARCH_KASAN_HW_TAGS
> > +     depends on SLUB
> > +     help
> > +       Enables hardware tag-based KASAN mode.
> > +
> > +       This mode requires hardware memory tagging support, and can be used
> > +       by any architecture that provides it.
> > +
> > +       Currently this mode is only implemented for arm64 CPUs starting from
> > +       ARMv8.5 and relies on Memory Tagging Extension and Top Byte Ignore.
> > +
> >  endchoice
> >
> >  choice
> >       prompt "Instrumentation type"
> > +     depends on KASAN_GENERIC || KASAN_SW_TAGS
> >       default KASAN_OUTLINE
> >
> >  config KASAN_OUTLINE
> > @@ -114,6 +135,7 @@ endchoice
> >
> >  config KASAN_STACK_ENABLE
> >       bool "Enable stack instrumentation (unsafe)" if CC_IS_CLANG && !COMPILE_TEST
> > +     depends on KASAN_GENERIC || KASAN_SW_TAGS
> >       help
> >         The LLVM stack address sanitizer has a know problem that
> >         causes excessive stack usage in a lot of functions, see
>
> How about something like the below change (introduce KASAN_INSTRUMENTED
> Kconfig var) to avoid the repeated "KASAN_GENERIC || KASAN_SW_TAGS".
> This could then also be used in the various .c/.h files (and make some
> of the code more readable hopefully).

I tried doing that initially, but it didn't really look good. The
reason is that we actually have two properties that are currently
common for the software modes, but aren't actually tied to each other:
instrumentation and shadow memory. Therefore we will end up with two
new configs: KASAN_INSTRUMENTED and KASAN_USES_SHADOW (or something),
and things get quite confusing. I think it's better to keep
KASAN_GENERIC || KASAN_SW_TAGS everywhere.

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2020-09-18 15:08 UTC|newest]

Thread overview: 90+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-15 21:15 [PATCH v2 00/37] kasan: add hardware tag-based mode for arm64 Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 01/37] kasan: KASAN_VMALLOC depends on KASAN_GENERIC Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 02/37] kasan: group vmalloc code Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 03/37] kasan: shadow declarations only for software modes Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 04/37] kasan: rename (un)poison_shadow to (un)poison_memory Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 05/37] kasan: rename KASAN_SHADOW_* to KASAN_GRANULE_* Andrey Konovalov
2020-09-18  8:04   ` Alexander Potapenko
2020-09-18 10:42     ` Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 06/37] kasan: only build init.c for software modes Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 07/37] kasan: split out shadow.c from common.c Andrey Konovalov
2020-09-18  8:17   ` Alexander Potapenko
2020-09-18 10:39     ` Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 08/37] kasan: rename generic/tags_report.c files Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 09/37] kasan: don't duplicate config dependencies Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 10/37] kasan: hide invalid free check implementation Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 11/37] kasan: decode stack frame only with KASAN_STACK_ENABLE Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 12/37] kasan, arm64: only init shadow for software modes Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-15 21:15 ` [PATCH v2 13/37] kasan, arm64: only use kasan_depth " Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-15 21:15 ` [PATCH v2 14/37] kasan: rename addr_has_shadow to addr_has_metadata Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 15/37] kasan: rename print_shadow_for_address to print_memory_metadata Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 16/37] kasan: kasan_non_canonical_hook only for software modes Andrey Konovalov
2020-09-15 21:15 ` [PATCH v2 17/37] kasan: rename SHADOW layout macros to META Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 18/37] kasan: separate metadata_fetch_row for each mode Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 19/37] kasan: don't allow SW_TAGS with ARM64_MTE Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 20/37] kasan: rename tags.c to tags_sw.c Andrey Konovalov
2020-09-18  9:41   ` Alexander Potapenko
2020-09-18  9:44     ` Alexander Potapenko
2020-09-18  9:46       ` Alexander Potapenko
2020-09-18 10:42         ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 21/37] kasan: introduce CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-09-18 12:32   ` Marco Elver
2020-09-18 15:06     ` Andrey Konovalov [this message]
2020-09-18 15:36       ` Marco Elver
2020-09-18 15:45         ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 22/37] arm64: mte: Add in-kernel MTE helpers Andrey Konovalov
2020-09-17 13:46   ` Catalin Marinas
2020-09-17 14:21     ` Vincenzo Frascino
2020-09-18  9:36       ` Catalin Marinas
2020-09-22 10:16         ` Vincenzo Frascino
2020-09-17 16:17     ` Vincenzo Frascino
2020-09-17 17:07       ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 23/37] arm64: kasan: Add arch layer for memory tagging helpers Andrey Konovalov
2020-09-17 17:05   ` Catalin Marinas
2020-09-18 13:00   ` Marco Elver
2020-09-18 14:56     ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 24/37] arm64: mte: Add in-kernel tag fault handler Andrey Konovalov
2020-09-17 14:03   ` Catalin Marinas
2020-09-17 14:24     ` Vincenzo Frascino
2020-09-17 14:59   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 25/37] arm64: kasan: Enable in-kernel MTE Andrey Konovalov
2020-09-17 16:35   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 26/37] arm64: mte: Convert gcr_user into an exclude mask Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 27/37] arm64: mte: Switch GCR_EL1 in kernel entry and exit Andrey Konovalov
2020-09-17 16:52   ` Catalin Marinas
2020-09-17 16:58     ` Catalin Marinas
2020-09-17 18:47     ` Vincenzo Frascino
2020-09-18  9:39       ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 28/37] arm64: kasan: Enable TBI EL1 Andrey Konovalov
2020-09-17 16:54   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 29/37] arm64: kasan: Align allocations for HW_TAGS Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 30/37] kasan: define KASAN_GRANULE_SIZE " Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 31/37] kasan, x86, s390: update undef CONFIG_KASAN Andrey Konovalov
2020-09-18 10:52   ` Marco Elver
2020-09-18 15:07     ` Andrey Konovalov
2020-09-24 21:35       ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 32/37] kasan, arm64: expand CONFIG_KASAN checks Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 33/37] kasan, arm64: implement HW_TAGS runtime Andrey Konovalov
2020-09-17 17:06   ` Catalin Marinas
2020-09-18 10:46   ` Marco Elver
2020-09-18 12:28     ` Andrey Konovalov
2020-09-18 12:52   ` Marco Elver
2020-09-18 15:00     ` Andrey Konovalov
2020-09-18 15:19   ` Marco Elver
2020-09-18 15:52     ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 34/37] kasan, arm64: print report from tag fault handler Andrey Konovalov
2020-09-17 17:04   ` Catalin Marinas
2020-09-18 12:26     ` Andrey Konovalov
2020-09-15 21:16 ` [PATCH v2 35/37] kasan, slub: reset tags when accessing metadata Andrey Konovalov
2020-09-18 14:44   ` Marco Elver
2020-09-18 14:55     ` Andrey Konovalov
2020-09-18 15:29       ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 36/37] kasan, arm64: enable CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-09-17 17:04   ` Catalin Marinas
2020-09-15 21:16 ` [PATCH v2 37/37] kasan: add documentation for hardware tag-based mode Andrey Konovalov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAAeHK+wF_tkBqHd7ESSa5jOy50AW1WfzSAM-qNf_+iMkLwptTQ@mail.gmail.com \
    --to=andreyknvl@google.com \
    --cc=Branislav.Rankov@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=aryabinin@virtuozzo.com \
    --cc=catalin.marinas@arm.com \
    --cc=dvyukov@google.com \
    --cc=elver@google.com \
    --cc=eugenis@google.com \
    --cc=glider@google.com \
    --cc=kasan-dev@googlegroups.com \
    --cc=kevin.brodsky@arm.com \
    --cc=lenaptr@google.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=vincenzo.frascino@arm.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).