linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Vincenzo Frascino <vincenzo.frascino@arm.com>
To: Catalin Marinas <catalin.marinas@arm.com>,
	Andrey Konovalov <andreyknvl@google.com>
Cc: linux-arm-kernel@lists.infradead.org,
	Marco Elver <elver@google.com>,
	Elena Petrova <lenaptr@google.com>,
	Kevin Brodsky <kevin.brodsky@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	Branislav Rankov <Branislav.Rankov@arm.com>,
	kasan-dev@googlegroups.com, linux-kernel@vger.kernel.org,
	linux-mm@kvack.org, Alexander Potapenko <glider@google.com>,
	Dmitry Vyukov <dvyukov@google.com>,
	Andrey Ryabinin <aryabinin@virtuozzo.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Evgenii Stepanov <eugenis@google.com>
Subject: Re: [PATCH v3 29/39] arm64: mte: Switch GCR_EL1 in kernel entry and exit
Date: Fri, 25 Sep 2020 12:50:23 +0100	[thread overview]
Message-ID: <e4624059-1598-17eb-2c64-3e7f26c2a1ba@arm.com> (raw)
In-Reply-To: <20200925113433.GF4846@gaia>

On 9/25/20 12:34 PM, Catalin Marinas wrote:
> On Fri, Sep 25, 2020 at 12:50:36AM +0200, Andrey Konovalov wrote:
>> diff --git a/arch/arm64/kernel/entry.S b/arch/arm64/kernel/entry.S
>> index ff34461524d4..c7cc1fdfbd1a 100644
>> --- a/arch/arm64/kernel/entry.S
>> +++ b/arch/arm64/kernel/entry.S
>> @@ -175,6 +175,49 @@ alternative_else_nop_endif
>>  #endif
>>  	.endm
>>  
>> +	.macro mte_set_gcr, tmp, tmp2
>> +#ifdef CONFIG_ARM64_MTE
>> +alternative_if_not ARM64_MTE
>> +	b	1f
>> +alternative_else_nop_endif
> 
> You don't need the alternative here. The macro is only invoked in an
> alternative path already (I'd be surprised if it even works, we don't
> handle nested alternatives well).
>

Yes, you are right. I forgot to remove it.

>> +	/*
>> +	 * Calculate and set the exclude mask preserving
>> +	 * the RRND (bit[16]) setting.
>> +	 */
>> +	mrs_s	\tmp2, SYS_GCR_EL1
>> +	bfi	\tmp2, \tmp, #0, #16
>> +	msr_s	SYS_GCR_EL1, \tmp2
>> +	isb
>> +1:
>> +#endif
>> +	.endm
>> +
>> +	.macro mte_set_kernel_gcr, tsk, tmp, tmp2
> 
> What's the point of a 'tsk' argument here?
> 

It is unused. I kept the interface same in between kernel and user.
I can either add a comment or remove it. Which one do you prefer?

>> +#ifdef CONFIG_KASAN_HW_TAGS
>> +#ifdef CONFIG_ARM64_MTE
> 
> Does KASAN_HW_TAGS depend on ARM64_MTE already? Just to avoid too may
> ifdefs. Otherwise, you can always write it as:
> 
> #if defined(CONFIG_KASAN_HW_TAGS) && defined(CONFIG_ARM64_MTE)
> 
> to save two lines (and its easier to read).
> 

It is indeed. I forgot to remove CONFIG_ARM64_MTE.

>> +alternative_if_not ARM64_MTE
>> +	b	1f
>> +alternative_else_nop_endif
>> +	ldr_l	\tmp, gcr_kernel_excl
>> +
>> +	mte_set_gcr \tmp, \tmp2
>> +1:
>> +#endif
>> +#endif
>> +	.endm
>> +
>> +	.macro mte_set_user_gcr, tsk, tmp, tmp2
>> +#ifdef CONFIG_ARM64_MTE
>> +alternative_if_not ARM64_MTE
>> +	b	1f
>> +alternative_else_nop_endif
>> +	ldr	\tmp, [\tsk, #THREAD_GCR_EL1_USER]
>> +
>> +	mte_set_gcr \tmp, \tmp2
>> +1:
>> +#endif
>> +	.endm
>> +
>>  	.macro	kernel_entry, el, regsize = 64
>>  	.if	\regsize == 32
>>  	mov	w0, w0				// zero upper 32 bits of x0
>> @@ -214,6 +257,8 @@ alternative_else_nop_endif
>>  
>>  	ptrauth_keys_install_kernel tsk, x20, x22, x23
>>  
>> +	mte_set_kernel_gcr tsk, x22, x23
>> +
>>  	scs_load tsk, x20
>>  	.else
>>  	add	x21, sp, #S_FRAME_SIZE
>> @@ -332,6 +377,8 @@ alternative_else_nop_endif
>>  	/* No kernel C function calls after this as user keys are set. */
>>  	ptrauth_keys_install_user tsk, x0, x1, x2
>>  
>> +	mte_set_user_gcr tsk, x0, x1
>> +
>>  	apply_ssbd 0, x0, x1
>>  	.endif
>>  
>> diff --git a/arch/arm64/kernel/mte.c b/arch/arm64/kernel/mte.c
>> index 393d0c794be4..c3b4f056fc54 100644
>> --- a/arch/arm64/kernel/mte.c
>> +++ b/arch/arm64/kernel/mte.c
>> @@ -22,6 +22,8 @@
>>  #include <asm/ptrace.h>
>>  #include <asm/sysreg.h>
>>  
>> +u64 gcr_kernel_excl __ro_after_init;
>> +
>>  static void mte_sync_page_tags(struct page *page, pte_t *ptep, bool check_swap)
>>  {
>>  	pte_t old_pte = READ_ONCE(*ptep);
>> @@ -116,6 +118,13 @@ void *mte_set_mem_tag_range(void *addr, size_t size, u8 tag)
>>  	return ptr;
>>  }
>>  
>> +void mte_init_tags(u64 max_tag)
>> +{
>> +	u64 incl = GENMASK(max_tag & MTE_TAG_MAX, 0);
>> +
>> +	gcr_kernel_excl = ~incl & SYS_GCR_EL1_EXCL_MASK;
>> +}
>> +
>>  static void update_sctlr_el1_tcf0(u64 tcf0)
>>  {
>>  	/* ISB required for the kernel uaccess routines */
>> @@ -151,7 +160,11 @@ static void update_gcr_el1_excl(u64 excl)
>>  static void set_gcr_el1_excl(u64 excl)
>>  {
>>  	current->thread.gcr_user_excl = excl;
>> -	update_gcr_el1_excl(excl);
>> +
>> +	/*
>> +	 * SYS_GCR_EL1 will be set to current->thread.gcr_user_incl value
>                                                       ^^^^^^^^^^^^^
> That's gcr_user_excl now.
> 
>> +	 * by mte_restore_gcr() in kernel_exit,
> 
> I don't think mte_restore_gcr is still around in this patch.
> 

This comment requires updating. I missed it.

-- 
Regards,
Vincenzo

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2020-09-25 11:49 UTC|newest]

Thread overview: 88+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-24 22:50 [PATCH v3 00/39] kasan: add hardware tag-based mode for arm64 Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 01/39] kasan: drop unnecessary GPL text from comment headers Andrey Konovalov
2020-10-01 17:18   ` elver
2020-09-24 22:50 ` [PATCH v3 02/39] kasan: KASAN_VMALLOC depends on KASAN_GENERIC Andrey Konovalov
2020-10-01 17:19   ` elver
2020-09-24 22:50 ` [PATCH v3 03/39] kasan: group vmalloc code Andrey Konovalov
2020-10-01 17:27   ` elver
2020-09-24 22:50 ` [PATCH v3 04/39] kasan: shadow declarations only for software modes Andrey Konovalov
2020-10-01 17:29   ` elver
2020-09-24 22:50 ` [PATCH v3 05/39] kasan: rename (un)poison_shadow to (un)poison_memory Andrey Konovalov
2020-10-01 17:29   ` elver
2020-09-24 22:50 ` [PATCH v3 06/39] kasan: rename KASAN_SHADOW_* to KASAN_GRANULE_* Andrey Konovalov
2020-10-01 17:30   ` elver
2020-09-24 22:50 ` [PATCH v3 07/39] kasan: only build init.c for software modes Andrey Konovalov
2020-10-01 17:31   ` elver
2020-09-24 22:50 ` [PATCH v3 08/39] kasan: split out shadow.c from common.c Andrey Konovalov
2020-10-01 17:32   ` elver
2020-09-24 22:50 ` [PATCH v3 09/39] kasan: define KASAN_GRANULE_PAGE Andrey Konovalov
2020-10-01 17:33   ` elver
2020-09-24 22:50 ` [PATCH v3 10/39] kasan: rename report and tags files Andrey Konovalov
2020-10-01 17:36   ` elver
2020-09-24 22:50 ` [PATCH v3 11/39] kasan: don't duplicate config dependencies Andrey Konovalov
2020-10-01 17:39   ` elver
2020-10-01 21:54     ` Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 12/39] kasan: hide invalid free check implementation Andrey Konovalov
2020-10-01 17:41   ` elver
2020-09-24 22:50 ` [PATCH v3 13/39] kasan: decode stack frame only with KASAN_STACK_ENABLE Andrey Konovalov
2020-10-01 17:43   ` elver
2020-09-24 22:50 ` [PATCH v3 14/39] kasan, arm64: only init shadow for software modes Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 15/39] kasan, arm64: only use kasan_depth " Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 16/39] kasan: rename addr_has_shadow to addr_has_metadata Andrey Konovalov
2020-10-01 17:45   ` elver
2020-09-24 22:50 ` [PATCH v3 17/39] kasan: rename print_shadow_for_address to print_memory_metadata Andrey Konovalov
2020-10-01 17:45   ` elver
2020-09-24 22:50 ` [PATCH v3 18/39] kasan: kasan_non_canonical_hook only for software modes Andrey Konovalov
2020-10-01 17:47   ` elver
2020-09-24 22:50 ` [PATCH v3 19/39] kasan: rename SHADOW layout macros to META Andrey Konovalov
2020-10-01 17:48   ` elver
2020-09-24 22:50 ` [PATCH v3 20/39] kasan: separate metadata_fetch_row for each mode Andrey Konovalov
2020-10-01 17:54   ` elver
2020-10-01 21:56     ` Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 21/39] kasan: don't allow SW_TAGS with ARM64_MTE Andrey Konovalov
2020-10-01 17:55   ` elver
2020-10-01 21:57     ` Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 22/39] kasan: introduce CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-10-01 17:57   ` elver
2020-09-24 22:50 ` [PATCH v3 23/39] arm64: Enable armv8.5-a asm-arch option Andrey Konovalov
2020-09-25 10:16   ` Catalin Marinas
2020-09-24 22:50 ` [PATCH v3 24/39] arm64: mte: Add in-kernel MTE helpers Andrey Konovalov
2020-09-25 10:15   ` Catalin Marinas
2020-09-25 11:28     ` Vincenzo Frascino
2020-09-25 12:50       ` Catalin Marinas
2020-09-25 13:36         ` Vincenzo Frascino
2020-09-24 22:50 ` [PATCH v3 25/39] arm64: kasan: Add arch layer for memory tagging helpers Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 26/39] arm64: mte: Add in-kernel tag fault handler Andrey Konovalov
2020-09-25 10:49   ` Catalin Marinas
2020-09-25 11:26     ` Andrey Konovalov
2020-09-25 11:47       ` Catalin Marinas
2020-09-25 11:52         ` Andrey Konovalov
2020-09-25 12:35           ` Catalin Marinas
2020-09-25 12:35   ` Catalin Marinas
2020-09-24 22:50 ` [PATCH v3 27/39] arm64: kasan: Enable in-kernel MTE Andrey Konovalov
2020-09-25 11:14   ` Catalin Marinas
2020-09-24 22:50 ` [PATCH v3 28/39] arm64: mte: Convert gcr_user into an exclude mask Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 29/39] arm64: mte: Switch GCR_EL1 in kernel entry and exit Andrey Konovalov
2020-09-25 11:34   ` Catalin Marinas
2020-09-25 11:50     ` Vincenzo Frascino [this message]
2020-09-25 12:38       ` Catalin Marinas
2020-09-24 22:50 ` [PATCH v3 30/39] arm64: kasan: Enable TBI EL1 Andrey Konovalov
2020-09-25 11:37   ` Catalin Marinas
2020-09-25 11:47     ` Vincenzo Frascino
2020-09-24 22:50 ` [PATCH v3 31/39] arm64: kasan: Align allocations for HW_TAGS Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 32/39] kasan: define KASAN_GRANULE_SIZE " Andrey Konovalov
2020-10-01 17:58   ` elver
2020-10-01 21:59     ` Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 33/39] kasan, x86, s390: update undef CONFIG_KASAN Andrey Konovalov
2020-10-01 17:59   ` elver
2020-09-24 22:50 ` [PATCH v3 34/39] kasan, arm64: expand CONFIG_KASAN checks Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 35/39] kasan, arm64: implement HW_TAGS runtime Andrey Konovalov
2020-10-01 18:00   ` elver
2020-09-24 22:50 ` [PATCH v3 36/39] kasan, arm64: print report from tag fault handler Andrey Konovalov
2020-09-25 11:39   ` Catalin Marinas
2020-09-24 22:50 ` [PATCH v3 37/39] kasan, slub: reset tags when accessing metadata Andrey Konovalov
2020-10-01 18:03   ` elver
2020-10-01 22:00     ` Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 38/39] kasan, arm64: enable CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-09-24 22:50 ` [PATCH v3 39/39] kasan: add documentation for hardware tag-based mode Andrey Konovalov
2020-10-01 18:03   ` elver

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e4624059-1598-17eb-2c64-3e7f26c2a1ba@arm.com \
    --to=vincenzo.frascino@arm.com \
    --cc=Branislav.Rankov@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=andreyknvl@google.com \
    --cc=aryabinin@virtuozzo.com \
    --cc=catalin.marinas@arm.com \
    --cc=dvyukov@google.com \
    --cc=elver@google.com \
    --cc=eugenis@google.com \
    --cc=glider@google.com \
    --cc=kasan-dev@googlegroups.com \
    --cc=kevin.brodsky@arm.com \
    --cc=lenaptr@google.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).