linux-arm-msm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
To: gregkh@linuxfoundation.org
Cc: hemantk@codeaurora.org, jhugo@codeaurora.org,
	bbhatt@codeaurora.org, linux-arm-msm@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	Randy Dunlap <rdunlap@infradead.org>,
	Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
Subject: [PATCH 01/18] bus: mhi: fix doubled words and struct image_info kernel-doc
Date: Mon, 21 Sep 2020 21:37:58 +0530	[thread overview]
Message-ID: <20200921160815.28071-3-manivannan.sadhasivam@linaro.org> (raw)
In-Reply-To: <20200921160815.28071-1-manivannan.sadhasivam@linaro.org>

From: Randy Dunlap <rdunlap@infradead.org>

Drop doubled word "table" in kernel-doc.
Fix syntax for the kernel-doc notation for struct image_info.
Note that the bhi_vec field is private and not part of the kernel-doc.

Drop doubled word "device" in a comment.

Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
Cc: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
Cc: Hemant Kumar <hemantk@codeaurora.org>
Cc: linux-arm-msm@vger.kernel.org
Reviewed-by: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
[mani: Added bus: prefix to the commit subject]
Signed-off-by: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
---
 include/linux/mhi.h | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/include/linux/mhi.h b/include/linux/mhi.h
index c4a940d98912..0779bc689b3e 100644
--- a/include/linux/mhi.h
+++ b/include/linux/mhi.h
@@ -85,13 +85,15 @@ enum mhi_ch_type {
 };
 
 /**
- * struct image_info - Firmware and RDDM table table
- * @mhi_buf - Buffer for firmware and RDDM table
- * @entries - # of entries in table
+ * struct image_info - Firmware and RDDM table
+ * @mhi_buf: Buffer for firmware and RDDM table
+ * @entries: # of entries in table
  */
 struct image_info {
 	struct mhi_buf *mhi_buf;
+	/* private: from internal.h */
 	struct bhi_vec_entry *bhi_vec;
+	/* public: */
 	u32 entries;
 };
 
@@ -593,7 +595,7 @@ int mhi_async_power_up(struct mhi_controller *mhi_cntrl);
 
 /**
  * mhi_sync_power_up - Start MHI power up sequence and wait till the device
- *                     device enters valid EE state
+ *                     enters valid EE state
  * @mhi_cntrl: MHI controller
  */
 int mhi_sync_power_up(struct mhi_controller *mhi_cntrl);
-- 
2.17.1


  parent reply	other threads:[~2020-09-21 16:08 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-21 16:07 [PATCH 00/18] MHI changes for v5.10 Manivannan Sadhasivam
2020-09-21 16:07 ` [PATCH] bus: mhi: core: Fix the building of MHI module Manivannan Sadhasivam
2020-09-21 16:13   ` Manivannan Sadhasivam
2020-09-21 16:07 ` Manivannan Sadhasivam [this message]
2020-09-21 16:07 ` [PATCH 02/18] bus: mhi: core: Remove double occurrence for mhi_ctrl_ev_task() declaration Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 03/18] bus: mhi: core: Abort suspends due to outgoing pending packets Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 04/18] bus: mhi: core: Use helper API to trigger a non-blocking host resume Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 05/18] bus: mhi: core: Trigger host resume if suspended during mhi_device_get() Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 06/18] bus: mhi: core: Use generic name field for an MHI device Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 07/18] bus: mhi: core: Introduce helper function to check device state Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 08/18] bus: mhi: core: Introduce counters to track MHI device state transitions Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 09/18] bus: mhi: core: Read and save device hardware information from BHI Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 10/18] bus: mhi: core: Introduce APIs to allocate and free the MHI controller Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 11/18] bus: mhi: core: Add const qualifier to MHI config information Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 12/18] bus: mhi: Remove include of rwlock_types.h Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 13/18] bus: mhi: Fix entries based on Kconfig coding style Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 14/18] bus: mhi: core: Introduce debugfs entries for MHI Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 15/18] bus: mhi: core: Introduce sysfs " Manivannan Sadhasivam
2020-09-27 10:26   ` Greg KH
2020-09-28  3:44     ` Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 16/18] bus: mhi: core: Allow shared IRQ for event rings Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 17/18] bus: mhi: Remove unused nr_irqs_req variable Manivannan Sadhasivam
2020-09-21 16:08 ` [PATCH 18/18] bus: mhi: core: Fix the building of MHI module Manivannan Sadhasivam
2020-09-27 10:22   ` Greg KH
2020-09-28  3:45     ` Manivannan Sadhasivam

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200921160815.28071-3-manivannan.sadhasivam@linaro.org \
    --to=manivannan.sadhasivam@linaro.org \
    --cc=bbhatt@codeaurora.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hemantk@codeaurora.org \
    --cc=jhugo@codeaurora.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rdunlap@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).