linux-bcache.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc()
@ 2020-06-17 22:33 Gustavo A. R. Silva
  2020-06-17 22:33 ` Gustavo A. R. Silva
  2020-06-20 14:17 ` Coly Li
  0 siblings, 2 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2020-06-17 22:33 UTC (permalink / raw)
  To: Coly Li, Kent Overstreet; +Cc: linux-bcache, linux-kernel, Gustavo A. R. Silva

Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes.

This code was detected with the help of Coccinelle and, audited and
fixed manually.

Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/md/bcache/movinggc.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/md/bcache/movinggc.c b/drivers/md/bcache/movinggc.c
index 7891fb512736..b7dd2d75f58c 100644
--- a/drivers/md/bcache/movinggc.c
+++ b/drivers/md/bcache/movinggc.c
@@ -145,8 +145,8 @@ static void read_moving(struct cache_set *c)
 			continue;
 		}
 
-		io = kzalloc(sizeof(struct moving_io) + sizeof(struct bio_vec)
-			     * DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS),
+		io = kzalloc(struct_size(io, bio.bio.bi_inline_vecs,
+					 DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS)),
 			     GFP_KERNEL);
 		if (!io)
 			goto err;
-- 
2.27.0

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc()
  2020-06-17 22:33 [PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc() Gustavo A. R. Silva
@ 2020-06-17 22:33 ` Gustavo A. R. Silva
  2020-06-20 14:17 ` Coly Li
  1 sibling, 0 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2020-06-17 22:33 UTC (permalink / raw)
  To: Coly Li, Kent Overstreet; +Cc: linux-bcache, linux-kernel, Gustavo A. R. Silva

Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes.

This code was detected with the help of Coccinelle and, audited and
fixed manually.

Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/md/bcache/movinggc.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/md/bcache/movinggc.c b/drivers/md/bcache/movinggc.c
index 7891fb512736..b7dd2d75f58c 100644
--- a/drivers/md/bcache/movinggc.c
+++ b/drivers/md/bcache/movinggc.c
@@ -145,8 +145,8 @@ static void read_moving(struct cache_set *c)
 			continue;
 		}
 
-		io = kzalloc(sizeof(struct moving_io) + sizeof(struct bio_vec)
-			     * DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS),
+		io = kzalloc(struct_size(io, bio.bio.bi_inline_vecs,
+					 DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS)),
 			     GFP_KERNEL);
 		if (!io)
 			goto err;
-- 
2.27.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc()
  2020-06-17 22:33 [PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc() Gustavo A. R. Silva
  2020-06-17 22:33 ` Gustavo A. R. Silva
@ 2020-06-20 14:17 ` Coly Li
  2020-06-20 14:17   ` Coly Li
  1 sibling, 1 reply; 4+ messages in thread
From: Coly Li @ 2020-06-20 14:17 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Kent Overstreet, linux-bcache, linux-kernel, Gustavo A. R. Silva

On 2020/6/18 06:33, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

The patch looks good to me, and I assume you already test and verify the
change. I will add them in my for-test directory.

Thanks.

Coly Li

> ---
>  drivers/md/bcache/movinggc.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/md/bcache/movinggc.c b/drivers/md/bcache/movinggc.c
> index 7891fb512736..b7dd2d75f58c 100644
> --- a/drivers/md/bcache/movinggc.c
> +++ b/drivers/md/bcache/movinggc.c
> @@ -145,8 +145,8 @@ static void read_moving(struct cache_set *c)
>  			continue;
>  		}
>  
> -		io = kzalloc(sizeof(struct moving_io) + sizeof(struct bio_vec)
> -			     * DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS),
> +		io = kzalloc(struct_size(io, bio.bio.bi_inline_vecs,
> +					 DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS)),
>  			     GFP_KERNEL);
>  		if (!io)
>  			goto err;
> 

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc()
  2020-06-20 14:17 ` Coly Li
@ 2020-06-20 14:17   ` Coly Li
  0 siblings, 0 replies; 4+ messages in thread
From: Coly Li @ 2020-06-20 14:17 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Kent Overstreet, linux-bcache, linux-kernel, Gustavo A. R. Silva

On 2020/6/18 06:33, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

The patch looks good to me, and I assume you already test and verify the
change. I will add them in my for-test directory.

Thanks.

Coly Li

> ---
>  drivers/md/bcache/movinggc.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/md/bcache/movinggc.c b/drivers/md/bcache/movinggc.c
> index 7891fb512736..b7dd2d75f58c 100644
> --- a/drivers/md/bcache/movinggc.c
> +++ b/drivers/md/bcache/movinggc.c
> @@ -145,8 +145,8 @@ static void read_moving(struct cache_set *c)
>  			continue;
>  		}
>  
> -		io = kzalloc(sizeof(struct moving_io) + sizeof(struct bio_vec)
> -			     * DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS),
> +		io = kzalloc(struct_size(io, bio.bio.bi_inline_vecs,
> +					 DIV_ROUND_UP(KEY_SIZE(&w->key), PAGE_SECTORS)),
>  			     GFP_KERNEL);
>  		if (!io)
>  			goto err;
> 


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-06-22 14:28 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-17 22:33 [PATCH][next] bcache: movinggc: Use struct_size() helper in kzalloc() Gustavo A. R. Silva
2020-06-17 22:33 ` Gustavo A. R. Silva
2020-06-20 14:17 ` Coly Li
2020-06-20 14:17   ` Coly Li

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).