linux-block.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/2 v2] Small cleanups
@ 2019-10-21  3:40 Damien Le Moal
  2019-10-21  3:40 ` [PATCH 1/2 v2] nvme: Cleanup and rename nvme_block_nr() Damien Le Moal
                   ` (2 more replies)
  0 siblings, 3 replies; 9+ messages in thread
From: Damien Le Moal @ 2019-10-21  3:40 UTC (permalink / raw)
  To: linux-nvme, Christoph Hellwig, Keith Busch, Sagi Grimberg,
	linux-block, Jens Axboe

This is series is a couple of cleanup patches. The first one cleans up
the helper function nvme_block_nr() using SECTOR_SHIFT instead of the
hard coded value 9 and clarifies the helper role by renaming it to
nvme_sect_to_lba(). The second patch introduces the nvme_lba_to_sect()
helper to convert a device logical block number into a 512B sector
value.

Please consider this series for kernel 5.5.

Damien Le Moal (2):
  nvme: Cleanup and rename nvme_block_nr()
  nvme: Introduce nvme_lba_to_sect()

 drivers/nvme/host/core.c | 20 ++++++++++----------
 drivers/nvme/host/nvme.h | 15 +++++++++++++--
 2 files changed, 23 insertions(+), 12 deletions(-)

Changes from v1:
* Renamed the helpers to a clearer function name.

-- 
2.21.0


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2019-10-21 13:55 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-21  3:40 [PATCH 0/2 v2] Small cleanups Damien Le Moal
2019-10-21  3:40 ` [PATCH 1/2 v2] nvme: Cleanup and rename nvme_block_nr() Damien Le Moal
2019-10-21  3:44   ` Christoph Hellwig
2019-10-21  3:44     ` Christoph Hellwig
2019-10-21  7:14   ` Johannes Thumshirn
2019-10-21  3:40 ` [PATCH 2/2 v2] nvme: Introduce nvme_lba_to_sect() Damien Le Moal
2019-10-21  3:44   ` Christoph Hellwig
2019-10-21  7:14   ` Johannes Thumshirn
2019-10-21 13:55 ` [PATCH 0/2 v2] Small cleanups Keith Busch

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).