linux-block.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] block: fix userspace documentation reference for del_gendisk()
@ 2020-11-17 14:06 Luis Chamberlain
  2021-04-23 18:38 ` Luis Chamberlain
  2021-04-23 18:56 ` Bart Van Assche
  0 siblings, 2 replies; 3+ messages in thread
From: Luis Chamberlain @ 2020-11-17 14:06 UTC (permalink / raw)
  To: axboe
  Cc: bvanassche, ming.lei, hch, jack, linux-block, linux-kernel,
	Luis Chamberlain

Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount
helpers") has a typo where it references drivers for del_gendisk() when we
instead meant userspace, as the reference is to the userspace experience.
This fixes this.

Signed-off-by: Luis Chamberlain <mcgrof@kernel.org>
---
 block/genhd.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/block/genhd.c b/block/genhd.c
index 0a273211fec2..9511620f558a 100644
--- a/block/genhd.c
+++ b/block/genhd.c
@@ -880,8 +880,8 @@ static void invalidate_partition(struct gendisk *disk, int partno)
  * with put_disk(), which should be called after del_gendisk(), if
  * __device_add_disk() was used.
  *
- * Drivers exist which depend on the release of the gendisk to be synchronous,
- * it should not be deferred.
+ * Userspace may exist which depends on the release of the gendisk to be
+ * synchronous, it should not be deferred.
  *
  * Context: can sleep
  */
-- 
2.28.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] block: fix userspace documentation reference for del_gendisk()
  2020-11-17 14:06 [PATCH] block: fix userspace documentation reference for del_gendisk() Luis Chamberlain
@ 2021-04-23 18:38 ` Luis Chamberlain
  2021-04-23 18:56 ` Bart Van Assche
  1 sibling, 0 replies; 3+ messages in thread
From: Luis Chamberlain @ 2021-04-23 18:38 UTC (permalink / raw)
  To: axboe; +Cc: bvanassche, ming.lei, hch, jack, linux-block, linux-kernel

*Poke*

This documentation fix is not merged yet.

 Luis

On Tue, Nov 17, 2020 at 02:06:58PM +0000, Luis Chamberlain wrote:
> Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount
> helpers") has a typo where it references drivers for del_gendisk() when we
> instead meant userspace, as the reference is to the userspace experience.
> This fixes this.
> 
> Signed-off-by: Luis Chamberlain <mcgrof@kernel.org>
> ---
>  block/genhd.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/block/genhd.c b/block/genhd.c
> index 0a273211fec2..9511620f558a 100644
> --- a/block/genhd.c
> +++ b/block/genhd.c
> @@ -880,8 +880,8 @@ static void invalidate_partition(struct gendisk *disk, int partno)
>   * with put_disk(), which should be called after del_gendisk(), if
>   * __device_add_disk() was used.
>   *
> - * Drivers exist which depend on the release of the gendisk to be synchronous,
> - * it should not be deferred.
> + * Userspace may exist which depends on the release of the gendisk to be
> + * synchronous, it should not be deferred.
>   *
>   * Context: can sleep
>   */
> -- 
> 2.28.0
> 

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] block: fix userspace documentation reference for del_gendisk()
  2020-11-17 14:06 [PATCH] block: fix userspace documentation reference for del_gendisk() Luis Chamberlain
  2021-04-23 18:38 ` Luis Chamberlain
@ 2021-04-23 18:56 ` Bart Van Assche
  1 sibling, 0 replies; 3+ messages in thread
From: Bart Van Assche @ 2021-04-23 18:56 UTC (permalink / raw)
  To: Luis Chamberlain, axboe; +Cc: ming.lei, hch, jack, linux-block, linux-kernel

On 11/17/20 6:06 AM, Luis Chamberlain wrote:
> Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount
> helpers") has a typo where it references drivers for del_gendisk() when we
> instead meant userspace, as the reference is to the userspace experience.
> This fixes this.
> 
> Signed-off-by: Luis Chamberlain <mcgrof@kernel.org>
> ---
>  block/genhd.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/block/genhd.c b/block/genhd.c
> index 0a273211fec2..9511620f558a 100644
> --- a/block/genhd.c
> +++ b/block/genhd.c
> @@ -880,8 +880,8 @@ static void invalidate_partition(struct gendisk *disk, int partno)
>   * with put_disk(), which should be called after del_gendisk(), if
>   * __device_add_disk() was used.
>   *
> - * Drivers exist which depend on the release of the gendisk to be synchronous,
> - * it should not be deferred.
> + * Userspace may exist which depends on the release of the gendisk to be
> + * synchronous, it should not be deferred.

Please change "may exist which depends" into "software may depend" to
make the comment easier to understand.

Thanks,

Bart.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-04-23 18:56 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-17 14:06 [PATCH] block: fix userspace documentation reference for del_gendisk() Luis Chamberlain
2021-04-23 18:38 ` Luis Chamberlain
2021-04-23 18:56 ` Bart Van Assche

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).