From: Ulf Hansson <firstname.lastname@example.org> To: Eric Biggers <email@example.com> Cc: linux-block <firstname.lastname@example.org>, linux-mmc <email@example.com>, linux-scsi <firstname.lastname@example.org>, email@example.com, Satya Tangirala <firstname.lastname@example.org> Subject: Re: [PATCH 4/5] blk-crypto: rename blk_keyslot_manager to blk_crypto_profile Date: Tue, 14 Sep 2021 11:04:20 +0200 [thread overview] Message-ID: <CAPDyKFpvZAQ+5niZkw2tk-q_6w=VAuK=P-OVGjQA7QbJW7OvgQ@mail.gmail.com> (raw) In-Reply-To: <email@example.com> On Mon, 13 Sept 2021 at 03:35, Eric Biggers <firstname.lastname@example.org> wrote: > > From: Eric Biggers <email@example.com> > > blk_keyslot_manager is misnamed because it doesn't necessarily manage > keyslots. It actually does several different things: > > - Contains the crypto capabilities of the device. > > - Provides functions to control the inline encryption hardware. > Originally these were just for programming/evicting keyslots; > however, new functionality (hardware-wrapped keys) will require new > functions here which are unrelated to keyslots. Moreover, > device-mapper devices already (ab)use "keyslot_evict" to pass key > eviction requests to their underlying devices even though > device-mapper devices don't have any keyslots themselves (so it > really should be "evict_key", not "keyslot_evict"). > > - Sometimes (but not always!) it manages keyslots. Originally it > always did, but device-mapper devices don't have keyslots > themselves, so they use a "passthrough keyslot manager" which > doesn't actually manage keyslots. This hack works, but the > terminology is unnatural. Also, some hardware doesn't have keyslots > and thus also uses a "passthrough keyslot manager" (support for such > hardware is yet to be upstreamed, but it will happen eventually). > > Let's stop having keyslot managers which don't actually manage keyslots. > Instead, rename blk_keyslot_manager to blk_crypto_profile. > > This is a fairly big change, since for consistency it also has to update > keyslot manager-related function names, variable names, and comments -- > not just the actual struct name. However it's still a fairly > straightforward change, as it doesn't change any actual functionality. > > Signed-off-by: Eric Biggers <firstname.lastname@example.org> > --- > block/blk-crypto-fallback.c | 60 ++-- > block/blk-crypto-profile.c | 518 ++++++++++++++--------------- > block/blk-crypto.c | 25 +- > block/blk-integrity.c | 2 +- > drivers/md/dm-core.h | 2 +- > drivers/md/dm-table.c | 168 +++++----- > drivers/md/dm.c | 8 +- > drivers/mmc/core/crypto.c | 11 +- > drivers/mmc/host/cqhci-crypto.c | 31 +- > drivers/scsi/ufs/ufshcd-crypto.c | 32 +- > drivers/scsi/ufs/ufshcd-crypto.h | 9 +- > drivers/scsi/ufs/ufshcd.c | 2 +- > drivers/scsi/ufs/ufshcd.h | 4 +- > include/linux/blk-crypto-profile.h | 164 +++++---- > include/linux/blkdev.h | 18 +- > include/linux/device-mapper.h | 4 +- > include/linux/mmc/host.h | 2 +- > 17 files changed, 548 insertions(+), 512 deletions(-) > Acked-by: Ulf Hansson <email@example.com> # For MMC [...] Kind regards Uffe
next prev parent reply other threads:[~2021-09-14 9:04 UTC|newest] Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-09-13 1:31 [PATCH 0/5] blk-crypto cleanups Eric Biggers 2021-09-13 1:31 ` [PATCH 1/5] blk-crypto-fallback: properly prefix function and struct names Eric Biggers 2021-09-15 7:36 ` Christoph Hellwig 2021-09-13 1:31 ` [PATCH 2/5] blk-crypto-fallback: consolidate static variables Eric Biggers 2021-09-15 7:39 ` Christoph Hellwig 2021-09-15 17:50 ` Eric Biggers 2021-09-16 7:39 ` Christoph Hellwig 2021-09-16 17:28 ` Eric Biggers 2021-09-13 1:31 ` [PATCH 3/5] blk-crypto: rename keyslot-manager files to blk-crypto-profile Eric Biggers 2021-09-14 9:04 ` Ulf Hansson 2021-09-15 7:45 ` Christoph Hellwig 2021-09-15 17:40 ` Eric Biggers 2021-09-16 7:42 ` Christoph Hellwig 2021-09-13 1:31 ` [PATCH 4/5] blk-crypto: rename blk_keyslot_manager to blk_crypto_profile Eric Biggers 2021-09-14 9:04 ` Ulf Hansson [this message] 2021-09-14 21:52 ` Eric Biggers 2021-09-13 1:31 ` [PATCH 5/5] blk-crypto: update inline encryption documentation Eric Biggers
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to='CAPDyKFpvZAQ+5niZkw2tk-q_6w=VAuK=P-OVGjQA7QbJW7OvgQ@mail.gmail.com' \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --subject='Re: [PATCH 4/5] blk-crypto: rename blk_keyslot_manager to blk_crypto_profile' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).