Linux-Bluetooth Archive on
 help / color / Atom feed
* [Bug 207843] New: Some ACPI discovered BRCM HCI UART chip write clock failed.
@ 2020-05-22  2:56 bugzilla-daemon
  0 siblings, 0 replies; only message in thread
From: bugzilla-daemon @ 2020-05-22  2:56 UTC (permalink / raw)
  To: linux-bluetooth

            Bug ID: 207843
           Summary: Some ACPI discovered BRCM HCI UART chip write clock
           Product: Drivers
           Version: 2.5
    Kernel Version: 5.6.13
          Hardware: All
                OS: Linux
              Tree: Mainline
            Status: NEW
          Severity: low
          Priority: P1
         Component: Bluetooth
        Regression: No

Created attachment 289213
dmesg output

>>My tablet uses AP6255 wifi/bluetooth module with BCM43455 chip.
>>The bluetooth controller worked well except bluetooth headset play sound
>>glitch.It's not configuration problem in bluez or pulseaudio.
>>Some log in dmesg indicated that baud rate was not correctly configured. 
>>>Bluetooth: BCM: failed to write clock (-56)
>>>Bluetooth: Failed to set baudrate.

>Steps to Reproduce:
>>1. Power on bluetooth headset.
>>2. If it was not automatically connect, connect to headset by bluetoothctl.
>>3. play sound.
>Actual Results:
>>sound glitches.
>Expect Results:
>>sound well.
>Additional Information: 
>>I suspect the baud rate was too low to transmit audio.
>>It seems the chip can't support write clock HCI command. Then bluetooth
>>driver used default 115200 baud rate.
>>I tried to force configure 4Mbps baud rate to my chip after write clock
>>failed, but reset it failed.  Then I hardcode baud rate to 3Mbps, it solved
>>the glitch problem. 
>>And I found the commit that introduced the 4Mbsp to ACPI device:
>>It seems not all ACPI discovered devices can support write clock.
>>So maybe the driver should fallback baud rate to 3Mbps if write clock failed.

Smiles ^__________^ zech

You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-22  2:56 [Bug 207843] New: Some ACPI discovered BRCM HCI UART chip write clock failed bugzilla-daemon

Linux-Bluetooth Archive on

Archives are clonable:
	git clone --mirror linux-bluetooth/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-bluetooth linux-bluetooth/ \
	public-inbox-index linux-bluetooth

Example config snippet for mirrors

Newsgroup available over NNTP:

AGPL code for this site: git clone