linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/6] cleanup property and extended attribute set
@ 2019-04-12  8:02 Anand Jain
  2019-04-12  8:02 ` [PATCH 1/6] btrfs: rename btrfs_setxattr to btrfs_setxattr_trans Anand Jain
                   ` (7 more replies)
  0 siblings, 8 replies; 13+ messages in thread
From: Anand Jain @ 2019-04-12  8:02 UTC (permalink / raw)
  To: linux-btrfs

In an attempt to stream line the property and extended attribute set here
are the few cleanup patches.

 1/6 to 3/6 are mostly non functional cleanups (except for the conversion
  to non static function in 3/6) and can be merged together.
 4/6 removes the readonly root check in btrfs_setxattr() more details in
  the change log.
 5/6 as now we have btrfs_setxattr() and btrfs_setxattr_trans() for the
  threads with transaction and without transaction respectively, so this
  patch uses them.
 6/6 as 5/6 as diverted the threads with transaction to btrfs_setxattr(),
  now btrfs_setxattr_trans() can drop the trans arg.

Anand Jain (6):
  btrfs: rename btrfs_setxattr to btrfs_setxattr_trans
  btrfs: rename do_setxattr to btrfs_setxattr
  btrfs: declare btrfs_setxattr as a non static function
  btrfs: remove redundant readonly root check in btrfs_setxattr_trans
  btrfs: split thread with trans to use btrfs_setxattr
  btrfs: cleanup btrfs_setxattr_trans drop trans arg

 fs/btrfs/acl.c   |  6 +++++-
 fs/btrfs/props.c | 25 +++++++++++++++++++------
 fs/btrfs/xattr.c | 25 ++++++++++---------------
 fs/btrfs/xattr.h |  7 ++++---
 4 files changed, 38 insertions(+), 25 deletions(-)

-- 
2.17.1


^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2019-04-17 10:40 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-04-12  8:02 [PATCH 0/6] cleanup property and extended attribute set Anand Jain
2019-04-12  8:02 ` [PATCH 1/6] btrfs: rename btrfs_setxattr to btrfs_setxattr_trans Anand Jain
2019-04-12  8:02 ` [PATCH 2/6] btrfs: rename do_setxattr to btrfs_setxattr Anand Jain
2019-04-12  8:02 ` [PATCH 3/6] btrfs: declare btrfs_setxattr as a non static function Anand Jain
2019-04-12  8:02 ` [PATCH 4/6] btrfs: remove redundant readonly root check in btrfs_setxattr_trans Anand Jain
2019-04-12  8:02 ` [PATCH 5/6] btrfs: split thread with trans to use btrfs_setxattr Anand Jain
2019-04-12  8:02 ` [PATCH 6/6] btrfs: cleanup btrfs_setxattr_trans drop trans arg Anand Jain
2019-04-12  9:33 ` [PATCH 0/6] cleanup property and extended attribute set Anand Jain
2019-04-15 19:01 ` David Sterba
2019-04-15 22:01   ` Anand Jain
2019-04-17  9:31     ` David Sterba
2019-04-17 10:24       ` Anand Jain
2019-04-17 10:40       ` Anand Jain

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).