linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Qu Wenruo <wqu@suse.com>
To: linux-btrfs@vger.kernel.org
Subject: Re: [PATCH 0/2] btrfs: paramater refactors for data and metadata endio call backs
Date: Mon, 9 Nov 2020 19:57:31 +0800	[thread overview]
Message-ID: <7c86d1d7-8736-1558-6fe3-dbf96a5acd44@suse.com> (raw)
In-Reply-To: <20201109115410.605880-1-wqu@suse.com>


[-- Attachment #1.1: Type: text/plain, Size: 1634 bytes --]



On 2020/11/9 下午7:54, Qu Wenruo wrote:
> This is another cleanup exposed when I'm fixing my subpage patchset.
> 
> Dating back to the old time where we still have hooks for data/metadata
> endio, we have a parameter called @phy_offset for both hooks.
> 
> That @phy_offset is the number of sectors compared to the bio on-disk

Well, phy_offset is the number of *bytes*, other than sectors.

I guess the mistake has already prove the point, it's really easy to get
screwed up for the @phy_offset and @icsum bad naming.

Thanks,
Qu

> bytenr, and is used to grab the csum from btrfs_io_bio.
> 
> This is far from straightforward, and costs reader tons of time to grasp
> the basic.
> 
> This patchset will change it by:
> - Remove phy_offset completely for metadata
>   Since metadata doesn't use btrfs_io_bio::csums[] at all, there is no
>   need for it.
> 
> - Use @disk_bytenr to replace @phy_offset/@icsum
>   Let the callee, check_data_csum() to calculate the offset from
>   @disk_bytenr and bio to get the csum offset.
> 
> Also, since we know the @disk_bytenr should alwasy be inside the bio
> range, add ASSERT() to check such assumption.
> 
> Qu Wenruo (2):
>   btrfs: remove the phy_offset parameter for
>     btrfs_validate_metadata_buffer()
>   btrfs: use more straightforward disk_bytenr to replace icsum for
>     check_data_csum()
> 
>  fs/btrfs/disk-io.c   |  2 +-
>  fs/btrfs/disk-io.h   |  2 +-
>  fs/btrfs/extent_io.c | 16 +++++++++-------
>  fs/btrfs/inode.c     | 35 ++++++++++++++++++++++++++---------
>  4 files changed, 37 insertions(+), 18 deletions(-)
> 


[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

      parent reply	other threads:[~2020-11-09 11:57 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-09 11:54 [PATCH 0/2] btrfs: paramater refactors for data and metadata endio call backs Qu Wenruo
2020-11-09 11:54 ` [PATCH 1/2] btrfs: remove the phy_offset parameter for btrfs_validate_metadata_buffer() Qu Wenruo
2020-11-09 12:21   ` Nikolay Borisov
2020-11-09 11:54 ` [PATCH 2/2] btrfs: use more straightforward disk_bytenr to replace icsum for check_data_csum() Qu Wenruo
2020-11-09 12:19   ` Nikolay Borisov
2020-11-09 12:34     ` Qu Wenruo
2020-11-09 11:57 ` Qu Wenruo [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7c86d1d7-8736-1558-6fe3-dbf96a5acd44@suse.com \
    --to=wqu@suse.com \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).