devicetree.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] arm64: dts: imx8m: use generic name for tmu
@ 2020-10-22  7:21 peng.fan
  2020-10-22  9:06 ` Krzysztof Kozlowski
  0 siblings, 1 reply; 2+ messages in thread
From: peng.fan @ 2020-10-22  7:21 UTC (permalink / raw)
  To: shawnguo, s.hauer, festevam, robh+dt
  Cc: kernel, linux-imx, linux-arm-kernel, linux-kernel, devicetree,
	marex, Peng Fan

From: Peng Fan <peng.fan@nxp.com>

Per devicetree specification, generic names are recommended
to be used, such as temperature-sensor.

Signed-off-by: Peng Fan <peng.fan@nxp.com>
---
 arch/arm64/boot/dts/freescale/imx8mm.dtsi | 2 +-
 arch/arm64/boot/dts/freescale/imx8mn.dtsi | 2 +-
 arch/arm64/boot/dts/freescale/imx8mp.dtsi | 2 +-
 arch/arm64/boot/dts/freescale/imx8mq.dtsi | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/arm64/boot/dts/freescale/imx8mm.dtsi b/arch/arm64/boot/dts/freescale/imx8mm.dtsi
index b83f400def8b..327f1d44ced9 100644
--- a/arch/arm64/boot/dts/freescale/imx8mm.dtsi
+++ b/arch/arm64/boot/dts/freescale/imx8mm.dtsi
@@ -404,7 +404,7 @@ gpio5: gpio@30240000 {
 				gpio-ranges = <&iomuxc 0 119 30>;
 			};
 
-			tmu: tmu@30260000 {
+			tmu: temperature-sensor@30260000 {
 				compatible = "fsl,imx8mm-tmu";
 				reg = <0x30260000 0x10000>;
 				clocks = <&clk IMX8MM_CLK_TMU_ROOT>;
diff --git a/arch/arm64/boot/dts/freescale/imx8mn.dtsi b/arch/arm64/boot/dts/freescale/imx8mn.dtsi
index 746faf1cf2fb..994fcb021b8f 100644
--- a/arch/arm64/boot/dts/freescale/imx8mn.dtsi
+++ b/arch/arm64/boot/dts/freescale/imx8mn.dtsi
@@ -311,7 +311,7 @@ gpio5: gpio@30240000 {
 				gpio-ranges = <&iomuxc 0 119 30>;
 			};
 
-			tmu: tmu@30260000 {
+			tmu: temperature-sensor@30260000 {
 				compatible = "fsl,imx8mn-tmu", "fsl,imx8mm-tmu";
 				reg = <0x30260000 0x10000>;
 				clocks = <&clk IMX8MN_CLK_TMU_ROOT>;
diff --git a/arch/arm64/boot/dts/freescale/imx8mp.dtsi b/arch/arm64/boot/dts/freescale/imx8mp.dtsi
index 6038f66aefc1..2a16016b1cf4 100644
--- a/arch/arm64/boot/dts/freescale/imx8mp.dtsi
+++ b/arch/arm64/boot/dts/freescale/imx8mp.dtsi
@@ -288,7 +288,7 @@ gpio5: gpio@30240000 {
 				gpio-ranges = <&iomuxc 0 114 30>;
 			};
 
-			tmu: tmu@30260000 {
+			tmu: temperature-sensor@30260000 {
 				compatible = "fsl,imx8mp-tmu";
 				reg = <0x30260000 0x10000>;
 				clocks = <&clk IMX8MP_CLK_TSENSOR_ROOT>;
diff --git a/arch/arm64/boot/dts/freescale/imx8mq.dtsi b/arch/arm64/boot/dts/freescale/imx8mq.dtsi
index 5e0e7d0f1bc4..ab57839a3de1 100644
--- a/arch/arm64/boot/dts/freescale/imx8mq.dtsi
+++ b/arch/arm64/boot/dts/freescale/imx8mq.dtsi
@@ -420,7 +420,7 @@ gpio5: gpio@30240000 {
 				gpio-ranges = <&iomuxc 0 119 30>;
 			};
 
-			tmu: tmu@30260000 {
+			tmu: temperature-sensor@30260000 {
 				compatible = "fsl,imx8mq-tmu";
 				reg = <0x30260000 0x10000>;
 				interrupts = <GIC_SPI 49 IRQ_TYPE_LEVEL_HIGH>;
-- 
2.28.0


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] arm64: dts: imx8m: use generic name for tmu
  2020-10-22  7:21 [PATCH] arm64: dts: imx8m: use generic name for tmu peng.fan
@ 2020-10-22  9:06 ` Krzysztof Kozlowski
  0 siblings, 0 replies; 2+ messages in thread
From: Krzysztof Kozlowski @ 2020-10-22  9:06 UTC (permalink / raw)
  To: peng.fan
  Cc: shawnguo, s.hauer, festevam, robh+dt, kernel, linux-imx,
	linux-arm-kernel, linux-kernel, devicetree, marex

On Thu, Oct 22, 2020 at 03:21:18PM +0800, peng.fan@nxp.com wrote:
> From: Peng Fan <peng.fan@nxp.com>
> 
> Per devicetree specification, generic names are recommended
> to be used, such as temperature-sensor.
> 
> Signed-off-by: Peng Fan <peng.fan@nxp.com>
> ---
>  arch/arm64/boot/dts/freescale/imx8mm.dtsi | 2 +-
>  arch/arm64/boot/dts/freescale/imx8mn.dtsi | 2 +-
>  arch/arm64/boot/dts/freescale/imx8mp.dtsi | 2 +-
>  arch/arm64/boot/dts/freescale/imx8mq.dtsi | 2 +-
>  4 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/arch/arm64/boot/dts/freescale/imx8mm.dtsi b/arch/arm64/boot/dts/freescale/imx8mm.dtsi
> index b83f400def8b..327f1d44ced9 100644
> --- a/arch/arm64/boot/dts/freescale/imx8mm.dtsi
> +++ b/arch/arm64/boot/dts/freescale/imx8mm.dtsi
> @@ -404,7 +404,7 @@ gpio5: gpio@30240000 {
>  				gpio-ranges = <&iomuxc 0 119 30>;
>  			};
>  
> -			tmu: tmu@30260000 {
> +			tmu: temperature-sensor@30260000 {

No, TMU is not a temperature-sensor. It does much more. TMU is quite
generic name for this class of device.

Best regards,
Krzysztof

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-10-22  9:06 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-22  7:21 [PATCH] arm64: dts: imx8m: use generic name for tmu peng.fan
2020-10-22  9:06 ` Krzysztof Kozlowski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).