linux-edac.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Borislav Petkov <bp@alien8.de>
To: Robert Richter <rrichter@marvell.com>
Cc: Mauro Carvalho Chehab <mchehab@kernel.org>,
	Tony Luck <tony.luck@intel.com>,
	James Morse <james.morse@arm.com>,
	Aristeu Rozanski <aris@redhat.com>,
	Matthias Brugger <mbrugger@suse.com>,
	linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 04/10] EDAC/ghes: Make SMBIOS handle private data to ghes
Date: Fri, 24 Apr 2020 18:21:57 +0200	[thread overview]
Message-ID: <20200424162157.GB6916@zn.tnic> (raw)
In-Reply-To: <20200422115814.22205-5-rrichter@marvell.com>

On Wed, Apr 22, 2020 at 01:58:08PM +0200, Robert Richter wrote:
> diff --git a/drivers/edac/ghes_edac.c b/drivers/edac/ghes_edac.c
> index 39efce0df881..23adb7674f9b 100644
> --- a/drivers/edac/ghes_edac.c
> +++ b/drivers/edac/ghes_edac.c
> @@ -15,6 +15,12 @@
>  #include "edac_module.h"
>  #include <ras/ras_event.h>
>  
> +struct ghes_dimm {

Simply struct dimm

> +	struct list_head entry;
> +	struct dimm_info *dimm;
> +	u16 handle;
> +};
> +
>  struct ghes_mci {
>  	struct mem_ctl_info *mci;
>  
> @@ -42,6 +48,16 @@ static DEFINE_MUTEX(ghes_reg_mutex);
>   */
>  static DEFINE_SPINLOCK(ghes_lock);
>  
> +/*
> + * Locking:
> + *
> + *  dimms, ghes_dimm_pool:  ghes_reg_mutex
> + *  ghes_dimm_list:         ghes_lock
> + */
> +static struct ghes_dimm *dimms;
> +static LIST_HEAD(ghes_dimm_list);
> +static LIST_HEAD(ghes_dimm_pool);

Those are static lists, no need to prefix them with "ghes_". There's too
much "ghes" in that code. :)

> +
>  /* "ghes_edac.force_load=1" skips the platform check */
>  static bool __read_mostly force_load;
>  module_param(force_load, bool, 0);
> @@ -72,11 +88,63 @@ struct memdev_dmi_entry {
>  	u16 conf_mem_clk_speed;
>  } __attribute__((__packed__));
>  
> -struct ghes_edac_dimm_fill {
> +struct dimm_fill {
> +	struct list_head dimms;
>  	struct mem_ctl_info *mci;
>  	unsigned int count;
>  };
>  
> +static int ghes_dimm_pool_create(int num_dimm)

Yeah, drop "ghes_" here too. I'm not going to comment on this in the
rest of the patchset but for the next version, please drop the "ghes_"
prefix from static functions and members - it unnecessarily gets in the
way when reading the code.

> +{
> +	struct ghes_dimm *ghes_dimm;
> +
> +	if (!num_dimm)
> +		return 0;
> +
> +	lockdep_assert_held(ghes_reg_mutex);
> +
> +	dimms = kcalloc(num_dimm, sizeof(*dimms), GFP_KERNEL);
> +	if (!dimms)
> +		return -ENOMEM;
> +
> +	for (ghes_dimm = dimms; ghes_dimm < dimms + num_dimm; ghes_dimm++)

And with the above shortening of names, this loop becomes:

	for (d = dimms; d < dimms + num_dimms; d++)
		list_add(&d->entry, &dimm_pool);

Simple.

> +
> +	return 0;
> +}
> +
> +static void ghes_dimm_pool_destroy(void)
> +{
> +	lockdep_assert_held(ghes_reg_mutex);
> +	INIT_LIST_HEAD(&ghes_dimm_pool);
> +	kfree(dimms);
> +}
> +
> +static struct ghes_dimm *ghes_dimm_alloc(struct dimm_info *dimm, u16 handle)
> +{
> +	struct ghes_dimm *ghes_dimm;
> +
> +	lockdep_assert_held(ghes_reg_mutex);

The 0day bot caught it already - this needs to be a ptr. Please test
with PROVE_LOCKING enabled before sending next time.

> +
> +	ghes_dimm = list_first_entry_or_null(&ghes_dimm_pool,
> +					struct ghes_dimm, entry);

Let that line stick out.

> +
> +	/* should be always non-zero */
> +	if (!WARN_ON_ONCE(!ghes_dimm)) {
> +		ghes_dimm->dimm = dimm;
> +		ghes_dimm->handle = handle;
> +		list_del(&ghes_dimm->entry);
> +	}
> +
> +	return ghes_dimm;
> +}
> +
> +static void ghes_dimm_release(struct list_head *dimms)
> +{
> +	lockdep_assert_held(ghes_reg_mutex);
> +	list_splice(dimms, &ghes_dimm_pool);
> +}
> +
>  static void ghes_edac_count_dimms(const struct dmi_header *dh, void *arg)
>  {
>  	int *num_dimm = arg;

...

> @@ -547,12 +626,18 @@ int ghes_edac_register(struct ghes *ghes, struct device *dev)
>  
>  	spin_lock_irqsave(&ghes_lock, flags);
>  	ghes_pvt = pvt;
> +	list_splice_tail(&dimm_fill.dimms, &ghes_dimm_list);
>  	spin_unlock_irqrestore(&ghes_lock, flags);
>  
>  	/* only set on success */
>  	refcount_set(&ghes_refcount, 1);
>  
>  unlock:
> +	if (rc < 0) {
> +		ghes_dimm_pool_destroy();
> +		pr_err("Can't register at EDAC core: %d\n", rc);

					with the EDAC core:

> +	}
> +
>  	mutex_unlock(&ghes_reg_mutex);
>  
>  	return rc;
> @@ -562,6 +647,7 @@ void ghes_edac_unregister(struct ghes *ghes)
>  {
>  	struct mem_ctl_info *mci;
>  	unsigned long flags;
> +	LIST_HEAD(dimm_list);
>  
>  	mutex_lock(&ghes_reg_mutex);
>  
> @@ -574,14 +660,19 @@ void ghes_edac_unregister(struct ghes *ghes)
>  	spin_lock_irqsave(&ghes_lock, flags);
>  	mci = ghes_pvt ? ghes_pvt->mci : NULL;
>  	ghes_pvt = NULL;
> +	list_splice_init(&ghes_dimm_list, &dimm_list);

Why do you need to do this?

Can't you simply do:

	 ghes_dimm_release(&ghes_dimm_list);

here?

Btw, please add an explanation above ghes_dimm_list and ghes_dimm_pool
what those are and what the rules are: stuff gets added on register to
what list and freed on unreg from what list, etc. So that it is clear
upon a quick glance.

Thx.

-- 
Regards/Gruss,
    Boris.

https://people.kernel.org/tglx/notes-about-netiquette

  parent reply	other threads:[~2020-04-24 16:22 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-22 11:58 [PATCH v2 00/10] EDAC/mc/ghes: Fixes, cleanup and reworks Robert Richter
2020-04-22 11:58 ` [PATCH v2 01/10] EDAC/mc: Fix usage of snprintf() and dimm location setup Robert Richter
2020-04-22 20:52   ` Borislav Petkov
2020-05-19  9:27     ` Robert Richter
2020-04-22 11:58 ` [PATCH v2 02/10] EDAC/mc: Use int type for parameters of edac_mc_alloc() Robert Richter
2020-04-23 17:49   ` Borislav Petkov
2020-05-19  9:33     ` Robert Richter
2020-04-22 11:58 ` [PATCH v2 03/10] EDAC/ghes: Remove unused members of struct ghes_edac_pvt, rename it to ghes_mci Robert Richter
2020-04-23 17:55   ` Borislav Petkov
2020-05-05  7:50     ` Robert Richter
2020-04-22 11:58 ` [PATCH v2 04/10] EDAC/ghes: Make SMBIOS handle private data to ghes Robert Richter
2020-04-24 12:12   ` kbuild test robot
2020-04-24 16:21   ` Borislav Petkov [this message]
2020-05-05 12:48     ` Robert Richter
2020-04-22 11:58 ` [PATCH v2 05/10] EDAC/ghes: Setup DIMM label from DMI and use it in error reports Robert Richter
2020-04-22 11:58 ` [PATCH v2 06/10] EDAC/ghes: Remove local variable rdr_mask in ghes_edac_dmidecode() Robert Richter
2020-04-27  7:08   ` Borislav Petkov
2020-04-27 17:24     ` Luck, Tony
2020-04-27 17:34       ` Borislav Petkov
2020-05-19  9:34         ` Robert Richter
2020-04-22 11:58 ` [PATCH v2 07/10] EDAC/ghes: Cleanup struct ghes_edac_dimm_fill, rename it to ghes_dimm_fill Robert Richter
2020-04-27 14:00   ` Borislav Petkov
2020-05-19  9:35     ` Robert Richter
2020-04-22 11:58 ` [PATCH v2 08/10] EDAC/ghes: Carve out MC device handling into separate functions Robert Richter
2020-04-27 16:38   ` Borislav Petkov
2020-05-06  8:45     ` Robert Richter
2020-05-11 13:32       ` Borislav Petkov
2020-05-19  9:57         ` Robert Richter
2020-04-22 11:58 ` [PATCH v2 09/10] EDAC/ghes: Have a separate code path for creating the fake MC Robert Richter
2020-04-22 11:58 ` [PATCH v2 10/10] EDAC/ghes: Carve out code into ghes_edac_register_{one,fake}() Robert Richter
2020-05-06  8:53 ` [PATCH v2 00/10] EDAC/mc/ghes: Fixes, cleanup and reworks Robert Richter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200424162157.GB6916@zn.tnic \
    --to=bp@alien8.de \
    --cc=aris@redhat.com \
    --cc=james.morse@arm.com \
    --cc=linux-edac@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mbrugger@suse.com \
    --cc=mchehab@kernel.org \
    --cc=rrichter@marvell.com \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).