linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH -next] fs: Fix 'mnt' kernel-doc warning in namespace.c
@ 2020-09-11 12:07 Wang Hai
  0 siblings, 0 replies; only message in thread
From: Wang Hai @ 2020-09-11 12:07 UTC (permalink / raw)
  To: viro; +Cc: linux-fsdevel, linux-kernel

Fixes the following W=1 kernel build warning(s):

fs/namespace.c:1358: warning: Excess function parameter 'mnt' description in 'may_umount_tree'

Rename mnt to m.

Reported-by: Hulk Robot <hulkci@huawei.com>
Signed-off-by: Wang Hai <wanghai38@huawei.com>
---
 fs/namespace.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/namespace.c b/fs/namespace.c
index 098f981dce5..9f9a2664dd7 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1358,7 +1358,7 @@ void mnt_cursor_del(struct mnt_namespace *ns, struct mount *cursor)
 
 /**
  * may_umount_tree - check if a mount tree is busy
- * @mnt: root of mount tree
+ * @m: root of mount tree
  *
  * This is called to check if a tree of mounts has any
  * open files, pwds, chroots or sub mounts that are
-- 
2.17.1


^ permalink raw reply related	[flat|nested] only message in thread

only message in thread, other threads:[~2020-09-11 12:13 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-11 12:07 [PATCH -next] fs: Fix 'mnt' kernel-doc warning in namespace.c Wang Hai

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).