linux-gpio.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bartosz Golaszewski <brgl@bgdev.pl>
To: "Joel Becker" <jlbec@evilplan.org>,
	"Christoph Hellwig" <hch@lst.de>, "Shuah Khan" <shuah@kernel.org>,
	"Linus Walleij" <linus.walleij@linaro.org>,
	"Andy Shevchenko" <andriy.shevchenko@linux.intel.com>,
	"Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>,
	"Geert Uytterhoeven" <geert@linux-m68k.org>,
	"Kent Gibson" <warthog618@gmail.com>,
	"Jonathan Corbet" <corbet@lwn.net>,
	"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
	"Al Viro" <viro@zeniv.linux.org.uk>,
	"Jack Winch" <sunt.un.morcov@gmail.com>
Cc: linux-gpio@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-doc@vger.kernel.org, Bartosz Golaszewski <brgl@bgdev.pl>
Subject: [PATCH v5 2/8] configfs: use BIT() for internal flags
Date: Mon, 20 Sep 2021 16:05:03 +0200	[thread overview]
Message-ID: <20210920140509.5177-3-brgl@bgdev.pl> (raw)
In-Reply-To: <20210920140509.5177-1-brgl@bgdev.pl>

For better readability and maintenance: use the BIT() macro for flag
definitions.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
 fs/configfs/configfs_internal.h | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/fs/configfs/configfs_internal.h b/fs/configfs/configfs_internal.h
index c0395363eab9..b1b2a43f6130 100644
--- a/fs/configfs/configfs_internal.h
+++ b/fs/configfs/configfs_internal.h
@@ -44,16 +44,16 @@ struct configfs_dirent {
 	struct configfs_fragment *s_frag;
 };
 
-#define CONFIGFS_ROOT		0x0001
-#define CONFIGFS_DIR		0x0002
-#define CONFIGFS_ITEM_ATTR	0x0004
-#define CONFIGFS_ITEM_BIN_ATTR	0x0008
-#define CONFIGFS_ITEM_LINK	0x0020
-#define CONFIGFS_USET_DIR	0x0040
-#define CONFIGFS_USET_DEFAULT	0x0080
-#define CONFIGFS_USET_DROPPING	0x0100
-#define CONFIGFS_USET_IN_MKDIR	0x0200
-#define CONFIGFS_USET_CREATING	0x0400
+#define CONFIGFS_ROOT			BIT(0)
+#define CONFIGFS_DIR			BIT(1)
+#define CONFIGFS_ITEM_ATTR		BIT(2)
+#define CONFIGFS_ITEM_BIN_ATTR		BIT(3)
+#define CONFIGFS_ITEM_LINK		BIT(5)
+#define CONFIGFS_USET_DIR		BIT(6)
+#define CONFIGFS_USET_DEFAULT		BIT(7)
+#define CONFIGFS_USET_DROPPING		BIT(8)
+#define CONFIGFS_USET_IN_MKDIR		BIT(9)
+#define CONFIGFS_USET_CREATING		BIT(10)
 #define CONFIGFS_NOT_PINNED	(CONFIGFS_ITEM_ATTR | CONFIGFS_ITEM_BIN_ATTR)
 
 extern struct mutex configfs_symlink_mutex;
-- 
2.30.1


  parent reply	other threads:[~2021-09-20 14:06 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-20 14:05 [PATCH v5 0/8] gpio: implement the configfs testing module Bartosz Golaszewski
2021-09-20 14:05 ` [PATCH v5 1/8] configfs: increase the item name length Bartosz Golaszewski
2021-09-20 14:05 ` Bartosz Golaszewski [this message]
2021-09-20 14:09   ` [PATCH v5 2/8] configfs: use BIT() for internal flags Christoph Hellwig
2021-09-20 14:13     ` Bartosz Golaszewski
2021-09-20 14:15       ` Christoph Hellwig
2021-09-20 14:29     ` Geert Uytterhoeven
2021-09-20 14:30       ` Christoph Hellwig
2021-09-20 14:45         ` Bartosz Golaszewski
2021-09-20 14:49           ` Geert Uytterhoeven
2021-09-20 15:00             ` Bartosz Golaszewski
2021-09-20 17:25               ` Matthew Wilcox
2021-09-20 14:05 ` [PATCH v5 3/8] configfs: implement committable items Bartosz Golaszewski
2021-09-20 14:05 ` [PATCH v5 4/8] samples: configfs: add a committable group Bartosz Golaszewski
2021-09-20 14:05 ` [PATCH v5 5/8] gpio: sim: new testing module Bartosz Golaszewski
2021-09-20 14:05 ` [PATCH v5 6/8] selftests: gpio: provide a helper for reading chip info Bartosz Golaszewski
2021-09-20 14:05 ` [PATCH v5 7/8] selftests: gpio: add a helper for reading GPIO line names Bartosz Golaszewski
2021-09-20 14:05 ` [PATCH v5 8/8] selftests: gpio: add test cases for gpio-sim Bartosz Golaszewski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210920140509.5177-3-brgl@bgdev.pl \
    --to=brgl@bgdev.pl \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=corbet@lwn.net \
    --cc=geert@linux-m68k.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@lst.de \
    --cc=jlbec@evilplan.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=shuah@kernel.org \
    --cc=sunt.un.morcov@gmail.com \
    --cc=u.kleine-koenig@pengutronix.de \
    --cc=viro@zeniv.linux.org.uk \
    --cc=warthog618@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).