linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] clk: ti: composite: Prefer kcalloc over open coded arithmetic
@ 2021-09-04 13:17 Len Baker
  2022-05-21  3:40 ` Stephen Boyd
  0 siblings, 1 reply; 2+ messages in thread
From: Len Baker @ 2021-09-04 13:17 UTC (permalink / raw)
  To: Tero Kristo, Michael Turquette, Stephen Boyd
  Cc: Len Baker, Kees Cook, linux-omap, linux-clk, linux-hardening,
	linux-kernel

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the purpose specific kcalloc() function instead of the argument
size * count in the kzalloc() function.

[1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <len.baker@gmx.com>
---
 drivers/clk/ti/composite.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/clk/ti/composite.c b/drivers/clk/ti/composite.c
index eaa43575cfa5..eb5ce9735c7d 100644
--- a/drivers/clk/ti/composite.c
+++ b/drivers/clk/ti/composite.c
@@ -253,7 +253,7 @@ int __init ti_clk_add_component(struct device_node *node, struct clk_hw *hw,
 		return -EINVAL;
 	}

-	parent_names = kzalloc((sizeof(char *) * num_parents), GFP_KERNEL);
+	parent_names = kcalloc(num_parents, sizeof(char *), GFP_KERNEL);
 	if (!parent_names)
 		return -ENOMEM;

--
2.25.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] clk: ti: composite: Prefer kcalloc over open coded arithmetic
  2021-09-04 13:17 [PATCH] clk: ti: composite: Prefer kcalloc over open coded arithmetic Len Baker
@ 2022-05-21  3:40 ` Stephen Boyd
  0 siblings, 0 replies; 2+ messages in thread
From: Stephen Boyd @ 2022-05-21  3:40 UTC (permalink / raw)
  To: Len Baker, Michael Turquette, Tero Kristo
  Cc: Len Baker, Kees Cook, linux-omap, linux-clk, linux-hardening,
	linux-kernel

Quoting Len Baker (2021-09-04 06:17:14)
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
> 
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <len.baker@gmx.com>
> ---

Applied to clk-next

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2022-05-21  3:40 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-04 13:17 [PATCH] clk: ti: composite: Prefer kcalloc over open coded arithmetic Len Baker
2022-05-21  3:40 ` Stephen Boyd

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).