linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] memstick: jmb38x_ms: Prefer struct_size over open coded arithmetic
@ 2021-09-11 13:19 Len Baker
  2021-09-14 11:23 ` Ulf Hansson
  0 siblings, 1 reply; 2+ messages in thread
From: Len Baker @ 2021-09-11 13:19 UTC (permalink / raw)
  To: Maxim Levitsky, Alex Dubov, Ulf Hansson
  Cc: Len Baker, Kees Cook, Tom Rix, linux-hardening, linux-mmc, linux-kernel

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the struct_size() helper to do the arithmetic instead of the
argument "size + count * size" in the kzalloc() function.

[1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <len.baker@gmx.com>
---
 drivers/memstick/host/jmb38x_ms.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/memstick/host/jmb38x_ms.c b/drivers/memstick/host/jmb38x_ms.c
index f9a93b0565e1..a7a0f0caea15 100644
--- a/drivers/memstick/host/jmb38x_ms.c
+++ b/drivers/memstick/host/jmb38x_ms.c
@@ -927,8 +927,7 @@ static int jmb38x_ms_probe(struct pci_dev *pdev,
 		goto err_out_int;
 	}

-	jm = kzalloc(sizeof(struct jmb38x_ms)
-		     + cnt * sizeof(struct memstick_host *), GFP_KERNEL);
+	jm = kzalloc(struct_size(jm, hosts, cnt), GFP_KERNEL);
 	if (!jm) {
 		rc = -ENOMEM;
 		goto err_out_int;
--
2.25.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] memstick: jmb38x_ms: Prefer struct_size over open coded arithmetic
  2021-09-11 13:19 [PATCH] memstick: jmb38x_ms: Prefer struct_size over open coded arithmetic Len Baker
@ 2021-09-14 11:23 ` Ulf Hansson
  0 siblings, 0 replies; 2+ messages in thread
From: Ulf Hansson @ 2021-09-14 11:23 UTC (permalink / raw)
  To: Len Baker
  Cc: Maxim Levitsky, Alex Dubov, Kees Cook, Tom Rix, linux-hardening,
	linux-mmc, Linux Kernel Mailing List

On Sat, 11 Sept 2021 at 15:22, Len Baker <len.baker@gmx.com> wrote:
>
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@gmx.com>

Applied for next, thanks!

Kind regards
Uffe


> ---
>  drivers/memstick/host/jmb38x_ms.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/memstick/host/jmb38x_ms.c b/drivers/memstick/host/jmb38x_ms.c
> index f9a93b0565e1..a7a0f0caea15 100644
> --- a/drivers/memstick/host/jmb38x_ms.c
> +++ b/drivers/memstick/host/jmb38x_ms.c
> @@ -927,8 +927,7 @@ static int jmb38x_ms_probe(struct pci_dev *pdev,
>                 goto err_out_int;
>         }
>
> -       jm = kzalloc(sizeof(struct jmb38x_ms)
> -                    + cnt * sizeof(struct memstick_host *), GFP_KERNEL);
> +       jm = kzalloc(struct_size(jm, hosts, cnt), GFP_KERNEL);
>         if (!jm) {
>                 rc = -ENOMEM;
>                 goto err_out_int;
> --
> 2.25.1
>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-09-14 11:24 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-11 13:19 [PATCH] memstick: jmb38x_ms: Prefer struct_size over open coded arithmetic Len Baker
2021-09-14 11:23 ` Ulf Hansson

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).