linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH][next] USB: serial: ti_usb_3410_5052: Use struct_size() helper in ti_write_byte()
@ 2022-01-20 21:31 Gustavo A. R. Silva
  2022-01-20 23:23 ` Kees Cook
  2022-03-03 13:05 ` Johan Hovold
  0 siblings, 2 replies; 3+ messages in thread
From: Gustavo A. R. Silva @ 2022-01-20 21:31 UTC (permalink / raw)
  To: Johan Hovold, Greg Kroah-Hartman
  Cc: linux-usb, linux-kernel, Gustavo A. R. Silva, linux-hardening

Make use of the struct_size() helper instead of an open-coded version,
in order to avoid any potential type mistakes or integer overflows that,
in the worst scenario, could lead to heap overflows.

Also, address the following sparse warnings:
drivers/usb/serial/ti_usb_3410_5052.c:1521:16: warning: using sizeof on a flexible structure

Link: https://github.com/KSPP/linux/issues/174
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/usb/serial/ti_usb_3410_5052.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/serial/ti_usb_3410_5052.c b/drivers/usb/serial/ti_usb_3410_5052.c
index 18c0bd853392..03f98e61626f 100644
--- a/drivers/usb/serial/ti_usb_3410_5052.c
+++ b/drivers/usb/serial/ti_usb_3410_5052.c
@@ -1512,13 +1512,13 @@ static int ti_write_byte(struct usb_serial_port *port,
 			 u8 mask, u8 byte)
 {
 	int status;
-	unsigned int size;
+	size_t size;
 	struct ti_write_data_bytes *data;
 
 	dev_dbg(&port->dev, "%s - addr 0x%08lX, mask 0x%02X, byte 0x%02X\n", __func__,
 		addr, mask, byte);
 
-	size = sizeof(struct ti_write_data_bytes) + 2;
+	size = struct_size(data, bData, 2);
 	data = kmalloc(size, GFP_KERNEL);
 	if (!data)
 		return -ENOMEM;
-- 
2.27.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] USB: serial: ti_usb_3410_5052: Use struct_size() helper in ti_write_byte()
  2022-01-20 21:31 [PATCH][next] USB: serial: ti_usb_3410_5052: Use struct_size() helper in ti_write_byte() Gustavo A. R. Silva
@ 2022-01-20 23:23 ` Kees Cook
  2022-03-03 13:05 ` Johan Hovold
  1 sibling, 0 replies; 3+ messages in thread
From: Kees Cook @ 2022-01-20 23:23 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Johan Hovold, Greg Kroah-Hartman, linux-usb, linux-kernel,
	linux-hardening

On Thu, Jan 20, 2022 at 03:31:31PM -0600, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
> 
> Also, address the following sparse warnings:
> drivers/usb/serial/ti_usb_3410_5052.c:1521:16: warning: using sizeof on a flexible structure
> 
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

Looks good.

Reviewed-by: Kees Cook <keescook@chromium.org>

-- 
Kees Cook

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] USB: serial: ti_usb_3410_5052: Use struct_size() helper in ti_write_byte()
  2022-01-20 21:31 [PATCH][next] USB: serial: ti_usb_3410_5052: Use struct_size() helper in ti_write_byte() Gustavo A. R. Silva
  2022-01-20 23:23 ` Kees Cook
@ 2022-03-03 13:05 ` Johan Hovold
  1 sibling, 0 replies; 3+ messages in thread
From: Johan Hovold @ 2022-03-03 13:05 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Greg Kroah-Hartman, linux-usb, linux-kernel, linux-hardening

On Thu, Jan 20, 2022 at 03:31:31PM -0600, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.

This boiler-plate motivation doesn't apply here since the "variable"
size is in fact constant.

> Also, address the following sparse warnings:
> drivers/usb/serial/ti_usb_3410_5052.c:1521:16: warning: using sizeof on a flexible structure

And this bit is again bogus, since this off-by-default warning would
still be there with this patch applied.

> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
> ---
>  drivers/usb/serial/ti_usb_3410_5052.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/usb/serial/ti_usb_3410_5052.c b/drivers/usb/serial/ti_usb_3410_5052.c
> index 18c0bd853392..03f98e61626f 100644
> --- a/drivers/usb/serial/ti_usb_3410_5052.c
> +++ b/drivers/usb/serial/ti_usb_3410_5052.c
> @@ -1512,13 +1512,13 @@ static int ti_write_byte(struct usb_serial_port *port,
>  			 u8 mask, u8 byte)
>  {
>  	int status;
> -	unsigned int size;
> +	size_t size;
>  	struct ti_write_data_bytes *data;
>  
>  	dev_dbg(&port->dev, "%s - addr 0x%08lX, mask 0x%02X, byte 0x%02X\n", __func__,
>  		addr, mask, byte);
>  
> -	size = sizeof(struct ti_write_data_bytes) + 2;
> +	size = struct_size(data, bData, 2);

I guess the change itself is fine otherwise and could be motivated as
documenting the constant.

At least as long as the compiler is smart enough to not generate any
additional code for this, there wouldn't be any downsides.

>  	data = kmalloc(size, GFP_KERNEL);
>  	if (!data)
>  		return -ENOMEM;

Johan

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-03-03 13:05 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-20 21:31 [PATCH][next] USB: serial: ti_usb_3410_5052: Use struct_size() helper in ti_write_byte() Gustavo A. R. Silva
2022-01-20 23:23 ` Kees Cook
2022-03-03 13:05 ` Johan Hovold

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).