linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] afs: Prefer struct_size over open coded arithmetic
@ 2021-09-19  9:44 Len Baker
  2021-09-21  0:09 ` Gustavo A. R. Silva
  2021-11-02  9:44 ` David Howells
  0 siblings, 2 replies; 4+ messages in thread
From: Len Baker @ 2021-09-19  9:44 UTC (permalink / raw)
  To: David Howells, Marc Dionne
  Cc: Len Baker, Gustavo A. R. Silva, Kees Cook, linux-afs,
	linux-hardening, linux-kernel

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, use the struct_size() helper to do the arithmetic instead of the
argument "size + size * count" in the kzalloc() function.

[1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Len Baker <len.baker@gmx.com>
---
 fs/afs/security.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/fs/afs/security.c b/fs/afs/security.c
index 3c7a8fc4f93f..7c6a63a30394 100644
--- a/fs/afs/security.c
+++ b/fs/afs/security.c
@@ -219,8 +219,7 @@ void afs_cache_permit(struct afs_vnode *vnode, struct key *key,
 	 * yet.
 	 */
 	size++;
-	new = kzalloc(sizeof(struct afs_permits) +
-		      sizeof(struct afs_permit) * size, GFP_NOFS);
+	new = kzalloc(struct_size(new, permits, size), GFP_NOFS);
 	if (!new)
 		goto out_put;

--
2.25.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] afs: Prefer struct_size over open coded arithmetic
  2021-09-19  9:44 [PATCH] afs: Prefer struct_size over open coded arithmetic Len Baker
@ 2021-09-21  0:09 ` Gustavo A. R. Silva
  2021-10-20 23:26   ` Gustavo A. R. Silva
  2021-11-02  9:44 ` David Howells
  1 sibling, 1 reply; 4+ messages in thread
From: Gustavo A. R. Silva @ 2021-09-21  0:09 UTC (permalink / raw)
  To: Len Baker, David Howells, Marc Dionne
  Cc: Gustavo A. R. Silva, Kees Cook, linux-afs, linux-hardening, linux-kernel



On 9/19/21 04:44, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + size * count" in the kzalloc() function.
> 
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <len.baker@gmx.com>

Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org>

Thanks
--
Gustavo

> ---
>  fs/afs/security.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/fs/afs/security.c b/fs/afs/security.c
> index 3c7a8fc4f93f..7c6a63a30394 100644
> --- a/fs/afs/security.c
> +++ b/fs/afs/security.c
> @@ -219,8 +219,7 @@ void afs_cache_permit(struct afs_vnode *vnode, struct key *key,
>  	 * yet.
>  	 */
>  	size++;
> -	new = kzalloc(sizeof(struct afs_permits) +
> -		      sizeof(struct afs_permit) * size, GFP_NOFS);
> +	new = kzalloc(struct_size(new, permits, size), GFP_NOFS);
>  	if (!new)
>  		goto out_put;
> 
> --
> 2.25.1
> 

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] afs: Prefer struct_size over open coded arithmetic
  2021-09-21  0:09 ` Gustavo A. R. Silva
@ 2021-10-20 23:26   ` Gustavo A. R. Silva
  0 siblings, 0 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2021-10-20 23:26 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Len Baker, David Howells, Marc Dionne, Kees Cook, linux-afs,
	linux-hardening, linux-kernel

On Mon, Sep 20, 2021 at 07:09:38PM -0500, Gustavo A. R. Silva wrote:
> 
> 
> On 9/19/21 04:44, Len Baker wrote:
> > As noted in the "Deprecated Interfaces, Language Features, Attributes,
> > and Conventions" documentation [1], size calculations (especially
> > multiplication) should not be performed in memory allocator (or similar)
> > function arguments due to the risk of them overflowing. This could lead
> > to values wrapping around and a smaller allocation being made than the
> > caller was expecting. Using those allocations could lead to linear
> > overflows of heap memory and other misbehaviors.
> > 
> > So, use the struct_size() helper to do the arithmetic instead of the
> > argument "size + size * count" in the kzalloc() function.
> > 
> > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> > 
> > Signed-off-by: Len Baker <len.baker@gmx.com>
> 
> Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org>

I'm taking this in my -next tree.

Thanks, Len.
--
Gustavo

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] afs: Prefer struct_size over open coded arithmetic
  2021-09-19  9:44 [PATCH] afs: Prefer struct_size over open coded arithmetic Len Baker
  2021-09-21  0:09 ` Gustavo A. R. Silva
@ 2021-11-02  9:44 ` David Howells
  1 sibling, 0 replies; 4+ messages in thread
From: David Howells @ 2021-11-02  9:44 UTC (permalink / raw)
  To: Len Baker
  Cc: dhowells, Marc Dionne, Gustavo A. R. Silva, Kees Cook, linux-afs,
	linux-hardening, linux-kernel

Len Baker <len.baker@gmx.com> wrote:

> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + size * count" in the kzalloc() function.
> 
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <len.baker@gmx.com>

Acked-by: David Howells <dhowells@redhat.com>


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-11-02  9:45 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-19  9:44 [PATCH] afs: Prefer struct_size over open coded arithmetic Len Baker
2021-09-21  0:09 ` Gustavo A. R. Silva
2021-10-20 23:26   ` Gustavo A. R. Silva
2021-11-02  9:44 ` David Howells

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).