linux-i2c.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rafael@kernel.org>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
	linux-i2c <linux-i2c@vger.kernel.org>,
	Wolfram Sang <wsa@the-dreams.de>,
	ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Mani, Rajmohan" <rajmohan.mani@intel.com>,
	Tomasz Figa <tfiga@chromium.org>,
	Bartosz Golaszewski <bgolaszewski@baylibre.com>,
	Bingbu Cao <bingbu.cao@intel.com>,
	Chiranjeevi Rapolu <chiranjeevi.rapolu@intel.com>,
	Hyungwoo Yang <hyungwoo.yang@intel.com>,
	Linux Media Mailing List <linux-media@vger.kernel.org>
Subject: Re: [PATCH v9 1/7] ACPI: scan: Obtain device's desired enumeration power state
Date: Mon, 1 Feb 2021 12:44:46 +0100	[thread overview]
Message-ID: <CAJZ5v0jjgy2KXOw5pyshvaEVzLctu4jsgYK1+YDA+8sZfp-6mw@mail.gmail.com> (raw)
In-Reply-To: <20210129212211.GK32460@paasikivi.fi.intel.com>

On Fri, Jan 29, 2021 at 10:22 PM Sakari Ailus
<sakari.ailus@linux.intel.com> wrote:
>
> On Fri, Jan 29, 2021 at 05:57:17PM +0100, Rafael J. Wysocki wrote:
> > On Fri, Jan 29, 2021 at 5:45 PM Sakari Ailus
> > <sakari.ailus@linux.intel.com> wrote:
> > >
> > > Hi Rafael,
> > >
> > > Thanks for the comments.
> > >
> > > On Fri, Jan 29, 2021 at 03:07:57PM +0100, Rafael J. Wysocki wrote:
> > > > On Fri, Jan 29, 2021 at 12:27 AM Sakari Ailus
> > > > <sakari.ailus@linux.intel.com> wrote:
> > > > >
> > > > > Store a device's desired enumeration power state in struct
> > > > > acpi_device_power_flags during acpi_device object's initialisation.
> > > > >
> > > > > Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> > > > > ---
> > > > >  drivers/acpi/scan.c     | 6 ++++++
> > > > >  include/acpi/acpi_bus.h | 3 ++-
> > > > >  2 files changed, 8 insertions(+), 1 deletion(-)
> > > > >
> > > > > diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
> > > > > index 1d7a02ee45e05..b077c645c9845 100644
> > > > > --- a/drivers/acpi/scan.c
> > > > > +++ b/drivers/acpi/scan.c
> > > > > @@ -987,6 +987,8 @@ static void acpi_bus_init_power_state(struct acpi_device *device, int state)
> > > > >
> > > > >  static void acpi_bus_get_power_flags(struct acpi_device *device)
> > > > >  {
> > > > > +       unsigned long long pre;
> > > > > +       acpi_status status;
> > > > >         u32 i;
> > > > >
> > > > >         /* Presence of _PS0|_PR0 indicates 'power manageable' */
> > > > > @@ -1008,6 +1010,10 @@ static void acpi_bus_get_power_flags(struct acpi_device *device)
> > > > >         if (acpi_has_method(device->handle, "_DSW"))
> > > > >                 device->power.flags.dsw_present = 1;
> > > > >
> > > > > +       status = acpi_evaluate_integer(device->handle, "_PRE", NULL, &pre);
> > > > > +       if (ACPI_SUCCESS(status) && !pre)
> > > > > +               device->power.flags.allow_low_power_probe = 1;
> > > >
> > > > While this is what has been discussed and thanks for taking it into
> > > > account, I'm now thinking that it may be cleaner to introduce a new
> > > > object to return the deepest power state of the device in which it can
> > > > be enumerated, say _DSE (Device State for Enumeration) such that 4
> > > > means D3cold, 3 - D3hot and so on, so the above check can be replaced
> > > > with something like
> > > >
> > > > status = acpi_evaluate_integer(device->handle, "_PRE", NULL, &dse);
> > >
> > > s/_PRE/_DSE/
> > >
> > > ?
> >
> > Yes, sorry.
> >
> > >
> > > > if (ACPI_FAILURE(status))
> > >
> > > ACPI_SUCCESS?
> >
> > Yup.
> >
> > > >         device->power.state_for_enumeratin = dse;
> > > >
> > > > And then, it is a matter of comparing ->power.state_for_enumeratin
> > > > with ->power.state and putting the device into D0 if the former is
> > > > shallower than the latter.
> > > >
> > > > What do you think?
> > >
> > > Sounds good. How about calling the function e.g.
> > > acpi_device_resume_for_probe(), so runtime PM could be used to resume the
> > > device if the function returns true?
> >
> > I'd rather try to power it up before enabling runtime PM, because in
> > order to do the latter properly, you need to know if the device is
> > active or suspended to start with.
> >
> > So you need something like (pseudo-code)
> >
> > if (this_device_needs_to_be_on(ACPI_COMPANION(dev))) {
> >    acpi_device_set_power(ACPI_COMPANION(dev), ACPI_STATE_D0);
> >    pm_runtime_set_active(dev);
> > } else {
> >    pm_runtime_set_suspended(dev);
>
> I guess the else branch isn't needed? The device remains suspended if its
> state hasn't been changed.

Assuming that the initial status is always "suspended", the else
branch is not needed.

> > }
> >
> > and then you can enable PM-runtime.
>
> Yes, agreed, this is what drivers should do. The I涎 framework would use
> the function and conditionally power the device on before enabling runtime
> PM.
>
> This is how it's implemented by the set already but I think the change in
> semantics requires a little more still.

Agreed.

  reply	other threads:[~2021-02-01 11:45 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-03  8:15 [PATCH v8 0/6] Support running driver's probe for a device powered off Sakari Ailus
2020-09-03  8:15 ` [PATCH v8 1/6] i2c: Allow an ACPI driver to manage the device's power state during probe Sakari Ailus
2020-09-03  8:15 ` [PATCH v8 2/6] Documentation: ACPI: Document i2c-allow-low-power-probe _DSD property Sakari Ailus
2020-09-03  8:15 ` [PATCH v8 3/6] ACPI: Add a convenience function to tell a device is in low power state Sakari Ailus
     [not found]   ` <0c2d4728-6e32-ef93-8961-381fe36cfdaa@linux.intel.com>
2020-09-11 13:01     ` Sakari Ailus
2020-09-03  8:15 ` [PATCH v8 4/6] ov5670: Support probe whilst the device is in a " Sakari Ailus
2020-09-03  8:15 ` [PATCH v8 5/6] media: i2c: imx319: Support probe while the device is off Sakari Ailus
2020-09-03  8:15 ` [PATCH v8 6/6] at24: Support probing while off Sakari Ailus
2020-09-09  9:35   ` Bartosz Golaszewski
2020-09-09 11:11     ` Wolfram Sang
2020-09-09 11:56       ` Bartosz Golaszewski
2020-09-09 12:16         ` Sakari Ailus
2020-09-11 12:11         ` Sakari Ailus
2020-10-06 11:20   ` Tomasz Figa
2020-10-06 11:23     ` Tomasz Figa
2020-09-11 12:49 ` [PATCH v8 0/6] Support running driver's probe for a device powered off Luca Ceresoli
2020-09-11 13:01   ` Sakari Ailus
2020-09-14  7:58     ` Luca Ceresoli
     [not found]       ` <20200914094727.GM26842@paasikivi.fi.intel.com>
2020-09-14 16:49         ` Luca Ceresoli
2020-09-23 11:08           ` Sakari Ailus
2020-09-23 15:37             ` Luca Ceresoli
2020-09-26 12:38         ` Tomasz Figa
2020-09-27 19:39           ` Wolfram Sang
2020-09-27 19:44             ` Tomasz Figa
2020-09-28 14:17               ` Rafael J. Wysocki
2020-09-28 16:49                 ` Tomasz Figa
2020-09-28 20:49                   ` Sakari Ailus
2020-09-26 12:46 ` Tomasz Figa
2021-01-28 23:27 ` [PATCH v9 1/7] ACPI: scan: Obtain device's desired enumeration power state Sakari Ailus
     [not found]   ` <CAJZ5v0hdG1W0D5E6GbrTDiAjMyC0mSgb3Z2WEBy3hhb4iJhDNw@mail.gmail.com>
2021-01-29 16:45     ` Sakari Ailus
2021-01-29 16:57       ` Rafael J. Wysocki
2021-01-29 21:22         ` Sakari Ailus
2021-02-01 11:44           ` Rafael J. Wysocki [this message]
2021-01-28 23:27 ` [PATCH v9 2/7] i2c: Allow an ACPI driver to manage the device's power state during probe Sakari Ailus
2021-01-28 23:27 ` [PATCH v9 3/7] Documentation: ACPI: Document _PRE object usage for enum power state Sakari Ailus
2021-01-28 23:27 ` [PATCH v9 4/7] ACPI: Add a convenience function to tell a device is in low " Sakari Ailus
2021-01-28 23:27 ` [PATCH v9 5/7] ov5670: Support probe whilst the device is in a " Sakari Ailus
2021-01-28 23:27 ` [PATCH v9 6/7] media: i2c: imx319: Support probe while the device is off Sakari Ailus
2021-01-29  2:58   ` Bingbu Cao
2021-01-28 23:27 ` [PATCH v9 7/7] at24: Support probing while off Sakari Ailus
     [not found]   ` <CAMpxmJVTPgvxOVdTkmt4VjUnGabNBKauKF_DKtnnkV6O0QYTWA@mail.gmail.com>
     [not found]     ` <20210129121955.GH32460@paasikivi.fi.intel.com>
2021-02-01  8:57       ` Bartosz Golaszewski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAJZ5v0jjgy2KXOw5pyshvaEVzLctu4jsgYK1+YDA+8sZfp-6mw@mail.gmail.com \
    --to=rafael@kernel.org \
    --cc=bgolaszewski@baylibre.com \
    --cc=bingbu.cao@intel.com \
    --cc=chiranjeevi.rapolu@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hyungwoo.yang@intel.com \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-i2c@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=rajmohan.mani@intel.com \
    --cc=sakari.ailus@linux.intel.com \
    --cc=tfiga@chromium.org \
    --cc=wsa@the-dreams.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).