linux-kbuild.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/2] kbuild: Refactor ./Kbuild
@ 2014-12-24  6:49 Masahiro Yamada
  2014-12-24  6:49 ` [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules Masahiro Yamada
  2014-12-24  6:49 ` [PATCH 2/2] kbuild: remove redundant line from bounds.h/asm-offsets.h Masahiro Yamada
  0 siblings, 2 replies; 5+ messages in thread
From: Masahiro Yamada @ 2014-12-24  6:49 UTC (permalink / raw)
  To: linux-kbuild; +Cc: Masahiro Yamada, linux-kernel




Masahiro Yamada (2):
  kbuild: merge bounds.h and asm-offsets.h rules
  kbuild: remove redundant line from bounds.h/asm-offsets.h

 Kbuild | 60 +++++++++++++++++++++---------------------------------------
 1 file changed, 21 insertions(+), 39 deletions(-)

-- 
1.9.1


^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules
  2014-12-24  6:49 [PATCH 0/2] kbuild: Refactor ./Kbuild Masahiro Yamada
@ 2014-12-24  6:49 ` Masahiro Yamada
  2015-01-02 16:04   ` Michal Marek
  2014-12-24  6:49 ` [PATCH 2/2] kbuild: remove redundant line from bounds.h/asm-offsets.h Masahiro Yamada
  1 sibling, 1 reply; 5+ messages in thread
From: Masahiro Yamada @ 2014-12-24  6:49 UTC (permalink / raw)
  To: linux-kbuild; +Cc: Masahiro Yamada, linux-kernel

The rules "cmd_bounds" and "cmd_offsets" are almost the same.
(The difference is only the include guards.)  They can be merged.

Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>
---

 Kbuild | 59 +++++++++++++++++++++--------------------------------------
 1 file changed, 21 insertions(+), 38 deletions(-)

diff --git a/Kbuild b/Kbuild
index 5d7c729..55a639f 100644
--- a/Kbuild
+++ b/Kbuild
@@ -5,19 +5,20 @@
 # 2) Generate asm-offsets.h (may need bounds.h)
 # 3) Check for missing system calls
 
-#####
-# 1) Generate bounds.h
-
-bounds-file := include/generated/bounds.h
-
-always  := $(bounds-file)
-targets := $(bounds-file) kernel/bounds.s
+# Default sed regexp - multiline due to syntax constraints
+define sed-y
+	"/^->/{s:->#\(.*\):/* \1 */:; \
+	s:^->\([^ ]*\) [\$$#]*\([-0-9]*\) \(.*\):#define \1 \2 /* \3 */:; \
+	s:^->\([^ ]*\) [\$$#]*\([^ ]*\) \(.*\):#define \1 \2 /* \3 */:; \
+	s:->::; p;}"
+endef
 
-quiet_cmd_bounds = GEN     $@
-define cmd_bounds
+quiet_cmd_offsets = GEN     $@
+define cmd_offsets
 	(set -e; \
-	 echo "#ifndef __LINUX_BOUNDS_H__"; \
-	 echo "#define __LINUX_BOUNDS_H__"; \
+	 INCLUDE_GUARD=$$(echo __$(notdir $@)__ | tr '[a-z].-' '[A-Z]__'); \
+	 echo "#ifndef $$INCLUDE_GUARD"; \
+	 echo "#define $$INCLUDE_GUARD"; \
 	 echo "/*"; \
 	 echo " * DO NOT MODIFY."; \
 	 echo " *"; \
@@ -30,6 +31,14 @@ define cmd_bounds
 	 echo "#endif" ) > $@
 endef
 
+#####
+# 1) Generate bounds.h
+
+bounds-file := include/generated/bounds.h
+
+always  := $(bounds-file)
+targets := $(bounds-file) kernel/bounds.s
+
 # We use internal kbuild rules to avoid the "is up to date" message from make
 kernel/bounds.s: kernel/bounds.c FORCE
 	$(Q)mkdir -p $(dir $@)
@@ -37,7 +46,7 @@ kernel/bounds.s: kernel/bounds.c FORCE
 
 $(obj)/$(bounds-file): kernel/bounds.s Kbuild
 	$(Q)mkdir -p $(dir $@)
-	$(call cmd,bounds)
+	$(call cmd,offsets)
 
 #####
 # 2) Generate asm-offsets.h
@@ -49,32 +58,6 @@ always  += $(offsets-file)
 targets += $(offsets-file)
 targets += arch/$(SRCARCH)/kernel/asm-offsets.s
 
-
-# Default sed regexp - multiline due to syntax constraints
-define sed-y
-	"/^->/{s:->#\(.*\):/* \1 */:; \
-	s:^->\([^ ]*\) [\$$#]*\([-0-9]*\) \(.*\):#define \1 \2 /* \3 */:; \
-	s:^->\([^ ]*\) [\$$#]*\([^ ]*\) \(.*\):#define \1 \2 /* \3 */:; \
-	s:->::; p;}"
-endef
-
-quiet_cmd_offsets = GEN     $@
-define cmd_offsets
-	(set -e; \
-	 echo "#ifndef __ASM_OFFSETS_H__"; \
-	 echo "#define __ASM_OFFSETS_H__"; \
-	 echo "/*"; \
-	 echo " * DO NOT MODIFY."; \
-	 echo " *"; \
-	 echo " * This file was generated by Kbuild"; \
-	 echo " *"; \
-	 echo " */"; \
-	 echo ""; \
-	 sed -ne $(sed-y) $<; \
-	 echo ""; \
-	 echo "#endif" ) > $@
-endef
-
 # We use internal kbuild rules to avoid the "is up to date" message from make
 arch/$(SRCARCH)/kernel/asm-offsets.s: arch/$(SRCARCH)/kernel/asm-offsets.c \
                                       $(obj)/$(bounds-file) FORCE
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH 2/2] kbuild: remove redundant line from bounds.h/asm-offsets.h
  2014-12-24  6:49 [PATCH 0/2] kbuild: Refactor ./Kbuild Masahiro Yamada
  2014-12-24  6:49 ` [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules Masahiro Yamada
@ 2014-12-24  6:49 ` Masahiro Yamada
  1 sibling, 0 replies; 5+ messages in thread
From: Masahiro Yamada @ 2014-12-24  6:49 UTC (permalink / raw)
  To: linux-kbuild; +Cc: Masahiro Yamada, linux-kernel

This line produces an extra comment line for bounds.h and
asm-offsets.h.

Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>
---

 Kbuild | 1 -
 1 file changed, 1 deletion(-)

diff --git a/Kbuild b/Kbuild
index 55a639f..5ac6d06 100644
--- a/Kbuild
+++ b/Kbuild
@@ -23,7 +23,6 @@ define cmd_offsets
 	 echo " * DO NOT MODIFY."; \
 	 echo " *"; \
 	 echo " * This file was generated by Kbuild"; \
-	 echo " *"; \
 	 echo " */"; \
 	 echo ""; \
 	 sed -ne $(sed-y) $<; \
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules
  2014-12-24  6:49 ` [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules Masahiro Yamada
@ 2015-01-02 16:04   ` Michal Marek
  2015-01-05  6:58     ` Masahiro Yamada
  0 siblings, 1 reply; 5+ messages in thread
From: Michal Marek @ 2015-01-02 16:04 UTC (permalink / raw)
  To: Masahiro Yamada, linux-kbuild; +Cc: linux-kernel

On 2014-12-24 07:49, Masahiro Yamada wrote:
> The rules "cmd_bounds" and "cmd_offsets" are almost the same.
> (The difference is only the include guards.)  They can be merged.

Good idea.


> Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com>
> ---
> 
>  Kbuild | 59 +++++++++++++++++++++--------------------------------------
>  1 file changed, 21 insertions(+), 38 deletions(-)
> 
> diff --git a/Kbuild b/Kbuild
> index 5d7c729..55a639f 100644
> --- a/Kbuild
> +++ b/Kbuild
> @@ -5,19 +5,20 @@
>  # 2) Generate asm-offsets.h (may need bounds.h)
>  # 3) Check for missing system calls
>  
> -#####
> -# 1) Generate bounds.h
> -
> -bounds-file := include/generated/bounds.h
> -
> -always  := $(bounds-file)
> -targets := $(bounds-file) kernel/bounds.s
> +# Default sed regexp - multiline due to syntax constraints
> +define sed-y
> +	"/^->/{s:->#\(.*\):/* \1 */:; \
> +	s:^->\([^ ]*\) [\$$#]*\([-0-9]*\) \(.*\):#define \1 \2 /* \3 */:; \
> +	s:^->\([^ ]*\) [\$$#]*\([^ ]*\) \(.*\):#define \1 \2 /* \3 */:; \
> +	s:->::; p;}"
> +endef
>  
> -quiet_cmd_bounds = GEN     $@
> -define cmd_bounds
> +quiet_cmd_offsets = GEN     $@
> +define cmd_offsets
>  	(set -e; \
> -	 echo "#ifndef __LINUX_BOUNDS_H__"; \
> -	 echo "#define __LINUX_BOUNDS_H__"; \
> +	 INCLUDE_GUARD=$$(echo __$(notdir $@)__ | tr '[a-z].-' '[A-Z]__'); \
> +	 echo "#ifndef $$INCLUDE_GUARD"; \
> +	 echo "#define $$INCLUDE_GUARD"; \

I think it would be more readable to write it as

  echo "#ifndef $(2)"; \
  ...

and pass the include guard name as an argument to cmd_offsets.

Otherwise it's a great cleanup.

Michal

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules
  2015-01-02 16:04   ` Michal Marek
@ 2015-01-05  6:58     ` Masahiro Yamada
  0 siblings, 0 replies; 5+ messages in thread
From: Masahiro Yamada @ 2015-01-05  6:58 UTC (permalink / raw)
  To: Michal Marek; +Cc: linux-kbuild, linux-kernel

Hi Michal,



On Fri, 02 Jan 2015 17:04:42 +0100
Michal Marek <mmarek@suse.cz> wrote:

> >  
> > -quiet_cmd_bounds = GEN     $@
> > -define cmd_bounds
> > +quiet_cmd_offsets = GEN     $@
> > +define cmd_offsets
> >  	(set -e; \
> > -	 echo "#ifndef __LINUX_BOUNDS_H__"; \
> > -	 echo "#define __LINUX_BOUNDS_H__"; \
> > +	 INCLUDE_GUARD=$$(echo __$(notdir $@)__ | tr '[a-z].-' '[A-Z]__'); \
> > +	 echo "#ifndef $$INCLUDE_GUARD"; \
> > +	 echo "#define $$INCLUDE_GUARD"; \
> 
> I think it would be more readable to write it as
> 
>   echo "#ifndef $(2)"; \
>   ...
> 
> and pass the include guard name as an argument to cmd_offsets.
> 
> Otherwise it's a great cleanup.
> 
> Michal


OK.  I have posted v2.


Best Regards
Masahiro Yamada


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2015-01-05  6:59 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-12-24  6:49 [PATCH 0/2] kbuild: Refactor ./Kbuild Masahiro Yamada
2014-12-24  6:49 ` [PATCH 1/2] kbuild: merge bounds.h and asm-offsets.h rules Masahiro Yamada
2015-01-02 16:04   ` Michal Marek
2015-01-05  6:58     ` Masahiro Yamada
2014-12-24  6:49 ` [PATCH 2/2] kbuild: remove redundant line from bounds.h/asm-offsets.h Masahiro Yamada

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).