archive mirror
 help / color / mirror / Atom feed
* [linux-lvm] lvmcache and bare mdadm arrays
@ 2019-01-16 19:27 Eugene Vikhman
  0 siblings, 0 replies; only message in thread
From: Eugene Vikhman @ 2019-01-16 19:27 UTC (permalink / raw)
  To: linux-lvm

[-- Attachment #1: Type: text/plain, Size: 974 bytes --]


I spent the last couple of days trying to set up a new server with 16 
sas drives for the main storage and 2 SSDs for caching it using lvmcache.

First I used mdadm to create raid10 on HDDs and raid1 on SSDs. Then I 
followed the steps from the lvmcache manpage and the lvcreate/lvconvert 
manpages to create the cache and the metadata LVs and convert them to a 
cache-pool. It went fine, "lvs -a" showed a normal cache-pool device. 
But the last step failed with an ambiguous error when I used lvconvert 
--type cache --cachepool vg/cache vg/slow. I tried playing with 
parameters and made sure that the error had nothing to do with them. For 
an unidentified reason ioctl failed saying it could not lock the device 

Today I tried setting up the raids with lvm itself and it all worked 
like a charm.

So my thought is maybe manpages should actually mention something about 
it and say "don't try setting up caching on a bare mdadm raid - it won't 

[-- Attachment #2: Type: text/html, Size: 1496 bytes --]

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2019-01-16 19:27 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-01-16 19:27 [linux-lvm] lvmcache and bare mdadm arrays Eugene Vikhman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).