Linux-Media Archive on lore.kernel.org
 help / color / Atom feed
From: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
	linux-media@vger.kernel.org,
	Jacopo Mondi <jacopo+renesas@jmondi.org>,
	niklas.soderlund+renesas@ragnatech.se,
	Mauro Carvalho Chehab <mchehab@kernel.org>,
	Hans Verkuil <hverkuil-cisco@xs4all.nl>
Subject: Re: [PATCH v5 12/24] media: entity: Add an iterator helper for connected pads
Date: Thu, 29 Apr 2021 15:14:53 +0300
Message-ID: <08a831ee-fc90-f06f-e3ec-ed79e689f30c@ideasonboard.com> (raw)
In-Reply-To: <20210429120719.GX3@paasikivi.fi.intel.com>

On 29/04/2021 15:07, Sakari Ailus wrote:
> On Thu, Apr 29, 2021 at 03:04:38PM +0300, Tomi Valkeinen wrote:
>> On 29/04/2021 14:56, Sakari Ailus wrote:
>>> Hi Laurent,
>>>
>>> On Thu, Apr 29, 2021 at 04:33:48AM +0300, Laurent Pinchart wrote:
>>>> Hi Sakari,
>>>>
>>>> On Tue, Apr 20, 2021 at 02:48:25PM +0300, Sakari Ailus wrote:
>>>>> On Sun, Apr 18, 2021 at 09:20:03PM +0300, Laurent Pinchart wrote:
>>>>>> On Thu, Apr 15, 2021 at 04:04:38PM +0300, Tomi Valkeinen wrote:
>>>>>>> From: Sakari Ailus <sakari.ailus@linux.intel.com>
>>>>>>>
>>>>>>> Add a helper macro for iterating over pads that are connected through
>>>>>>> enabled routes. This can be used to find all the connected pads within an
>>>>>>> entity, for instance starting from the pad which has been obtained during
>>>>>>> the graph walk.
>>>>>>>
>>>>>>> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
>>>>>>> Reviewed-by: Niklas Söderlund <niklas.soderlund+renesas@ragnatech.se>
>>>>>>>
>>>>>>> - Make __media_entity_next_routed_pad() return NULL and adjust the
>>>>>>>     iterator to handle that
>>>>>>> Signed-off-by: Jacopo Mondi <jacopo+renesas@jmondi.org>
>>>>>>> ---
>>>>>>>    include/media/media-entity.h | 27 +++++++++++++++++++++++++++
>>>>>>>    1 file changed, 27 insertions(+)
>>>>>>>
>>>>>>> diff --git a/include/media/media-entity.h b/include/media/media-entity.h
>>>>>>> index 73de1c335e4e..edd6f60ed6b4 100644
>>>>>>> --- a/include/media/media-entity.h
>>>>>>> +++ b/include/media/media-entity.h
>>>>>>> @@ -916,6 +916,33 @@ __must_check int media_graph_walk_init(
>>>>>>>    bool media_entity_has_route(struct media_entity *entity, unsigned int pad0,
>>>>>>>    			    unsigned int pad1);
>>>>>>> +static inline struct media_pad *__media_entity_next_routed_pad(
>>>>>>> +	struct media_pad *start, struct media_pad *iter)
>>>>>>> +{
>>>>>>> +	struct media_entity *entity = start->entity;
>>>>>>> +
>>>>>>> +	for (; iter < &entity->pads[entity->num_pads]; iter++)
>>>>>>> +		if (media_entity_has_route(entity, start->index, iter->index))
>>>>>>> +			return iter;
>>>>>>
>>>>>> I'd use curly braces.
>>>>>>
>>>>>>> +
>>>>>>> +	return NULL;
>>>>>>> +}
>>>>>>
>>>>>> Does this need to be inlined ?
>>>>>
>>>>> I guess it doesn't have to. It's used inside loops and it's rather small so
>>>>> I think it should be fine that way.
>>>>
>>>> It may not be that small. I'd rather let the compiler decide whether to
>>>> inline it or not.
>>>
>>> Works for me.
>>>
>>>>
>>>>>>> +
>>>>>>> +/**
>>>>>>> + * media_entity_for_each_routed_pad - Iterate over entity pads connected by routes
>>>>>>
>>>>>> "routed" sounds a bit weird. Would media_entity_for_each_connected_pad()
>>>>>> be a better name ?
>>>>>
>>>>> "Connected" is often used in context of links. We're dealing with routes
>>>>> here, so I thought "routed" is appropriate to avoid confusion.
>>>>
>>>> I understand the confusion, maybe we can find a better term that would
>>>> be different than "connected". "routed" really sounds weird in this
>>>> context.
>>>
>>> I'm fine with connected.
>>>
>>>>
>>>>>>> + *
>>>>>>> + * @start: The stating pad
>>>>>>
>>>>>> s/stating/starting/
>>>>>>
>>>>>>> + * @iter: The iterator pad
>>>>>>> + *
>>>>>>> + * Iterate over all pads connected through routes from a given pad
>>>>>>
>>>>>> "from the @start pad"
>>>>>>
>>>>>>> + * within an entity. The iteration will include the starting pad itself.
>>>>>>
>>>>>> s/starting/@start/
>>>>>>
>>>>>> I wonder if it wouldn't be more logical to not include the start pad.
>>>>>> That wouldn't match the current usage patterns, which would need to be
>>>>>> adapted accordingly, but I'm worried that including the start pad will
>>>>>> lead to annoying bugs in the future. Maybe I worry too much.
>>>>>
>>>>> The aim here is to find all pads that are routed to another pad within the
>>>>> same entity. If you remove the start pad, it becomes a task harder than
>>>>> difficult.
>>>>
>>>> Intuitively, "all pads that are routed to another pad" doesn't include
>>>> the "another pad". I'm not opposed to including the start pad as that's
>>>> what the current usage patterns need, but we should then rename the
>>>> macro accordingly as its current name is counter-intuitive.
>>>
>>> I'm certainly not opposed to that. But it shouldn't be too much longer than
>>> what's already there.
>>>
>>>>
>>>>>> And now that I reread the patch, I also wonder if "start" is a good
>>>>>> name, as it implies we start the enumeration from a given pad, while we
>>>>>> enumerate all pads connected to a given pad. I'm not sure what a better
>>>>>> name would be though, maybe just pad ?
>>>>>
>>>>> There are two pads here. Therefore explicitly calling them something else
>>>>> makes sense IMO.
>>>>
>>>> Makes sense, but "start" isn't a good name as we're not starting
>>>> anything.
>>>
>>> "start" is not a verb here. It's where the iteration *starts*.
>>
>> Hmm, no, the 'start' is a filter here, isn't it? The macro iterates over all
>> pads which have a route to 'start'.
> 
> The iteration starts from "start", but it does not return all pads, only
> the connected ones.

No, I don't think it does. It starts from the first pad, and if that is 
connected (has route to 'start') it returns that the first pad.

> But feel free to use another name if you have a better one.

I don't have one, even if I tried. "common_connected_pad" is a bit too 
long =).

Although 'start' hints that it would be the start for the iteration, 
which is misleading. So perhaps 'connected' is better, if only to remove 
the confusion.

  Tomi

  reply index

Thread overview: 72+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-15 13:04 [PATCH v5 00/24] v4l: subdev internal routing Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 01/24] media: entity: Use pad as a starting point for graph walk Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 02/24] media: entity: Use pads instead of entities in the media graph walk stack Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 03/24] media: entity: Walk the graph based on pads Tomi Valkeinen
2021-04-18 17:47   ` Laurent Pinchart
2021-04-20 11:30     ` Sakari Ailus
2021-04-15 13:04 ` [PATCH v5 04/24] v4l: mc: Start walk from a specific pad in use count calculation Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 05/24] media: entity: Add iterator helper for entity pads Tomi Valkeinen
2021-04-18 17:52   ` Laurent Pinchart
2021-04-22 12:04     ` Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 06/24] media: entity: Move the pipeline from entity to pads Tomi Valkeinen
2021-04-18 18:00   ` Laurent Pinchart
2021-04-20 11:38     ` Sakari Ailus
2021-04-15 13:04 ` [PATCH v5 07/24] media: entity: Use pad as the starting point for a pipeline Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 08/24] media: entity: Add has_route entity operation Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 09/24] media: entity: Add media_entity_has_route() function Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 10/24] media: entity: Use routing information during graph traversal Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 11/24] media: entity: Skip link validation for pads to which there is no route to Tomi Valkeinen
2021-04-18 18:06   ` Laurent Pinchart
2021-04-20 11:41     ` Sakari Ailus
2021-04-23 12:37       ` Tomi Valkeinen
2021-04-29 12:06         ` Sakari Ailus
2021-04-29 14:10           ` Laurent Pinchart
2021-04-15 13:04 ` [PATCH v5 12/24] media: entity: Add an iterator helper for connected pads Tomi Valkeinen
2021-04-18 18:20   ` Laurent Pinchart
2021-04-20 11:48     ` Sakari Ailus
2021-04-29  1:33       ` Laurent Pinchart
2021-04-29 11:56         ` Sakari Ailus
2021-04-29 12:04           ` Tomi Valkeinen
2021-04-29 12:07             ` Sakari Ailus
2021-04-29 12:14               ` Tomi Valkeinen [this message]
2021-04-15 13:04 ` [PATCH v5 13/24] media: entity: Add only connected pads to the pipeline Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 14/24] media: entity: Add debug information in graph walk route check Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 15/24] v4l: Add bus type to frame descriptors Tomi Valkeinen
2021-04-18 19:23   ` Laurent Pinchart
2021-04-20 11:50     ` Sakari Ailus
2021-04-22 12:30       ` Tomi Valkeinen
2021-04-29 11:58         ` Sakari Ailus
2021-04-29 14:09           ` Laurent Pinchart
2021-04-15 13:04 ` [PATCH v5 16/24] v4l: Add CSI-2 bus configuration " Tomi Valkeinen
2021-04-18 19:24   ` Laurent Pinchart
2021-04-20 16:32     ` Sakari Ailus
2021-04-15 13:04 ` [PATCH v5 17/24] v4l: Add stream to frame descriptor Tomi Valkeinen
2021-04-18 19:27   ` Laurent Pinchart
2021-04-22 12:47     ` Tomi Valkeinen
2021-04-22 16:18       ` Laurent Pinchart
2021-04-15 13:04 ` [PATCH v5 18/24] v4l: subdev: Add [GS]_ROUTING subdev ioctls and operations Tomi Valkeinen
2021-04-18 18:32   ` Laurent Pinchart
2021-04-22 11:16     ` Tomi Valkeinen
2021-04-22 16:20       ` Laurent Pinchart
2021-04-22 16:58         ` Tomi Valkeinen
2021-04-20 16:35   ` Sakari Ailus
2021-04-15 13:04 ` [PATCH v5 19/24] media: Documentation: Add GS_ROUTING documentation Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 20/24] v4l: mc: Add an S_ROUTING helper function for power state changes Tomi Valkeinen
2021-04-18 18:55   ` Laurent Pinchart
2021-04-20 16:41     ` Sakari Ailus
2021-04-15 13:04 ` [PATCH v5 21/24] v4l: subdev: routing kernel helper functions Tomi Valkeinen
2021-04-18 19:18   ` Laurent Pinchart
2021-04-15 13:04 ` [PATCH v5 22/24] v4l: subdev: add v4l2_subdev_get_format_dir() Tomi Valkeinen
2021-04-18 19:04   ` Laurent Pinchart
2021-04-21 13:04     ` Tomi Valkeinen
2021-04-29  1:43       ` Laurent Pinchart
2021-05-04  6:49         ` Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 23/24] v4l: subdev: Take routing information into account in link validation Tomi Valkeinen
2021-04-15 13:04 ` [PATCH v5 24/24] v4l: subdev: increase V4L2_FRAME_DESC_ENTRY_MAX to 8 Tomi Valkeinen
2021-04-18 19:06   ` Laurent Pinchart
2021-04-16  8:38 ` [PATCH v5 00/24] v4l: subdev internal routing Niklas Söderlund
2021-04-16  8:47   ` Tomi Valkeinen
2021-04-16  8:56     ` Niklas Söderlund
2021-04-18 17:32 ` Laurent Pinchart
2021-04-21 12:57   ` Tomi Valkeinen
2021-04-29  1:27     ` Laurent Pinchart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=08a831ee-fc90-f06f-e3ec-ed79e689f30c@ideasonboard.com \
    --to=tomi.valkeinen@ideasonboard.com \
    --cc=hverkuil-cisco@xs4all.nl \
    --cc=jacopo+renesas@jmondi.org \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=niklas.soderlund+renesas@ragnatech.se \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Linux-Media Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linux-media/0 linux-media/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-media linux-media/ https://lore.kernel.org/linux-media \
		linux-media@vger.kernel.org
	public-inbox-index linux-media

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-media


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git