linux-media.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[]
@ 2020-01-20 19:41 Justin Swartz
  2020-01-20 19:41 ` [PATCH 2/4] [media] dt-bindings: Add rk3228 to the Rockchip RGA binding doc Justin Swartz
  2020-01-21 10:45 ` [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Ezequiel Garcia
  0 siblings, 2 replies; 5+ messages in thread
From: Justin Swartz @ 2020-01-20 19:41 UTC (permalink / raw)
  To: Jacob Chen, Ezequiel Garcia, Mauro Carvalho Chehab, Heiko Stuebner
  Cc: Justin Swartz, linux-media, linux-arm-kernel, linux-rockchip,
	linux-kernel

Add an entry to the rockchip_rga_match array for "rockchip,rk3228-rga"

Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
---
 drivers/media/platform/rockchip/rga/rga.c | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/drivers/media/platform/rockchip/rga/rga.c b/drivers/media/platform/rockchip/rga/rga.c
index e9ff12b6b..268116cd5 100644
--- a/drivers/media/platform/rockchip/rga/rga.c
+++ b/drivers/media/platform/rockchip/rga/rga.c
@@ -956,6 +956,9 @@ static const struct dev_pm_ops rga_pm = {
 
 static const struct of_device_id rockchip_rga_match[] = {
 	{
+		.compatible = "rockchip,rk3228-rga",
+	},
+	{
 		.compatible = "rockchip,rk3288-rga",
 	},
 	{
-- 
2.11.0


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH 2/4] [media] dt-bindings: Add rk3228 to the Rockchip RGA binding doc
  2020-01-20 19:41 [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Justin Swartz
@ 2020-01-20 19:41 ` Justin Swartz
  2020-01-21 10:45 ` [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Ezequiel Garcia
  1 sibling, 0 replies; 5+ messages in thread
From: Justin Swartz @ 2020-01-20 19:41 UTC (permalink / raw)
  To: Jacob Chen, Ezequiel Garcia, Mauro Carvalho Chehab, Rob Herring,
	Mark Rutland, Heiko Stuebner
  Cc: Justin Swartz, linux-media, devicetree, linux-arm-kernel,
	linux-rockchip, linux-kernel

Add "rockchip,rk3228-rga" to the list of acceptable values for
the "compatible" property.

Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
---
 Documentation/devicetree/bindings/media/rockchip-rga.txt | 1 +
 1 file changed, 1 insertion(+)

diff --git a/Documentation/devicetree/bindings/media/rockchip-rga.txt b/Documentation/devicetree/bindings/media/rockchip-rga.txt
index fd5276abf..9bac1782d 100644
--- a/Documentation/devicetree/bindings/media/rockchip-rga.txt
+++ b/Documentation/devicetree/bindings/media/rockchip-rga.txt
@@ -6,6 +6,7 @@ BitBLT, alpha blending and image blur/sharpness.
 
 Required properties:
 - compatible: value should be one of the following
+		"rockchip,rk3228-rga";
 		"rockchip,rk3288-rga";
 		"rockchip,rk3399-rga";
 
-- 
2.11.0


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[]
  2020-01-20 19:41 [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Justin Swartz
  2020-01-20 19:41 ` [PATCH 2/4] [media] dt-bindings: Add rk3228 to the Rockchip RGA binding doc Justin Swartz
@ 2020-01-21 10:45 ` Ezequiel Garcia
  2020-01-21 11:51   ` Justin Swartz
  2020-01-21 13:01   ` Heiko Stuebner
  1 sibling, 2 replies; 5+ messages in thread
From: Ezequiel Garcia @ 2020-01-21 10:45 UTC (permalink / raw)
  To: Justin Swartz, Jacob Chen, Mauro Carvalho Chehab, Heiko Stuebner
  Cc: linux-media, linux-arm-kernel, linux-rockchip, linux-kernel

On Mon, 2020-01-20 at 19:41 +0000, Justin Swartz wrote:
> Add an entry to the rockchip_rga_match array for "rockchip,rk3228-rga"
> 
> Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
> ---
>  drivers/media/platform/rockchip/rga/rga.c | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/drivers/media/platform/rockchip/rga/rga.c b/drivers/media/platform/rockchip/rga/rga.c
> index e9ff12b6b..268116cd5 100644
> --- a/drivers/media/platform/rockchip/rga/rga.c
> +++ b/drivers/media/platform/rockchip/rga/rga.c
> @@ -956,6 +956,9 @@ static const struct dev_pm_ops rga_pm = {
>  
>  static const struct of_device_id rockchip_rga_match[] = {
>  	{
> +		.compatible = "rockchip,rk3228-rga",
> +	},

Unless you need to tune something in the driver
specifically for rk3228, then you don't need a
new compatible string.

As the name implies, it's just a "compatible",
so you may simply declare your rga dts node as
compatible to "rockchip,rk3288-rga".

(Of course, this means we shouldn't have added
the rk3399 compatible string.)

Regards,
Ezequiel


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[]
  2020-01-21 10:45 ` [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Ezequiel Garcia
@ 2020-01-21 11:51   ` Justin Swartz
  2020-01-21 13:01   ` Heiko Stuebner
  1 sibling, 0 replies; 5+ messages in thread
From: Justin Swartz @ 2020-01-21 11:51 UTC (permalink / raw)
  To: Ezequiel Garcia
  Cc: Jacob Chen, Mauro Carvalho Chehab, Heiko Stuebner, linux-media,
	linux-arm-kernel, linux-rockchip, linux-kernel

Hi Ezequiel,

On 2020-01-21 12:45, Ezequiel Garcia wrote:

> On Mon, 2020-01-20 at 19:41 +0000, Justin Swartz wrote:
> 
>> Add an entry to the rockchip_rga_match array for "rockchip,rk3228-rga"
>> 
>> Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
>> ---
>> drivers/media/platform/rockchip/rga/rga.c | 3 +++
>> 1 file changed, 3 insertions(+)
>> 
>> diff --git a/drivers/media/platform/rockchip/rga/rga.c 
>> b/drivers/media/platform/rockchip/rga/rga.c
>> index e9ff12b6b..268116cd5 100644
>> --- a/drivers/media/platform/rockchip/rga/rga.c
>> +++ b/drivers/media/platform/rockchip/rga/rga.c
>> @@ -956,6 +956,9 @@ static const struct dev_pm_ops rga_pm = {
>> 
>> static const struct of_device_id rockchip_rga_match[] = {
>> {
>> +        .compatible = "rockchip,rk3228-rga",
>> +    },
> 
> Unless you need to tune something in the driver
> specifically for rk3228, then you don't need a
> new compatible string.
> 
> As the name implies, it's just a "compatible",
> so you may simply declare your rga dts node as
> compatible to "rockchip,rk3288-rga".
> 
> (Of course, this means we shouldn't have added
> the rk3399 compatible string.)

Thank you for the clarification.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[]
  2020-01-21 10:45 ` [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Ezequiel Garcia
  2020-01-21 11:51   ` Justin Swartz
@ 2020-01-21 13:01   ` Heiko Stuebner
  1 sibling, 0 replies; 5+ messages in thread
From: Heiko Stuebner @ 2020-01-21 13:01 UTC (permalink / raw)
  To: Ezequiel Garcia
  Cc: Justin Swartz, Jacob Chen, Mauro Carvalho Chehab, linux-media,
	linux-arm-kernel, linux-rockchip, linux-kernel

Hi Ezequiel,

Am Dienstag, 21. Januar 2020, 11:45:01 CET schrieb Ezequiel Garcia:
> On Mon, 2020-01-20 at 19:41 +0000, Justin Swartz wrote:
> > Add an entry to the rockchip_rga_match array for "rockchip,rk3228-rga"
> > 
> > Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
> > ---
> >  drivers/media/platform/rockchip/rga/rga.c | 3 +++
> >  1 file changed, 3 insertions(+)
> > 
> > diff --git a/drivers/media/platform/rockchip/rga/rga.c b/drivers/media/platform/rockchip/rga/rga.c
> > index e9ff12b6b..268116cd5 100644
> > --- a/drivers/media/platform/rockchip/rga/rga.c
> > +++ b/drivers/media/platform/rockchip/rga/rga.c
> > @@ -956,6 +956,9 @@ static const struct dev_pm_ops rga_pm = {
> >  
> >  static const struct of_device_id rockchip_rga_match[] = {
> >  	{
> > +		.compatible = "rockchip,rk3228-rga",
> > +	},
> 
> Unless you need to tune something in the driver
> specifically for rk3228, then you don't need a
> new compatible string.
> 
> As the name implies, it's just a "compatible",
> so you may simply declare your rga dts node as
> compatible to "rockchip,rk3288-rga".
> 
> (Of course, this means we shouldn't have added
> the rk3399 compatible string.)

small correction, we normally do that in two parts in the dts,
	compatible = "rockchip,rk3228-rga", "rockchip,rk3288-rga"

etc. So the compatible needs to be added to binding document but
not necessarily to the driver but does leave us the option of later
defining that new compatible in the driver to handle quirks that may
be discovered later on, without needing to adapt existing devicetrees.


Heiko



^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-01-21 13:01 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-20 19:41 [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Justin Swartz
2020-01-20 19:41 ` [PATCH 2/4] [media] dt-bindings: Add rk3228 to the Rockchip RGA binding doc Justin Swartz
2020-01-21 10:45 ` [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[] Ezequiel Garcia
2020-01-21 11:51   ` Justin Swartz
2020-01-21 13:01   ` Heiko Stuebner

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).