linux-media.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Hans Verkuil <hverkuil@xs4all.nl>
To: Marco Felsch <m.felsch@pengutronix.de>
Cc: mchehab@kernel.org, sakari.ailus@linux.intel.com,
	hans.verkuil@cisco.com, jacopo+renesas@jmondi.org,
	robh+dt@kernel.org, laurent.pinchart@ideasonboard.com,
	linux-media@vger.kernel.org, devicetree@vger.kernel.org,
	kernel@pengutronix.de
Subject: Re: [PATCH v7 02/13] media: v4l2-fwnode: add v4l2_fwnode_connector
Date: Mon, 19 Aug 2019 11:18:30 +0200	[thread overview]
Message-ID: <f19fa316-6d89-5c6b-9225-12935a69ff86@xs4all.nl> (raw)
In-Reply-To: <20190819091748.n7v6m2h33xuitrl4@pengutronix.de>

On 8/19/19 11:17 AM, Marco Felsch wrote:
> On 19-08-16 12:59, Hans Verkuil wrote:
>> On 8/15/19 1:57 PM, Marco Felsch wrote:
>>> Currently every driver needs to parse the connector endpoints by it self.
>>> This is the initial work to make this generic. A generic connector has
>>> common members and connector specific members. The common members are:
>>>   - type
>>>   - label (optional)
>>>   - links
>>>   - nr_of_links
>>>
>>> The specific members are stored within a union, since only one of them
>>> can be available at the time. Since this is the initial support the
>>> patch adds only the analog-connector specific ones.
>>>
>>> Signed-off-by: Marco Felsch <m.felsch@pengutronix.de>
>>> ---
>>> [1] https://patchwork.kernel.org/cover/10794703/
>>>
>>> v7:
>>> - fix spelling issues
>>> - constify label
>>> - support variable label size
>>> - replace single remote_port/id members by links member of variable
>>>   size
>>> - squash v4l2-connector into v4l2-fwnode
>>>
>>> @Jacopo: I dropped your r b tag because I changed the port/id logic.
>>>
>>> v6:
>>> - fix some spelling and style issues
>>> - rm unnecessary comments
>>> - drop vga and dvi connector
>>> - fix misspelt connector
>>>
>>> v2-v4:
>>> - nothing since the patch was squashed from series [1] into this
>>>   series.
>>> ---
>>>  include/media/v4l2-fwnode.h | 45 +++++++++++++++++++++++++++++++++++++
>>>  1 file changed, 45 insertions(+)
>>>
>>> diff --git a/include/media/v4l2-fwnode.h b/include/media/v4l2-fwnode.h
>>> index f6a7bcd13197..e39c198882fc 100644
>>> --- a/include/media/v4l2-fwnode.h
>>> +++ b/include/media/v4l2-fwnode.h
>>> @@ -123,6 +123,51 @@ struct v4l2_fwnode_link {
>>>  	unsigned int remote_port;
>>>  };
>>>  
>>> +/**
>>> + * enum v4l2_connector_type - connector type
>>> + * @V4L2_CON_UNKNOWN:   unknown connector type, no V4L2 connector configuration
>>> + * @V4L2_CON_COMPOSITE: analog composite connector
>>> + * @V4L2_CON_SVIDEO:    analog svideo connector
>>> + * @V4L2_CON_HDMI:      digital hdmi connector
>>> + */
>>> +enum v4l2_connector_type {
>>> +	V4L2_CON_UNKNOWN,
>>> +	V4L2_CON_COMPOSITE,
>>> +	V4L2_CON_SVIDEO,
>>> +	V4L2_CON_HDMI,
>>
>> Please use CONN instead of CON. CONN is the traditional abbreviation
>> used for connectors. 'CON' is too generic (there are many words that
>> start with 'con').
> 
> Okay.
> 
>> Regards,
>>
>> 	Hans
>>
>>> +};
>>> +
>>> +/**
>>> + * struct v4l2_fwnode_connector_analog - analog connector data structure
>>> + * @supported_tvnorms: tv norms this connector supports, set to V4L2_STD_ALL
>>> + *                     if no restrictions are specified.
>>> + */
>>> +struct v4l2_fwnode_connector_analog {
>>> +	v4l2_std_id supported_tvnorms;
> 
> After we found the correct dt-binding and naming convention I would
> change that property to 'sdtv_stds'. Is that okay?

Yes.

	Hans

> 
> Regards,
>   Marco
> 
>>> +};
>>> +
>>> +/**
>>> + * struct v4l2_fwnode_connector - the connector data structure
>>> + * @label: optional connector label
>>> + * @type: connector type
>>> + * @links: list of &struct v4l2_fwnode_link links the connector is connected to
>>> + * @nr_of_links: total number of links
>>> + * @connector: connector configuration
>>> + * @connector.analog: analog connector configuration
>>> + *                    &struct v4l2_fwnode_connector_analog
>>> + */
>>> +struct v4l2_fwnode_connector {
>>> +	const char *label;
>>> +	enum v4l2_connector_type type;
>>> +	struct v4l2_fwnode_link *links;
>>> +	unsigned int nr_of_links;
>>> +
>>> +	union {
>>> +		struct v4l2_fwnode_connector_analog analog;
>>> +		/* future connectors */
>>> +	} connector;
>>> +};
>>> +
>>>  /**
>>>   * v4l2_fwnode_endpoint_parse() - parse all fwnode node properties
>>>   * @fwnode: pointer to the endpoint's fwnode handle
>>>
>>
>>
> 


  reply	other threads:[~2019-08-19  9:18 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-15 11:57 [PATCH v7 00/13] Add TVP5150 features Marco Felsch
2019-08-15 11:57 ` [PATCH v7 01/13] dt-bindings: connector: analog: add tv norms property Marco Felsch
2019-08-16 11:11   ` Hans Verkuil
2019-08-19  8:09     ` Marco Felsch
2019-08-19  8:18       ` Marco Felsch
2019-08-19  8:41         ` Hans Verkuil
2019-08-19  8:39       ` Hans Verkuil
2019-08-19  9:01         ` Marco Felsch
2019-08-19  9:06           ` Hans Verkuil
2019-08-15 11:57 ` [PATCH v7 02/13] media: v4l2-fwnode: add v4l2_fwnode_connector Marco Felsch
2019-08-16 10:59   ` Hans Verkuil
2019-08-19  9:17     ` Marco Felsch
2019-08-19  9:18       ` Hans Verkuil [this message]
2019-08-15 11:57 ` [PATCH v7 03/13] media: v4l2-fwnode: add initial connector parsing support Marco Felsch
2019-08-15 11:57 ` [PATCH v7 04/13] partial revert of "[media] tvp5150: add HW input connectors support" Marco Felsch
2019-08-15 11:57 ` [PATCH v7 05/13] media: tvp5150: add input source selection of_graph support Marco Felsch
2019-08-19  6:20   ` Marco Felsch
2019-08-15 11:57 ` [PATCH v7 06/13] media: dt-bindings: tvp5150: Add input port connectors DT bindings Marco Felsch
2019-08-16 21:01   ` Rob Herring
2019-08-15 11:57 ` [PATCH v7 07/13] media: tvp5150: add FORMAT_TRY support for get/set selection handlers Marco Felsch
2019-08-16 11:27   ` Hans Verkuil
2019-08-19 10:40     ` Marco Felsch
2019-08-19 10:41       ` Hans Verkuil
2019-08-15 11:57 ` [PATCH v7 08/13] media: tvp5150: initialize subdev before parsing device tree Marco Felsch
2019-08-15 11:57 ` [PATCH v7 09/13] media: tvp5150: add s_power callback Marco Felsch
2019-08-15 11:57 ` [PATCH v7 10/13] media: dt-bindings: tvp5150: cleanup bindings stlye Marco Felsch
2019-08-16 11:28   ` Hans Verkuil
2019-08-15 11:57 ` [PATCH v7 11/13] media: dt-bindings: tvp5150: add optional tvnorms documentation Marco Felsch
2019-08-15 11:57 ` [PATCH v7 12/13] media: tvp5150: add support to limit tv norms on connector Marco Felsch
2019-08-15 11:57 ` [PATCH v7 13/13] media: tvp5150: make debug output more readable Marco Felsch

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f19fa316-6d89-5c6b-9225-12935a69ff86@xs4all.nl \
    --to=hverkuil@xs4all.nl \
    --cc=devicetree@vger.kernel.org \
    --cc=hans.verkuil@cisco.com \
    --cc=jacopo+renesas@jmondi.org \
    --cc=kernel@pengutronix.de \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-media@vger.kernel.org \
    --cc=m.felsch@pengutronix.de \
    --cc=mchehab@kernel.org \
    --cc=robh+dt@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).