linux-mediatek.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v5 0/10] mfd: mt6360: Merge different sub-devices I2C read/write
@ 2020-09-22 10:20 Gene Chen
  2020-09-22 10:20 ` [PATCH v5 01/10] mfd: mt6360: Rearrange include file Gene Chen
                   ` (9 more replies)
  0 siblings, 10 replies; 15+ messages in thread
From: Gene Chen @ 2020-09-22 10:20 UTC (permalink / raw)
  To: lee.jones, matthias.bgg
  Cc: gene_chen, linux-kernel, cy_huang, benjamin.chao, linux-mediatek,
	Wilma.Wu, linux-arm-kernel, shufan_lee

This patch series merge different sub-device I2C read/write into one Regmap and
fix coding style for well-organized.

Gene Chen (10)
  mfd: mt6360: Rearrange include file
  mfd: mt6360: Remove redundant brackets around raw numbers
  mfd: mt6360: Indicate sub-dev compatible name by using
  mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360
  mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata
  mfd: mt6360: Rename mt6360_pmu by mt6360
  mfd: mt6360: Remove handle_post_irq callback function
  mfd: mt6360: Fix flow which is used to check ic exist
  mfd: mt6360: Merge header file into driver and remove unuse register define
  mfd: mt6360: Merge different sub-devices I2C read/write

 b/drivers/mfd/Kconfig       |    1 
 b/drivers/mfd/mt6360-core.c |  564 +++++++++++++++++++++++++++++---------------
 include/linux/mfd/mt6360.h  |  240 ------------------
 3 files changed, 380 insertions(+), 425 deletions(-)

changelogs between v2 & v3
- Replace mt6360_data to mt6360_ddata
- Split I2C read/write to regmap driver

changelogs between v3 & v4
- Merge back mt6360 regmap driver to MFD driver

changelogs between v4 & v5
- use devm_regmap_init
- define crc calculation magic number


_______________________________________________
Linux-mediatek mailing list
Linux-mediatek@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-mediatek

^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2020-11-04 15:39 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-22 10:20 [PATCH v5 0/10] mfd: mt6360: Merge different sub-devices I2C read/write Gene Chen
2020-09-22 10:20 ` [PATCH v5 01/10] mfd: mt6360: Rearrange include file Gene Chen
2020-09-22 10:20 ` [PATCH v5 02/10] mfd: mt6360: Remove redundant brackets around raw numbers Gene Chen
2020-09-22 10:20 ` [PATCH v5 03/10] mfd: mt6360: Indicate sub-dev compatible name by using "-" Gene Chen
2020-09-22 10:20 ` [PATCH v5 04/10] mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360 regulator resources Gene Chen
2020-10-01  9:10   ` Lee Jones
2020-09-22 10:20 ` [PATCH v5 05/10] mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata Gene Chen
2020-09-22 10:20 ` [PATCH v5 06/10] mfd: mt6360: Rename mt6360_pmu by mt6360 Gene Chen
2020-09-22 10:20 ` [PATCH v5 07/10] mfd: mt6360: Remove handle_post_irq callback function Gene Chen
2020-09-22 10:20 ` [PATCH v5 08/10] mfd: mt6360: Fix flow which is used to check ic exist Gene Chen
2020-09-22 10:20 ` [PATCH v5 09/10] mfd: mt6360: Merge header file into driver and remove unuse register define Gene Chen
2020-10-01  9:11   ` Lee Jones
2020-09-22 10:20 ` [PATCH v5 10/10] mfd: mt6360: Merge different sub-devices I2C read/write Gene Chen
2020-10-27  9:35   ` Gene Chen
2020-11-04 15:38   ` Lee Jones

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).