linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/5] mm/vmalloc.c: improve readability and rewrite vmap_area
@ 2019-06-30  7:56 Pengfei Li
  2019-06-30  7:56 ` [PATCH 1/5] mm/vmalloc.c: Introduce a wrapper function of insert_vmap_area() Pengfei Li
                   ` (5 more replies)
  0 siblings, 6 replies; 12+ messages in thread
From: Pengfei Li @ 2019-06-30  7:56 UTC (permalink / raw)
  To: akpm, peterz, urezki
  Cc: rpenyaev, mhocko, guro, aryabinin, rppt, mingo, rick.p.edgecombe,
	linux-mm, linux-kernel, Pengfei Li

Hi,

This series of patches is to reduce the size of struct vmap_area.

Since the members of struct vmap_area are not being used at the same time,
it is possible to reduce its size by placing several members that are not
used at the same time in a union.

The first 4 patches did some preparatory work for this and improved
readability.

The fifth patch is the main patch, it did the work of rewriting vmap_area.

More details can be obtained from the commit message.

Thanks,

Pengfei

Pengfei Li (5):
  mm/vmalloc.c: Introduce a wrapper function of insert_vmap_area()
  mm/vmalloc.c: Introduce a wrapper function of
    insert_vmap_area_augment()
  mm/vmalloc.c: Rename function __find_vmap_area() for readability
  mm/vmalloc.c: Modify function merge_or_add_vmap_area() for readability
  mm/vmalloc.c: Rewrite struct vmap_area to reduce its size

 include/linux/vmalloc.h |  28 +++++---
 mm/vmalloc.c            | 144 +++++++++++++++++++++++++++-------------
 2 files changed, 117 insertions(+), 55 deletions(-)

-- 
2.21.0


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2019-07-02 12:41 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-06-30  7:56 [PATCH 0/5] mm/vmalloc.c: improve readability and rewrite vmap_area Pengfei Li
2019-06-30  7:56 ` [PATCH 1/5] mm/vmalloc.c: Introduce a wrapper function of insert_vmap_area() Pengfei Li
2019-06-30  7:56 ` [PATCH 2/5] mm/vmalloc.c: Introduce a wrapper function of insert_vmap_area_augment() Pengfei Li
2019-06-30  7:56 ` [PATCH 3/5] mm/vmalloc.c: Rename function __find_vmap_area() for readability Pengfei Li
2019-07-02 12:23   ` Matthew Wilcox
2019-07-02 12:40     ` oddtux
2019-06-30  7:56 ` [PATCH 4/5] mm/vmalloc.c: Modify function merge_or_add_vmap_area() " Pengfei Li
2019-06-30  7:56 ` [PATCH 5/5] mm/vmalloc.c: Rewrite struct vmap_area to reduce its size Pengfei Li
2019-07-01  9:20 ` [PATCH 0/5] mm/vmalloc.c: improve readability and rewrite vmap_area Michal Hocko
2019-07-01 10:11   ` Uladzislau Rezki
2019-07-02 12:18     ` oddtux
2019-07-02 11:51   ` oddtux

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).