linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] mm: rename gfpflags_to_migratetype to gfp_migratetype for same convention
@ 2020-03-29  8:08 Wei Yang
  2020-03-30  7:31 ` Pankaj Gupta
  0 siblings, 1 reply; 3+ messages in thread
From: Wei Yang @ 2020-03-29  8:08 UTC (permalink / raw)
  To: akpm; +Cc: linux-mm, linux-kernel, Wei Yang

Pageblock migrate type is encoded in GFP flags, just as zone_type and
zonelist.

Currently we use gfp_zone() and gfp_zonelist() to extract related
information, it would be proper to use the same naming convention for
migrate type.

Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
---
 include/linux/gfp.h | 2 +-
 mm/compaction.c     | 2 +-
 mm/page_alloc.c     | 4 ++--
 mm/page_owner.c     | 7 +++----
 4 files changed, 7 insertions(+), 8 deletions(-)

diff --git a/include/linux/gfp.h b/include/linux/gfp.h
index e5b817cb86e7..7874b8e1c29f 100644
--- a/include/linux/gfp.h
+++ b/include/linux/gfp.h
@@ -305,7 +305,7 @@ struct vm_area_struct;
 #define GFP_MOVABLE_MASK (__GFP_RECLAIMABLE|__GFP_MOVABLE)
 #define GFP_MOVABLE_SHIFT 3
 
-static inline int gfpflags_to_migratetype(const gfp_t gfp_flags)
+static inline int gfp_migratetype(const gfp_t gfp_flags)
 {
 	VM_WARN_ON((gfp_flags & GFP_MOVABLE_MASK) == GFP_MOVABLE_MASK);
 	BUILD_BUG_ON((1UL << GFP_MOVABLE_SHIFT) != ___GFP_MOVABLE);
diff --git a/mm/compaction.c b/mm/compaction.c
index 672d3c78c6ab..784128c79e6f 100644
--- a/mm/compaction.c
+++ b/mm/compaction.c
@@ -2089,7 +2089,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc)
 	INIT_LIST_HEAD(&cc->freepages);
 	INIT_LIST_HEAD(&cc->migratepages);
 
-	cc->migratetype = gfpflags_to_migratetype(cc->gfp_mask);
+	cc->migratetype = gfp_migratetype(cc->gfp_mask);
 	ret = compaction_suitable(cc->zone, cc->order, cc->alloc_flags,
 							cc->classzone_idx);
 	/* Compaction is likely to fail */
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index 0e823bca3f2f..ef790dfad6aa 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -4182,7 +4182,7 @@ gfp_to_alloc_flags(gfp_t gfp_mask)
 		alloc_flags |= ALLOC_KSWAPD;
 
 #ifdef CONFIG_CMA
-	if (gfpflags_to_migratetype(gfp_mask) == MIGRATE_MOVABLE)
+	if (gfp_migratetype(gfp_mask) == MIGRATE_MOVABLE)
 		alloc_flags |= ALLOC_CMA;
 #endif
 	return alloc_flags;
@@ -4632,7 +4632,7 @@ static inline bool prepare_alloc_pages(gfp_t gfp_mask, unsigned int order,
 	ac->high_zoneidx = gfp_zone(gfp_mask);
 	ac->zonelist = node_zonelist(preferred_nid, gfp_mask);
 	ac->nodemask = nodemask;
-	ac->migratetype = gfpflags_to_migratetype(gfp_mask);
+	ac->migratetype = gfp_migratetype(gfp_mask);
 
 	if (cpusets_enabled()) {
 		*alloc_mask |= __GFP_HARDWALL;
diff --git a/mm/page_owner.c b/mm/page_owner.c
index 18ecde9f45b2..360461509423 100644
--- a/mm/page_owner.c
+++ b/mm/page_owner.c
@@ -312,8 +312,7 @@ void pagetypeinfo_showmixedcount_print(struct seq_file *m,
 				continue;
 
 			page_owner = get_page_owner(page_ext);
-			page_mt = gfpflags_to_migratetype(
-					page_owner->gfp_mask);
+			page_mt = gfp_migratetype(page_owner->gfp_mask);
 			if (pageblock_mt != page_mt) {
 				if (is_migrate_cma(pageblock_mt))
 					count[MIGRATE_MOVABLE]++;
@@ -359,7 +358,7 @@ print_page_owner(char __user *buf, size_t count, unsigned long pfn,
 
 	/* Print information relevant to grouping pages by mobility */
 	pageblock_mt = get_pageblock_migratetype(page);
-	page_mt  = gfpflags_to_migratetype(page_owner->gfp_mask);
+	page_mt  = gfp_migratetype(page_owner->gfp_mask);
 	ret += snprintf(kbuf + ret, count - ret,
 			"PFN %lu type %s Block %lu type %s Flags %#lx(%pGp)\n",
 			pfn,
@@ -416,7 +415,7 @@ void __dump_page_owner(struct page *page)
 
 	page_owner = get_page_owner(page_ext);
 	gfp_mask = page_owner->gfp_mask;
-	mt = gfpflags_to_migratetype(gfp_mask);
+	mt = gfp_migratetype(gfp_mask);
 
 	if (!test_bit(PAGE_EXT_OWNER, &page_ext->flags)) {
 		pr_alert("page_owner info is not present (never set?)\n");
-- 
2.23.0



^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] mm: rename gfpflags_to_migratetype to gfp_migratetype for same convention
  2020-03-29  8:08 [PATCH] mm: rename gfpflags_to_migratetype to gfp_migratetype for same convention Wei Yang
@ 2020-03-30  7:31 ` Pankaj Gupta
  2020-03-30 12:33   ` Wei Yang
  0 siblings, 1 reply; 3+ messages in thread
From: Pankaj Gupta @ 2020-03-30  7:31 UTC (permalink / raw)
  To: Wei Yang; +Cc: Andrew Morton, linux-mm, linux-kernel

> Pageblock migrate type is encoded in GFP flags, just as zone_type and
> zonelist.
>
> Currently we use gfp_zone() and gfp_zonelist() to extract related
> information, it would be proper to use the same naming convention for
> migrate type.
>
> Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
> ---
>  include/linux/gfp.h | 2 +-
>  mm/compaction.c     | 2 +-
>  mm/page_alloc.c     | 4 ++--
>  mm/page_owner.c     | 7 +++----
>  4 files changed, 7 insertions(+), 8 deletions(-)
>
> diff --git a/include/linux/gfp.h b/include/linux/gfp.h
> index e5b817cb86e7..7874b8e1c29f 100644
> --- a/include/linux/gfp.h
> +++ b/include/linux/gfp.h
> @@ -305,7 +305,7 @@ struct vm_area_struct;
>  #define GFP_MOVABLE_MASK (__GFP_RECLAIMABLE|__GFP_MOVABLE)
>  #define GFP_MOVABLE_SHIFT 3
>
> -static inline int gfpflags_to_migratetype(const gfp_t gfp_flags)
> +static inline int gfp_migratetype(const gfp_t gfp_flags)
>  {
>         VM_WARN_ON((gfp_flags & GFP_MOVABLE_MASK) == GFP_MOVABLE_MASK);
>         BUILD_BUG_ON((1UL << GFP_MOVABLE_SHIFT) != ___GFP_MOVABLE);
> diff --git a/mm/compaction.c b/mm/compaction.c
> index 672d3c78c6ab..784128c79e6f 100644
> --- a/mm/compaction.c
> +++ b/mm/compaction.c
> @@ -2089,7 +2089,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc)
>         INIT_LIST_HEAD(&cc->freepages);
>         INIT_LIST_HEAD(&cc->migratepages);
>
> -       cc->migratetype = gfpflags_to_migratetype(cc->gfp_mask);
> +       cc->migratetype = gfp_migratetype(cc->gfp_mask);
>         ret = compaction_suitable(cc->zone, cc->order, cc->alloc_flags,
>                                                         cc->classzone_idx);
>         /* Compaction is likely to fail */
> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> index 0e823bca3f2f..ef790dfad6aa 100644
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -4182,7 +4182,7 @@ gfp_to_alloc_flags(gfp_t gfp_mask)
>                 alloc_flags |= ALLOC_KSWAPD;
>
>  #ifdef CONFIG_CMA
> -       if (gfpflags_to_migratetype(gfp_mask) == MIGRATE_MOVABLE)
> +       if (gfp_migratetype(gfp_mask) == MIGRATE_MOVABLE)
>                 alloc_flags |= ALLOC_CMA;
>  #endif
>         return alloc_flags;
> @@ -4632,7 +4632,7 @@ static inline bool prepare_alloc_pages(gfp_t gfp_mask, unsigned int order,
>         ac->high_zoneidx = gfp_zone(gfp_mask);
>         ac->zonelist = node_zonelist(preferred_nid, gfp_mask);
>         ac->nodemask = nodemask;
> -       ac->migratetype = gfpflags_to_migratetype(gfp_mask);
> +       ac->migratetype = gfp_migratetype(gfp_mask);
>
>         if (cpusets_enabled()) {
>                 *alloc_mask |= __GFP_HARDWALL;
> diff --git a/mm/page_owner.c b/mm/page_owner.c
> index 18ecde9f45b2..360461509423 100644
> --- a/mm/page_owner.c
> +++ b/mm/page_owner.c
> @@ -312,8 +312,7 @@ void pagetypeinfo_showmixedcount_print(struct seq_file *m,
>                                 continue;
>
>                         page_owner = get_page_owner(page_ext);
> -                       page_mt = gfpflags_to_migratetype(
> -                                       page_owner->gfp_mask);
> +                       page_mt = gfp_migratetype(page_owner->gfp_mask);
>                         if (pageblock_mt != page_mt) {
>                                 if (is_migrate_cma(pageblock_mt))
>                                         count[MIGRATE_MOVABLE]++;
> @@ -359,7 +358,7 @@ print_page_owner(char __user *buf, size_t count, unsigned long pfn,
>
>         /* Print information relevant to grouping pages by mobility */
>         pageblock_mt = get_pageblock_migratetype(page);
> -       page_mt  = gfpflags_to_migratetype(page_owner->gfp_mask);
> +       page_mt  = gfp_migratetype(page_owner->gfp_mask);
>         ret += snprintf(kbuf + ret, count - ret,
>                         "PFN %lu type %s Block %lu type %s Flags %#lx(%pGp)\n",
>                         pfn,
> @@ -416,7 +415,7 @@ void __dump_page_owner(struct page *page)
>
>         page_owner = get_page_owner(page_ext);
>         gfp_mask = page_owner->gfp_mask;
> -       mt = gfpflags_to_migratetype(gfp_mask);
> +       mt = gfp_migratetype(gfp_mask);
>
>         if (!test_bit(PAGE_EXT_OWNER, &page_ext->flags)) {
>                 pr_alert("page_owner info is not present (never set?)\n");
> --
> 2.23.0

I think it makes sense for naming consistency, at-least to me.

Reviewed-by: Pankaj Gupta <pankaj.gupta.linux@gmail.com>
>
>


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] mm: rename gfpflags_to_migratetype to gfp_migratetype for same convention
  2020-03-30  7:31 ` Pankaj Gupta
@ 2020-03-30 12:33   ` Wei Yang
  0 siblings, 0 replies; 3+ messages in thread
From: Wei Yang @ 2020-03-30 12:33 UTC (permalink / raw)
  To: Pankaj Gupta; +Cc: Wei Yang, Andrew Morton, linux-mm, linux-kernel

On Mon, Mar 30, 2020 at 09:31:59AM +0200, Pankaj Gupta wrote:
...
>
>I think it makes sense for naming consistency, at-least to me.
>

Thanks

>Reviewed-by: Pankaj Gupta <pankaj.gupta.linux@gmail.com>
>>
>>

-- 
Wei Yang
Help you, Help me


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-03-30 12:33 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-03-29  8:08 [PATCH] mm: rename gfpflags_to_migratetype to gfp_migratetype for same convention Wei Yang
2020-03-30  7:31 ` Pankaj Gupta
2020-03-30 12:33   ` Wei Yang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).