linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] kprobes: Use module_name() macro
@ 2020-08-18  5:08 Jarkko Sakkinen
  2020-08-18 14:49 ` Masami Hiramatsu
  0 siblings, 1 reply; 5+ messages in thread
From: Jarkko Sakkinen @ 2020-08-18  5:08 UTC (permalink / raw)
  To: linux-kernel
  Cc: Jarkko Sakkinen, linux-mm, Andi Kleen, Ard Biesheuvel,
	Jessica Yu, Mark Rutland, Masami Hiramatsu, Mike Rapoport,
	Peter Zijlstra, Russell King, Will Deacon, Steven Rostedt,
	Ingo Molnar

It is advised to use module_name() macro instead of dereferencing mod->name
directly. This makes sense for consistencys sake and also it prevents a
hard dependency to CONFIG_MODULES.

Cc: linux-mm@kvack.org
Cc: Andi Kleen <ak@linux.intel.com>
Cc: Ard Biesheuvel <ardb@kernel.org>
Cc: Jessica Yu <jeyu@kernel.org>
Cc: Mark Rutland <mark.rutland@arm.com>,
Cc: Masami Hiramatsu <mhiramat@kernel.org>
Cc: Mike Rapoport <rppt@kernel.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Russell King <linux@armlinux.org.uk>
Cc: Will Deacon <will@kernel.org>
Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
---
I thought that to get things moving it would make sense to fix this low
hanging fruit issue first. Similarly as Masami's fix kernel/kprobes.c
this will make my patch set less rambling, and thus easier to follow.
 kernel/trace/trace_kprobe.c | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
index aefb6065b508..19c00ee90945 100644
--- a/kernel/trace/trace_kprobe.c
+++ b/kernel/trace/trace_kprobe.c
@@ -106,9 +106,10 @@ static nokprobe_inline bool trace_kprobe_has_gone(struct trace_kprobe *tk)
 static nokprobe_inline bool trace_kprobe_within_module(struct trace_kprobe *tk,
 						 struct module *mod)
 {
-	int len = strlen(mod->name);
+	int len = strlen(module_name(mod));
 	const char *name = trace_kprobe_symbol(tk);
-	return strncmp(mod->name, name, len) == 0 && name[len] == ':';
+
+	return strncmp(module_name(mod), name, len) == 0 && name[len] == ':';
 }
 
 static nokprobe_inline bool trace_kprobe_module_exist(struct trace_kprobe *tk)
@@ -688,7 +689,7 @@ static int trace_kprobe_module_callback(struct notifier_block *nb,
 			if (ret)
 				pr_warn("Failed to re-register probe %s on %s: %d\n",
 					trace_probe_name(&tk->tp),
-					mod->name, ret);
+					module_name(mod), ret);
 		}
 	}
 	mutex_unlock(&event_mutex);
-- 
2.25.1



^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] kprobes: Use module_name() macro
  2020-08-18  5:08 [PATCH] kprobes: Use module_name() macro Jarkko Sakkinen
@ 2020-08-18 14:49 ` Masami Hiramatsu
  2020-08-18 16:33   ` Jarkko Sakkinen
  0 siblings, 1 reply; 5+ messages in thread
From: Masami Hiramatsu @ 2020-08-18 14:49 UTC (permalink / raw)
  To: Jarkko Sakkinen
  Cc: linux-kernel, linux-mm, Andi Kleen, Ard Biesheuvel, Jessica Yu,
	Mark Rutland, Masami Hiramatsu, Mike Rapoport, Peter Zijlstra,
	Russell King, Will Deacon, Steven Rostedt, Ingo Molnar

On Tue, 18 Aug 2020 08:08:57 +0300
Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> wrote:

> It is advised to use module_name() macro instead of dereferencing mod->name
> directly. This makes sense for consistencys sake and also it prevents a
> hard dependency to CONFIG_MODULES.
> 
> Cc: linux-mm@kvack.org
> Cc: Andi Kleen <ak@linux.intel.com>
> Cc: Ard Biesheuvel <ardb@kernel.org>
> Cc: Jessica Yu <jeyu@kernel.org>
> Cc: Mark Rutland <mark.rutland@arm.com>,
> Cc: Masami Hiramatsu <mhiramat@kernel.org>
> Cc: Mike Rapoport <rppt@kernel.org>
> Cc: Peter Zijlstra <peterz@infradead.org>
> Cc: Russell King <linux@armlinux.org.uk>
> Cc: Will Deacon <will@kernel.org>
> Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>

OK, this looks good to me.

Acked-by: Masami Hiramatsu <mhiramat@kernel.org>

Thank you,

> ---
> I thought that to get things moving it would make sense to fix this low
> hanging fruit issue first. Similarly as Masami's fix kernel/kprobes.c
> this will make my patch set less rambling, and thus easier to follow.
>  kernel/trace/trace_kprobe.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
> index aefb6065b508..19c00ee90945 100644
> --- a/kernel/trace/trace_kprobe.c
> +++ b/kernel/trace/trace_kprobe.c
> @@ -106,9 +106,10 @@ static nokprobe_inline bool trace_kprobe_has_gone(struct trace_kprobe *tk)
>  static nokprobe_inline bool trace_kprobe_within_module(struct trace_kprobe *tk,
>  						 struct module *mod)
>  {
> -	int len = strlen(mod->name);
> +	int len = strlen(module_name(mod));
>  	const char *name = trace_kprobe_symbol(tk);
> -	return strncmp(mod->name, name, len) == 0 && name[len] == ':';
> +
> +	return strncmp(module_name(mod), name, len) == 0 && name[len] == ':';
>  }
>  
>  static nokprobe_inline bool trace_kprobe_module_exist(struct trace_kprobe *tk)
> @@ -688,7 +689,7 @@ static int trace_kprobe_module_callback(struct notifier_block *nb,
>  			if (ret)
>  				pr_warn("Failed to re-register probe %s on %s: %d\n",
>  					trace_probe_name(&tk->tp),
> -					mod->name, ret);
> +					module_name(mod), ret);
>  		}
>  	}
>  	mutex_unlock(&event_mutex);
> -- 
> 2.25.1
> 


-- 
Masami Hiramatsu <mhiramat@kernel.org>


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] kprobes: Use module_name() macro
  2020-08-18 14:49 ` Masami Hiramatsu
@ 2020-08-18 16:33   ` Jarkko Sakkinen
  2020-08-18 17:00     ` Steven Rostedt
  0 siblings, 1 reply; 5+ messages in thread
From: Jarkko Sakkinen @ 2020-08-18 16:33 UTC (permalink / raw)
  To: Masami Hiramatsu
  Cc: linux-kernel, linux-mm, Andi Kleen, Ard Biesheuvel, Jessica Yu,
	Mark Rutland, Mike Rapoport, Peter Zijlstra, Russell King,
	Will Deacon, Steven Rostedt, Ingo Molnar

On Tue, Aug 18, 2020 at 11:49:56PM +0900, Masami Hiramatsu wrote:
> On Tue, 18 Aug 2020 08:08:57 +0300
> Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> wrote:
> 
> > It is advised to use module_name() macro instead of dereferencing mod->name
> > directly. This makes sense for consistencys sake and also it prevents a
> > hard dependency to CONFIG_MODULES.
> > 
> > Cc: linux-mm@kvack.org
> > Cc: Andi Kleen <ak@linux.intel.com>
> > Cc: Ard Biesheuvel <ardb@kernel.org>
> > Cc: Jessica Yu <jeyu@kernel.org>
> > Cc: Mark Rutland <mark.rutland@arm.com>,
> > Cc: Masami Hiramatsu <mhiramat@kernel.org>
> > Cc: Mike Rapoport <rppt@kernel.org>
> > Cc: Peter Zijlstra <peterz@infradead.org>
> > Cc: Russell King <linux@armlinux.org.uk>
> > Cc: Will Deacon <will@kernel.org>
> > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
> 
> OK, this looks good to me.
> 
> Acked-by: Masami Hiramatsu <mhiramat@kernel.org>

Great, thank you.

When this might get included to a PR, or at minimum land to linux-next?

Just thinking what to use as the baseline for the next version of my
main series.

BR,
/Jarkko


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] kprobes: Use module_name() macro
  2020-08-18 16:33   ` Jarkko Sakkinen
@ 2020-08-18 17:00     ` Steven Rostedt
  2020-08-19 21:06       ` Jarkko Sakkinen
  0 siblings, 1 reply; 5+ messages in thread
From: Steven Rostedt @ 2020-08-18 17:00 UTC (permalink / raw)
  To: Jarkko Sakkinen
  Cc: Masami Hiramatsu, linux-kernel, linux-mm, Andi Kleen,
	Ard Biesheuvel, Jessica Yu, Mark Rutland, Mike Rapoport,
	Peter Zijlstra, Russell King, Will Deacon, Ingo Molnar

On Tue, 18 Aug 2020 19:33:56 +0300
Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> wrote:

> > Acked-by: Masami Hiramatsu <mhiramat@kernel.org>  
> 
> Great, thank you.
> 
> When this might get included to a PR, or at minimum land to linux-next?
> 
> Just thinking what to use as the baseline for the next version of my
> main series.

I can apply this to my tree along with Masami's latest bootconfig
patches. This will be for linux-next. I don't usually push to
linux-next until around -rc3. Would that be too late?

-- Steve


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] kprobes: Use module_name() macro
  2020-08-18 17:00     ` Steven Rostedt
@ 2020-08-19 21:06       ` Jarkko Sakkinen
  0 siblings, 0 replies; 5+ messages in thread
From: Jarkko Sakkinen @ 2020-08-19 21:06 UTC (permalink / raw)
  To: Steven Rostedt
  Cc: Masami Hiramatsu, linux-kernel, linux-mm, Andi Kleen,
	Ard Biesheuvel, Jessica Yu, Mark Rutland, Mike Rapoport,
	Peter Zijlstra, Russell King, Will Deacon, Ingo Molnar

On Tue, Aug 18, 2020 at 01:00:45PM -0400, Steven Rostedt wrote:
> On Tue, 18 Aug 2020 19:33:56 +0300
> Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> wrote:
> 
> > > Acked-by: Masami Hiramatsu <mhiramat@kernel.org>  
> > 
> > Great, thank you.
> > 
> > When this might get included to a PR, or at minimum land to linux-next?
> > 
> > Just thinking what to use as the baseline for the next version of my
> > main series.
> 
> I can apply this to my tree along with Masami's latest bootconfig
> patches. This will be for linux-next. I don't usually push to
> linux-next until around -rc3. Would that be too late?
> 
> -- Steve

Nope. I have piles of stuff to catch before getting to work with this
(because coming back from vacation).

/Jarkko


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-08-19 21:06 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-08-18  5:08 [PATCH] kprobes: Use module_name() macro Jarkko Sakkinen
2020-08-18 14:49 ` Masami Hiramatsu
2020-08-18 16:33   ` Jarkko Sakkinen
2020-08-18 17:00     ` Steven Rostedt
2020-08-19 21:06       ` Jarkko Sakkinen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).