linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/13] mm: clean up some lru related pieces
@ 2020-09-18  3:00 Yu Zhao
  2020-09-18  3:00 ` [PATCH 01/13] mm: use add_page_to_lru_list() Yu Zhao
                   ` (14 more replies)
  0 siblings, 15 replies; 30+ messages in thread
From: Yu Zhao @ 2020-09-18  3:00 UTC (permalink / raw)
  To: Andrew Morton, Michal Hocko
  Cc: Alex Shi, Steven Rostedt, Ingo Molnar, Johannes Weiner,
	Vladimir Davydov, Roman Gushchin, Shakeel Butt, Chris Down,
	Yafang Shao, Vlastimil Babka, Huang Ying, Pankaj Gupta,
	Matthew Wilcox, Konstantin Khlebnikov, Minchan Kim, Jaewon Kim,
	cgroups, linux-mm, linux-kernel, Yu Zhao

Hi Andrew,

I see you have taken this:
  mm: use add_page_to_lru_list()/page_lru()/page_off_lru()
Do you mind dropping it?

Michal asked to do a bit of additional work. So I thought I probably
should create a series to do more cleanups I've been meaning to.

This series contains the change in the patch above and goes a few
more steps farther. It's intended to improve readability and should
not have any performance impacts. There are minor behavior changes in
terms of debugging and error reporting, which I have all highlighted
in the individual patches. All patches were properly tested on 5.8
running Chrome OS, with various debug options turned on.

Michal,

Do you mind taking a looking at the entire series?

Thank you.

Yu Zhao (13):
  mm: use add_page_to_lru_list()
  mm: use page_off_lru()
  mm: move __ClearPageLRU() into page_off_lru()
  mm: shuffle lru list addition and deletion functions
  mm: don't pass enum lru_list to lru list addition functions
  mm: don't pass enum lru_list to trace_mm_lru_insertion()
  mm: don't pass enum lru_list to del_page_from_lru_list()
  mm: rename page_off_lru() to __clear_page_lru_flags()
  mm: inline page_lru_base_type()
  mm: VM_BUG_ON lru page flags
  mm: inline __update_lru_size()
  mm: make lruvec_lru_size() static
  mm: enlarge the int parameter of update_lru_size()

 include/linux/memcontrol.h     |  14 ++--
 include/linux/mm_inline.h      | 115 ++++++++++++++-------------------
 include/linux/mmzone.h         |   2 -
 include/linux/vmstat.h         |   2 +-
 include/trace/events/pagemap.h |  11 ++--
 mm/compaction.c                |   2 +-
 mm/memcontrol.c                |  10 +--
 mm/mlock.c                     |   2 +-
 mm/swap.c                      |  53 ++++++---------
 mm/vmscan.c                    |  28 +++-----
 10 files changed, 95 insertions(+), 144 deletions(-)

-- 
2.28.0.681.g6f77f65b4e-goog



^ permalink raw reply	[flat|nested] 30+ messages in thread

end of thread, other threads:[~2020-10-13  2:30 UTC | newest]

Thread overview: 30+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-18  3:00 [PATCH 00/13] mm: clean up some lru related pieces Yu Zhao
2020-09-18  3:00 ` [PATCH 01/13] mm: use add_page_to_lru_list() Yu Zhao
2020-09-18  7:32   ` Michal Hocko
2020-09-18 10:05     ` Yu Zhao
2020-09-18  3:00 ` [PATCH 02/13] mm: use page_off_lru() Yu Zhao
2020-09-18  7:37   ` Michal Hocko
2020-09-18 10:27     ` Yu Zhao
2020-09-18 11:09       ` Michal Hocko
2020-09-18 18:53         ` Yu Zhao
2020-09-21 11:16           ` Michal Hocko
2020-09-18 11:24       ` Michal Hocko
2020-09-18  3:00 ` [PATCH 03/13] mm: move __ClearPageLRU() into page_off_lru() Yu Zhao
2020-09-18  7:38   ` Michal Hocko
2020-09-18  3:00 ` [PATCH 04/13] mm: shuffle lru list addition and deletion functions Yu Zhao
2020-09-18  3:00 ` [PATCH 05/13] mm: don't pass enum lru_list to lru list addition functions Yu Zhao
2020-09-18  3:00 ` [PATCH 06/13] mm: don't pass enum lru_list to trace_mm_lru_insertion() Yu Zhao
2020-09-18  3:00 ` [PATCH 07/13] mm: don't pass enum lru_list to del_page_from_lru_list() Yu Zhao
2020-09-18  3:00 ` [PATCH 08/13] mm: rename page_off_lru() to __clear_page_lru_flags() Yu Zhao
2020-09-18  3:00 ` [PATCH 09/13] mm: inline page_lru_base_type() Yu Zhao
2020-09-18  3:00 ` [PATCH 10/13] mm: VM_BUG_ON lru page flags Yu Zhao
2020-09-18  3:00 ` [PATCH 11/13] mm: inline __update_lru_size() Yu Zhao
2020-09-18  3:00 ` [PATCH 12/13] mm: make lruvec_lru_size() static Yu Zhao
2020-09-18  3:00 ` [PATCH 13/13] mm: enlarge the int parameter of update_lru_size() Yu Zhao
2020-09-18  7:45 ` [PATCH 00/13] mm: clean up some lru related pieces Michal Hocko
2020-09-18  9:36   ` Yu Zhao
2020-09-18 20:46 ` Hugh Dickins
2020-09-18 21:01   ` Yu Zhao
2020-09-18 21:19     ` Hugh Dickins
2020-09-19  0:31       ` Alex Shi
2020-10-13  2:30       ` Hugh Dickins

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).