linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Michal Hocko <mhocko@suse.com>
To: Hui Su <sh_def@163.com>
Cc: akpm@linux-foundation.org, linux-mm@kvack.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] mm/oom_kill.c: remove the unmatched comments
Date: Tue, 27 Oct 2020 15:58:14 +0100	[thread overview]
Message-ID: <20201027145814.GY20500@dhcp22.suse.cz> (raw)
In-Reply-To: <20201027144529.GA3558@rlk>

On Tue 27-10-20 22:45:29, Hui Su wrote:
> is_dump_unreclaim_slabs() just check whether nr_unreclaimable
> slabs amount is greater than user memory, not match witch comment.

As I've tried to explain, the comment is not explaining what the
function does but how it should be used. It is not a kerneldoc afterall.
So it is a good match. I can see how that might confuse somebody so I am
not against changing this but the changelog shouldn't really be
confusing on its own. What do you think about the following instead.

"
Comment for is_dump_unreclaim_slabs is not really clear whether it is
meant to instruct how to use the function or whether it is an outdated
information of the past implementation of the function. it doesn't realy
help that is_dump_unreclaim_slabs is hard to grasp on its own.
Rename the helper to should_dump_unreclaim_slabs which should make it
clear what it is meant to do and drop the comment as the purpose should
be pretty evident now.
"

> So delete the comment, and rename it to should_dump_unreclaim_slabs().
> 
> Signed-off-by: Hui Su <sh_def@163.com>
> ---
>  mm/oom_kill.c | 8 ++------
>  1 file changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/mm/oom_kill.c b/mm/oom_kill.c
> index 8b84661a6410..d181e24d7193 100644
> --- a/mm/oom_kill.c
> +++ b/mm/oom_kill.c
> @@ -170,11 +170,7 @@ static bool oom_unkillable_task(struct task_struct *p)
>  	return false;
>  }
>  
> -/*
> - * Print out unreclaimble slabs info when unreclaimable slabs amount is greater
> - * than all user memory (LRU pages)
> - */
> -static bool is_dump_unreclaim_slabs(void)
> +static bool should_dump_unreclaim_slabs(void)
>  {
>  	unsigned long nr_lru;
>  
> @@ -463,7 +459,7 @@ static void dump_header(struct oom_control *oc, struct task_struct *p)
>  		mem_cgroup_print_oom_meminfo(oc->memcg);
>  	else {
>  		show_mem(SHOW_MEM_FILTER_NODES, oc->nodemask);
> -		if (is_dump_unreclaim_slabs())
> +		if (should_dump_unreclaim_slabs())
>  			dump_unreclaimable_slab();
>  	}
>  	if (sysctl_oom_dump_tasks)
> -- 
> 2.25.1
> 

-- 
Michal Hocko
SUSE Labs


       reply	other threads:[~2020-10-27 14:58 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20201027144529.GA3558@rlk>
2020-10-27 14:58 ` Michal Hocko [this message]
2020-10-27 15:11   ` [PATCH v2] mm/oom_kill.c: remove the unmatched comments Hui Su
2020-10-27 19:23     ` Michal Hocko
2020-10-28 15:31       ` [PATCH v3] mm/oom_kill: remove comment and rename is_dump_unreclaim_slabs() Hui Su
2020-10-28 21:53         ` Andrew Morton
2020-10-29  7:51           ` Michal Hocko
2020-10-30 18:27         ` [PATCH v4] mm/oom_kill: change " Hui Su
2020-11-02  7:28           ` Michal Hocko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201027145814.GY20500@dhcp22.suse.cz \
    --to=mhocko@suse.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=sh_def@163.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).