linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-10 12:19:45 to 2020-07-13 08:43:18 UTC [more...]

[PATCH v18 00/14] Introduce Data Access MONitor (DAMON)
 2020-07-13  8:41 UTC  (2+ messages)
` [PATCH v18 01/14] mm/page_ext: Export lookup_page_ext() to GPL modules

[RFC]: mm,power: introduce MADV_WIPEONSUSPEND
 2020-07-13  8:02 UTC  (10+ messages)

[PATCH v5 0/9] clean-up the migration target allocation functions
 2020-07-13  7:53 UTC  (13+ messages)
` [PATCH v5 1/9] mm/page_isolation: prefer the node of the source page
` [PATCH v5 2/9] mm/migrate: move migration helper from .h to .c
` [PATCH v5 3/9] mm/hugetlb: unify migration callbacks
` [PATCH v5 4/9] mm/migrate: clear __GFP_RECLAIM to make the migration callback consistent with regular THP allocations
` [PATCH v5 5/9] mm/migrate: make a standard migration target allocation function
` [PATCH v5 6/9] mm/mempolicy: use a standard migration target allocation callback
` [PATCH v5 7/9] mm/page_alloc: remove a wrapper for alloc_migration_target()
` [PATCH v5 8/9] mm/memory-failure: "
` [PATCH v5 9/9] mm/memory_hotplug: "

[PATCH v2 00/22] device-dax: Support sub-dividing soft-reserved ranges
 2020-07-13  7:03 UTC  (27+ messages)
` [PATCH v2 01/22] x86/numa: Cleanup configuration dependent command-line options
` [PATCH v2 02/22] x86/numa: Add 'nohmat' option
` [PATCH v2 03/22] efi/fake_mem: Arrange for a resource entry per efi_fake_mem instance
` [PATCH v2 04/22] ACPI: HMAT: Refactor hmat_register_target_device to hmem_register_device
` [PATCH v2 05/22] resource: Report parent to walk_iomem_res_desc() callback
` [PATCH v2 06/22] x86: Move NUMA_KEEP_MEMINFO and related definition to x86-internals
` [PATCH v2 07/22] numa: Introduce a generic memory_add_physaddr_to_nid()
` [PATCH v2 08/22] memblock: Introduce a generic phys_addr_to_target_node()
` [PATCH v2 09/22] arm64: Convert to generic memblock for numa-info
` [PATCH v2 10/22] ACPI: HMAT: Attach a device for each soft-reserved range
` [PATCH v2 11/22] device-dax: Drop the dax_region.pfn_flags attribute
` [PATCH v2 12/22] device-dax: Move instance creation parameters to 'struct dev_dax_data'
` [PATCH v2 13/22] device-dax: Make pgmap optional for instance creation
` [PATCH v2 14/22] device-dax: Kill dax_kmem_res
` [PATCH v2 15/22] device-dax: Add an allocation interface for device-dax instances
` [PATCH v2 16/22] device-dax: Introduce 'seed' devices
` [PATCH v2 17/22] drivers/base: Make device_find_child_by_name() compatible with sysfs inputs
` [PATCH v2 18/22] device-dax: Add resize support
` [PATCH v2 19/22] mm/memremap_pages: Convert to 'struct range'
` [PATCH v2 20/22] mm/memremap_pages: Support multiple ranges per invocation
` [PATCH v2 21/22] device-dax: Add dis-contiguous resource support
` [PATCH v2 22/22] device-dax: Introduce 'mapping' devices

[PATCH] mm, oom: don't invoke oom killer if current has been reapered
 2020-07-13  6:21 UTC  (4+ messages)

[RFC PATCH 0/7] mmu context cleanup, lazy tlb cleanup,
 2020-07-13  4:58 UTC  (8+ messages)
` [RFC PATCH 4/7] x86: use exit_lazy_tlb rather than membarrier_mm_sync_core_before_usermode
` [RFC PATCH 7/7] lazy tlb: shoot lazies, a non-refcounting lazy tlb option

mmotm 2020-07-09-21-00 uploaded
 2020-07-13  4:17 UTC  (4+ messages)
` mmotm 2020-07-09-21-00 uploaded (drivers/net/ethernet/mellanox/mlx5/core/en_main.c)

WARNING: at mm/mremap.c:211 move_page_tables in i386
 2020-07-13  3:51 UTC  (16+ messages)

[PATCH V5 0/4] mm/debug_vm_pgtable: Add some more tests
 2020-07-13  3:23 UTC  (5+ messages)
` [PATCH V5 1/4] mm/debug_vm_pgtable: Add tests validating arch helpers for core MM features
` [PATCH V5 2/4] mm/debug_vm_pgtable: Add tests validating advanced arch page table helpers
` [PATCH V5 3/4] mm/debug_vm_pgtable: Add debug prints for individual tests
` [PATCH V5 4/4] Documentation/mm: Add descriptions for arch page table helpers

[PATCH v3] mm, oom: make the calculation of oom badness more accurate
 2020-07-13  2:39 UTC  (4+ messages)

[PATCH] mm : fix pte _PAGE_DIRTY bit when fallback migrate page
 2020-07-13  1:57 UTC  (3+ messages)

Memcg stat for available memory
 2020-07-12 22:02 UTC  (7+ messages)

[PATCH v5] mm/zswap: move to use crypto_acomp API for hardware acceleration
 2020-07-12 13:29 UTC 

[PATCH v2 0/2] arm64: tlb: add support for TLBI RANGE instructions
 2020-07-12 12:03 UTC  (6+ messages)
` [PATCH v2 2/2] arm64: tlb: Use the TLBI RANGE feature in arm64

[PATCH] mm/sparse: cleanup the code surrounding memory_present()
 2020-07-12  8:31 UTC 

[PATCH 17/26] mm/riscv: Use general page fault accounting
 2020-07-11 19:43 UTC  (2+ messages)

[PATCH v3 1/1] mm/vmalloc.c: Remove BUG() from the find_va_links()
 2020-07-11 10:45 UTC 

[PATCH] mm: vmscan: consistent update to pgrefill
 2020-07-11 10:07 UTC  (5+ messages)

[PATCH 0/4] Remove/consolidate calls to find_get_entry
 2020-07-11  3:31 UTC  (7+ messages)
` [PATCH 1/4] mm: Factor find_get_swap_page out of mincore_page
` [PATCH 2/4] mm: Use find_get_swap_page in memcontrol
` [PATCH 3/4] mm: Optimise madvise WILLNEED
` [PATCH 4/4] proc: Optimise smaps for shmem entries
` [PATCH 5/4] mm: Return head pages from find_get_entry

[PATCH v2 0/6] Improvements for dump_page()
 2020-07-11  2:04 UTC  (12+ messages)
` [PATCH v2 1/6] mm: Handle page->mapping better in dump_page
` [PATCH v2 2/6] mm: Dump compound page information on a second line
` [PATCH v2 3/6] mm: Print head flags in dump_page
` [PATCH v2 5/6] mm: Print the inode number "
` [PATCH v2 6/6] mm: Print hashed address of struct page

[PATCH v16 00/22] per memcg lru_lock
 2020-07-11  1:02 UTC  (24+ messages)
` [PATCH v16 01/22] mm/vmscan: remove unnecessary lruvec adding
` [PATCH v16 02/22] mm/page_idle: no unlikely double check for idle page counting
` [PATCH v16 03/22] mm/compaction: correct the comments of compact_defer_shift
` [PATCH v16 04/22] mm/compaction: rename compact_deferred as compact_should_defer
` [PATCH v16 05/22] mm/thp: move lru_add_page_tail func to huge_memory.c
` [PATCH v16 06/22] mm/thp: clean up lru_add_page_tail
` [PATCH v16 07/22] mm/thp: remove code path which never got into
` [PATCH v16 08/22] mm/thp: narrow lru locking
` [PATCH v16 09/22] mm/memcg: add debug checking in lock_page_memcg
` [PATCH v16 10/22] mm/swap: fold vm event PGROTATED into pagevec_move_tail_fn
` [PATCH v16 11/22] mm/lru: move lru_lock holding in func lru_note_cost_page
` [PATCH v16 12/22] mm/lru: move lock into lru_note_cost
` [PATCH v16 13/22] mm/lru: introduce TestClearPageLRU
` [PATCH v16 14/22] mm/thp: add tail pages into lru anyway in split_huge_page()
` [PATCH v16 15/22] mm/compaction: do page isolation first in compaction
` [PATCH v16 16/22] mm/mlock: reorder isolation sequence during munlock
` [PATCH v16 17/22] mm/swap: serialize memcg changes during pagevec_lru_move_fn
` [PATCH v16 18/22] mm/lru: replace pgdat lru_lock with lruvec lock
` [PATCH v16 19/22] mm/lru: introduce the relock_page_lruvec function
` [PATCH v16 20/22] mm/vmscan: use relock for move_pages_to_lru
` [PATCH v16 21/22] mm/pgdat: remove pgdat lru_lock
` [PATCH v16 22/22] mm/lru: revise the comments of lru_lock

[PATCH 00/12] device-dax: Support sub-dividing soft-reserved ranges
 2020-07-11  0:52 UTC  (9+ messages)
` [PATCH 11/12] device-dax: Add dis-contiguous resource support

[PATCH 0/5] mm/migrate: avoid device private invalidations
 2020-07-10 20:17 UTC  (4+ messages)
` [PATCH 3/5] mm/notifier: add migration invalidation type

[PATCH 1/1] mm/vmalloc.c: Add an error message if two areas overlap
 2020-07-10 20:04 UTC  (7+ messages)

[PATCH v3 0/5] mm/hmm/nouveau: add PMD system memory mapping
 2020-07-10 20:13 UTC  (3+ messages)

[PATCH v2 0/2] mm/migrate: optimize migrate_vma_setup() for holes
 2020-07-10 19:48 UTC  (3+ messages)
` [PATCH v2 1/2] "
` [PATCH v2 2/2] mm/migrate: add migrate-shared test for migrate_vma_*()

[PATCH v2 1/1] mm/vmalloc.c: Add an error message if two areas overlap
 2020-07-10 19:44 UTC 

[PATCH] mm: memcontrol: avoid workload stalls when lowering memory.high
 2020-07-10 19:41 UTC  (6+ messages)

ERROR: modpost: "min_low_pfn" undefined!
 2020-07-10 19:21 UTC 

[PATCH v2 00/11] Fix PM hibernation in Xen guests
 2020-07-10 18:17 UTC  (2+ messages)

[linux-next:pending-fixes] BUILD SUCCESS 228d84f5d4f9ba5452fbb21e2c6fbad98bc2d94c
 2020-07-10 17:49 UTC 

[PATCH] mm: Close race between munmap() and expand_upwards()/downwards()
 2020-07-10 17:35 UTC  (2+ messages)

[RFC] Kill THP deferred split queue?
 2020-07-10 17:32 UTC  (3+ messages)

a question of split_huge_page
 2020-07-10 17:29 UTC  (10+ messages)

[RFC PATCH v2 0/5] mm: extend memfd with ability to create "secret" memory areas
 2020-07-10 17:12 UTC  (7+ messages)
` [RFC PATCH v2 1/5] mm: make HPAGE_PxD_{SHIFT,MASK,SIZE} always available

[GIT PULL] Fix gfs2 readahead deadlocks
 2020-07-10 16:55 UTC  (2+ messages)

[PATCH v8 4/4] kasan: update documentation for generic kasan
 2020-07-10 16:27 UTC 

[PATCH v8 3/4] kasan: add tests for call_rcu stack recording
 2020-07-10 16:25 UTC 

[PATCH v8 2/4] kasan: record and print the free track
 2020-07-10 16:24 UTC 

[PATCH v8 1/4] rcu: kasan: record and print call_rcu() call stack
 2020-07-10 16:24 UTC 

[PATCH v8 0/4] kasan: memorize and print call_rcu stack
 2020-07-10 16:21 UTC 

[PATCH 0/2] mm/migrate: optimize migrate_vma_setup() for holes
 2020-07-10 16:19 UTC  (4+ messages)
` [PATCH 1/2] "

[hnaz-linux-mm:master 145/290] mm/kasan/report.c:185:20: error: 'struct kasan_alloc_meta' has no member named 'free_track'
 2020-07-10 15:32 UTC  (4+ messages)

[PATCH v1] arm64: tlb: don't set the ttl value in flush_tlb_page_nosync
 2020-07-10 15:29 UTC  (2+ messages)

[PATCH v2] mm, oom: make the calculation of oom badness more accurate
 2020-07-10 14:10 UTC  (7+ messages)

[PATCH v14 00/20] per memcg lru lock
 2020-07-10 14:09 UTC  (9+ messages)
` [PATCH v14 07/20] mm/thp: narrow lru locking

[PATCH v3] vmalloc: Add the right hint when vmalloc failed
 2020-07-10 14:04 UTC  (5+ messages)

[PATCH v1 0/9] s390: implement and optimize vmemmap_free()
 2020-07-10 14:02 UTC  (7+ messages)

[PATCH v6 0/4] make vm_committed_as_batch aware of vm overcommit policy
 2020-07-10 14:01 UTC  (5+ messages)
` [PATCH v6 1/4] proc/meminfo: avoid open coded reading of vm_committed_as
` [PATCH v6 2/4] mm/util.c: make vm_memory_committed() more accurate
` [PATCH v6 3/4] percpu_counter: add percpu_counter_sync()
` [PATCH v6 4/4] mm: adjust vm_committed_as_batch according to vm overcommit policy

[PATCH v3 1/3] mm/shuffle: don't move pages between zones and don't read garbage memmaps
 2020-07-10 14:03 UTC  (2+ messages)

[PATCH v4 0/2] Fix and enable pmem as RAM device on arm64
 2020-07-10 14:00 UTC  (4+ messages)

[hnaz-linux-mm:master 268/300] arm-linux-gnueabi-ld: section .data VMA overlaps section .rodata VMA
 2020-07-10 12:43 UTC 

[PATCH] kasan: Remove kasan_unpoison_stack_above_sp_to()
 2020-07-10 12:42 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).