linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Linus Torvalds <torvalds@linux-foundation.org>
To: Joe Perches <joe@perches.com>
Cc: David Howells <dhowells@redhat.com>,
	Waiman Long <longman@redhat.com>,
	 Andrew Morton <akpm@linux-foundation.org>,
	 Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>,
	James Morris <jmorris@namei.org>,
	 "Serge E. Hallyn" <serge@hallyn.com>,
	Linux-MM <linux-mm@kvack.org>,
	keyrings@vger.kernel.org,
	 Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] mm: Add kvfree_sensitive() for freeing sensitive data objects
Date: Mon, 6 Apr 2020 09:41:31 -0700	[thread overview]
Message-ID: <CAHk-=whgvhyi_=2AsfFLUznqmrO9TOjuzTvcYHvCC=f0+Y7PkQ@mail.gmail.com> (raw)
In-Reply-To: <d509771b7e08fff0d18654b746e413e93ed62fe8.camel@perches.com>

On Mon, Apr 6, 2020 at 9:12 AM Joe Perches <joe@perches.com> wrote:
>
> While I agree with Linus about the __ prefix,
> the z is pretty common and symmetric to all
> the <foo>zalloc uses.

Yes, we have a pattern of 'z' for zero.

But the _operation_ isn't symmetric.

"kzalloc()" has absolutely _nothing_ to do with "kzfree()". They are
not some kind of "opposite symmetric operation".  They are totally
different. They have absolutely nothing in common.

So using the same naming is wrong. They have one implementation detail
that looks superficially similar ("zero the area"), but even that
superficial similarity is actually completely false. They may both use
"memset()", but in one case it is correct and makes sense, and in the
other case it's actually a bug waiting to happen, and you really
should use that "memzero_explicit()", which is a very very different
operation from a normal memzero().

So even the implementation isn't really validly similar, but even if
it had been, the _reason_ for doing so is completely different.

They simply don't really pair up in any way.

             Linus


  reply	other threads:[~2020-04-06 16:41 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-06  2:37 [PATCH] mm: Add kvfree_sensitive() for freeing sensitive data objects Waiman Long
2020-04-06  4:20 ` David Rientjes
2020-04-06 14:36   ` Waiman Long
2020-04-06 14:39     ` Matthew Wilcox
2020-04-06  7:44 ` David Howells
2020-04-06 23:20   ` David Rientjes
2020-04-06 14:32 ` David Howells
2020-04-06 14:40   ` Waiman Long
2020-04-06 15:45 ` Joe Perches
2020-04-06 16:00 ` David Howells
2020-04-06 16:10   ` Joe Perches
2020-04-06 16:41     ` Linus Torvalds [this message]
2020-04-06 16:42       ` Joe Perches
2020-04-06 17:11         ` Linus Torvalds
2020-04-06 17:20           ` Joe Perches
2020-04-06 17:26             ` Matthew Wilcox
2020-04-06 17:33             ` Linus Torvalds
2020-04-06 17:46               ` Joe Perches
2020-04-06 17:58     ` Waiman Long
2020-04-06 18:06       ` Linus Torvalds
2020-04-06 18:46         ` Joe Perches
2020-04-06 16:26   ` David Howells
2020-04-06 16:38     ` Joe Perches
2020-04-06 17:10     ` Joe Perches
2020-04-06 17:24       ` Matthew Wilcox
2020-04-06 17:26       ` Linus Torvalds
2020-04-06 17:51       ` David Howells
2020-04-06 17:58         ` Linus Torvalds

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAHk-=whgvhyi_=2AsfFLUznqmrO9TOjuzTvcYHvCC=f0+Y7PkQ@mail.gmail.com' \
    --to=torvalds@linux-foundation.org \
    --cc=akpm@linux-foundation.org \
    --cc=dhowells@redhat.com \
    --cc=jarkko.sakkinen@linux.intel.com \
    --cc=jmorris@namei.org \
    --cc=joe@perches.com \
    --cc=keyrings@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=longman@redhat.com \
    --cc=serge@hallyn.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).