linux-mm.kvack.org archive mirror
 help / color / mirror / Atom feed
From: Michel Lespinasse <walken@google.com>
To: Laurent Dufour <ldufour@linux.ibm.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	linux-mm <linux-mm@kvack.org>,
	 LKML <linux-kernel@vger.kernel.org>,
	Peter Zijlstra <peterz@infradead.org>,
	 Vlastimil Babka <vbabka@suse.cz>,
	Matthew Wilcox <willy@infradead.org>,
	 Liam Howlett <Liam.Howlett@oracle.com>,
	Jerome Glisse <jglisse@redhat.com>,
	 Davidlohr Bueso <dave@stgolabs.net>,
	David Rientjes <rientjes@google.com>,
	Hugh Dickins <hughd@google.com>,  Ying Han <yinghan@google.com>
Subject: Re: [PATCH 7/8] mmap locking API: add MMAP_LOCK_INITIALIZER
Date: Mon, 6 Apr 2020 06:04:16 -0700	[thread overview]
Message-ID: <CANN689GOqEnLQHD-VNjwhTCwvLWNsRPLmo+yBumzE_y2_YsoMQ@mail.gmail.com> (raw)
In-Reply-To: <1c463464-1d72-287e-e785-f077a95ccf20@linux.ibm.com>

On Mon, Apr 6, 2020 at 2:46 AM Laurent Dufour <ldufour@linux.ibm.com> wrote:
>
> Le 26/03/2020 à 08:02, Michel Lespinasse a écrit :
> > Define a new initializer for the mmap locking api.
> > Initially this just evaluates to __RWSEM_INITIALIZER as the API
> > is defined as wrappers around rwsem.
>
> I can't see the benefit of this change.
> The overall idea is to hide the mmap_sem name. Here the macro
> MMAP_LOCK_INITIALIZER() doesn't hide the name.

The idea for the initializer is that it makes it easier to change the
underlying implementation - if we do, we can change the initializer
without having to change every place where it is used. I actually do
that in my other patch series converting the mmap_sem to a range lock.

But you are correct that it does not help with renaming the mmap_sem
field - my next commit in this series still has to do that in every
place this initializer is used.


  reply	other threads:[~2020-04-06 13:04 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-26  7:02 [PATCH 0/8] Add a new mmap locking API wrapping mmap_sem calls Michel Lespinasse
2020-03-26  7:02 ` [PATCH 1/8] mmap locking API: initial implementation as rwsem wrappers Michel Lespinasse
2020-03-26 17:56   ` Jason Gunthorpe
2020-03-26 18:06     ` Matthew Wilcox
2020-03-26 18:09       ` Matthew Wilcox
2020-03-26 22:09         ` Michel Lespinasse
2020-03-26  7:02 ` [PATCH 2/8] MMU notifier: use the new mmap locking API Michel Lespinasse
2020-03-26  7:02 ` [PATCH 3/8] mmap locking API: use coccinelle to convert mmap_sem rwsem call sites Michel Lespinasse
2020-03-27  0:01   ` kbuild test robot
2020-03-27  0:40   ` kbuild test robot
2020-03-26  7:02 ` [PATCH 4/8] mmap locking API: convert mmap_sem call sites missed by coccinelle Michel Lespinasse
2020-03-26 23:13   ` kbuild test robot
2020-03-26 23:27   ` kbuild test robot
2020-03-26  7:02 ` [PATCH 5/8] mmap locking API: convert nested write lock sites Michel Lespinasse
2020-03-26 12:09   ` Matthew Wilcox
2020-03-26 12:56     ` Michel Lespinasse
2020-03-26  7:02 ` [PATCH 6/8] mmap locking API: add mmap_read_release() and mmap_read_unlock_non_owner() Michel Lespinasse
2020-03-26  7:02 ` [PATCH 7/8] mmap locking API: add MMAP_LOCK_INITIALIZER Michel Lespinasse
2020-04-06  9:46   ` Laurent Dufour
2020-04-06 13:04     ` Michel Lespinasse [this message]
2020-03-26  7:02 ` [PATCH 8/8] mmap locking API: rename mmap_sem to mmap_lock Michel Lespinasse
2020-04-06 12:45   ` Laurent Dufour
2020-04-06 13:17     ` Michel Lespinasse
2020-04-06 16:03     ` Davidlohr Bueso
2020-03-26  7:13 ` [PATCH 0/8] Add a new mmap locking API wrapping mmap_sem calls Michel Lespinasse

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CANN689GOqEnLQHD-VNjwhTCwvLWNsRPLmo+yBumzE_y2_YsoMQ@mail.gmail.com \
    --to=walken@google.com \
    --cc=Liam.Howlett@oracle.com \
    --cc=akpm@linux-foundation.org \
    --cc=dave@stgolabs.net \
    --cc=hughd@google.com \
    --cc=jglisse@redhat.com \
    --cc=ldufour@linux.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=peterz@infradead.org \
    --cc=rientjes@google.com \
    --cc=vbabka@suse.cz \
    --cc=willy@infradead.org \
    --cc=yinghan@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).