linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Boris Brezillon <boris.brezillon@collabora.com>
To: Miquel Raynal <miquel.raynal@bootlin.com>
Cc: Boris Brezillon <bbrezillon@kernel.org>,
	Richard Weinberger <richard@nod.at>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"stable@vger.kernel.org" <stable@vger.kernel.org>,
	liaoweixiong <liaoweixiong@allwinnertech.com>,
	"linux-mtd@lists.infradead.org" <linux-mtd@lists.infradead.org>,
	Schrempf Frieder <frieder.schrempf@kontron.de>,
	Jeff Kletsky <git-commits@allycomm.com>,
	Peter Pan <peterpandong@micron.com>
Subject: Re: [PATCH 3/3] mtd: spinand: Wait for the erase op to finish before writing a bad block marker
Date: Mon, 17 Feb 2020 12:14:02 +0100	[thread overview]
Message-ID: <20200217121402.44e00350@collabora.com> (raw)
In-Reply-To: <20200217113919.0508acc4@xps13>

On Mon, 17 Feb 2020 11:39:19 +0100
Miquel Raynal <miquel.raynal@bootlin.com> wrote:

> Hi Frieder,
> 
> Schrempf Frieder <frieder.schrempf@kontron.de> wrote on Tue, 11 Feb
> 2020 16:35:53 +0000:
> 
> > From: Frieder Schrempf <frieder.schrempf@kontron.de>
> > 
> > Currently when marking a block, we use spinand_erase_op() to erase
> > the block before writing the marker to the OOB area without waiting
> > for the operation to succeed. This can lead to the marking failing
> > silently and no bad block marker being written to the flash.
> > 
> > To fix this we reuse the spinand_erase() function, that already does
> > everything we need to do before actually writing the marker.
> >   
> 
> Thanks a lot for this series!
> 
> Yet I don't really understand the point of waiting for the erasure if
> it failed: we don't really care as programming (1 -> 0) cells is always
> possible. Are you sure this lead to an error?

Actually, I think I already pointed out that we should probably write
the BBM without erasing the block. IIRC, this logic has been copied
from rawnand where some controllers don't disable the ECC engine when
doing raw accesses, leading to ECC errors if the block is not erased
before BBMs are programmed. Assuming we don't let such drivers being
merged in spinand, this erase operation can be dropped.

> 
> Also, why just not calling spinand_erase() instead of
> spinand_erase_op() from spinand_markbad()?
> 
> > Fixes: 7529df465248 ("mtd: nand: Add core infrastructure to support SPI NANDs")
> > Cc: stable@vger.kernel.org
> > Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de>
> > ---
> >  drivers/mtd/nand/spi/core.c | 56 ++++++++++++++++++-------------------
> >  1 file changed, 28 insertions(+), 28 deletions(-)
> > 
> > diff --git a/drivers/mtd/nand/spi/core.c b/drivers/mtd/nand/spi/core.c
> > index 925db6269861..8a69d13639e2 100644
> > --- a/drivers/mtd/nand/spi/core.c
> > +++ b/drivers/mtd/nand/spi/core.c
> > @@ -600,6 +600,32 @@ static int spinand_mtd_block_isbad(struct mtd_info *mtd, loff_t offs)
> >  	return ret;
> >  }
> >  
> > +static int __spinand_erase(struct nand_device *nand, const struct nand_pos *pos,
> > +			   bool hard_fail)

I hate those __ prefix. Please find a more descriptive name
(spinand_erase_block() or spinand_erase_and_wait()?)

> > +{
> > +	struct spinand_device *spinand = nand_to_spinand(nand);
> > +	u8 status;
> > +	int ret;
> > +
> > +	ret = spinand_select_target(spinand, pos->target);
> > +	if (ret)
> > +		return ret;
> > +
> > +	ret = spinand_write_enable_op(spinand);
> > +	if (ret)
> > +		return ret;
> > +
> > +	ret = spinand_erase_op(spinand, pos);
> > +	if (ret && hard_fail)
> > +		return ret;
> > +
> > +	ret = spinand_wait(spinand, &status);
> > +	if (!ret && (status & STATUS_ERASE_FAILED))
> > +		ret = -EIO;
> > +
> > +	return ret;
> > +}
> > +
> >  static int spinand_markbad(struct nand_device *nand, const struct nand_pos *pos)
> >  {
> >  	struct spinand_device *spinand = nand_to_spinand(nand);
> > @@ -614,16 +640,10 @@ static int spinand_markbad(struct nand_device *nand, const struct nand_pos *pos)
> >  	int ret;
> >  
> >  	/* Erase block before marking it bad. */
> > -	ret = spinand_select_target(spinand, pos->target);
> > -	if (ret)
> > -		return ret;
> > -
> > -	ret = spinand_write_enable_op(spinand);
> > +	ret = __spinand_erase(nand, pos, false);
> >  	if (ret)
> >  		return ret;
> >  
> > -	spinand_erase_op(spinand, pos);
> > -
> >  	return spinand_write_page(spinand, &req);
> >  }
> >  
> > @@ -644,27 +664,7 @@ static int spinand_mtd_block_markbad(struct mtd_info *mtd, loff_t offs)
> >  
> >  static int spinand_erase(struct nand_device *nand, const struct nand_pos *pos)
> >  {
> > -	struct spinand_device *spinand = nand_to_spinand(nand);
> > -	u8 status;
> > -	int ret;
> > -
> > -	ret = spinand_select_target(spinand, pos->target);
> > -	if (ret)
> > -		return ret;
> > -
> > -	ret = spinand_write_enable_op(spinand);
> > -	if (ret)
> > -		return ret;
> > -
> > -	ret = spinand_erase_op(spinand, pos);
> > -	if (ret)
> > -		return ret;
> > -
> > -	ret = spinand_wait(spinand, &status);
> > -	if (!ret && (status & STATUS_ERASE_FAILED))
> > -		ret = -EIO;
> > -
> > -	return ret;
> > +	return __spinand_erase(nand, pos, true);
> >  }
> >  
> >  static int spinand_mtd_erase(struct mtd_info *mtd,  
> 
> Thanks,
> Miquèl


______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

  reply	other threads:[~2020-02-17 11:14 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-11 16:35 [PATCH 0/3] mtd: spinand: Fix reading and writing of bad block markers Schrempf Frieder
2020-02-11 16:35 ` [PATCH 1/3] mtd: spinand: Stop using spinand->oobbuf for buffering " Schrempf Frieder
2020-02-11 18:35   ` Schrempf Frieder
2020-02-17 11:17   ` Boris Brezillon
2020-02-11 16:35 ` [PATCH 2/3] mtd: spinand: Explicitly use MTD_OPS_RAW to write the bad block marker to OOB Schrempf Frieder
2020-02-17 11:18   ` Boris Brezillon
2020-02-11 16:35 ` [PATCH 3/3] mtd: spinand: Wait for the erase op to finish before writing a bad block marker Schrempf Frieder
2020-02-17 10:39   ` Miquel Raynal
2020-02-17 11:14     ` Boris Brezillon [this message]
2020-02-17 11:29       ` Schrempf Frieder
2020-02-17 11:19     ` Schrempf Frieder
2020-02-17 11:30       ` David Laight

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200217121402.44e00350@collabora.com \
    --to=boris.brezillon@collabora.com \
    --cc=bbrezillon@kernel.org \
    --cc=frieder.schrempf@kontron.de \
    --cc=git-commits@allycomm.com \
    --cc=liaoweixiong@allwinnertech.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=miquel.raynal@bootlin.com \
    --cc=peterpandong@micron.com \
    --cc=richard@nod.at \
    --cc=stable@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).