linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Miquel Raynal <miquel.raynal@bootlin.com>
To: Boris Brezillon <boris.brezillon@collabora.com>
Cc: Rickard Andersson <rickaran@axis.com>,
	Richard Weinberger <richard@nod.at>,
	linux-mtd@lists.infradead.org,
	Vignesh Raghavendra <vigneshr@ti.com>,
	Tudor Ambarus <Tudor.Ambarus@microchip.com>
Subject: Re: [PATCH v5 14/28] mtd: rawnand: timings: Add a helper to find the closest ONFI mode
Date: Wed, 27 May 2020 09:42:13 +0200	[thread overview]
Message-ID: <20200527094213.49f59069@xps13> (raw)
In-Reply-To: <20200526234205.73021fc2@collabora.com>

Hi Boris,

Boris Brezillon <boris.brezillon@collabora.com> wrote on Tue, 26 May
2020 23:42:05 +0200:

> On Tue, 26 May 2020 21:17:11 +0200
> Miquel Raynal <miquel.raynal@bootlin.com> wrote:
> 
> > Vendors are allowed to provide their own set of timings. In this case,
> > we provide a way to derive the "closest" timing mode so that, if the
> > NAND controller does not support tweaking these parameters, it will be
> > able to configure itself anyway.
> > 
> > Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
> > ---
> >  drivers/mtd/nand/raw/internals.h    |  2 ++
> >  drivers/mtd/nand/raw/nand_timings.c | 49 +++++++++++++++++++++++++++++
> >  2 files changed, 51 insertions(+)
> > 
> > diff --git a/drivers/mtd/nand/raw/internals.h b/drivers/mtd/nand/raw/internals.h
> > index dc84e3b55d48..c7357ae86eeb 100644
> > --- a/drivers/mtd/nand/raw/internals.h
> > +++ b/drivers/mtd/nand/raw/internals.h
> > @@ -88,6 +88,8 @@ int onfi_fill_data_interface(struct nand_chip *chip,
> >  			     struct nand_data_interface *iface,
> >  			     enum nand_data_interface_type type,
> >  			     int timing_mode);
> > +unsigned int
> > +onfi_find_closest_sdr_mode(const struct nand_sdr_timings *spec_timings);
> >  int nand_get_features(struct nand_chip *chip, int addr, u8 *subfeature_param);
> >  int nand_set_features(struct nand_chip *chip, int addr, u8 *subfeature_param);
> >  int nand_read_page_raw_notsupp(struct nand_chip *chip, u8 *buf,
> > diff --git a/drivers/mtd/nand/raw/nand_timings.c b/drivers/mtd/nand/raw/nand_timings.c
> > index ce6bb87db2e8..3c44c4b90536 100644
> > --- a/drivers/mtd/nand/raw/nand_timings.c
> > +++ b/drivers/mtd/nand/raw/nand_timings.c
> > @@ -273,6 +273,55 @@ static const struct nand_data_interface onfi_sdr_timings[] = {
> >  	},
> >  };
> >  
> > +/**
> > + * onfi_find_closest_sdr_mode - Derive the closest ONFI SDR timing mode given a
> > + *                              set of timings
> > + * @spec_timings: the timings to challenge
> > + */
> > +unsigned int
> > +onfi_find_closest_sdr_mode(const struct nand_sdr_timings *spec_timings)
> > +{
> > +	const struct nand_sdr_timings *onfi_timings;
> > +	int mode;
> > +
> > +	for (mode = ARRAY_SIZE(onfi_sdr_timings) - 1; mode > 0; mode--) {
> > +		onfi_timings = &onfi_sdr_timings[mode].timings.sdr;
> > +
> > +		if (spec_timings->tCCS_min > onfi_timings->tCCS_min ||
> > +		    spec_timings->tADL_min > onfi_timings->tADL_min ||
> > +		    spec_timings->tALH_min > onfi_timings->tALH_min ||
> > +		    spec_timings->tALS_min > onfi_timings->tALS_min ||
> > +		    spec_timings->tAR_min > onfi_timings->tAR_min ||
> > +		    spec_timings->tCEH_min > onfi_timings->tCEH_min ||
> > +		    spec_timings->tCH_min > onfi_timings->tCH_min ||
> > +		    spec_timings->tCLH_min > onfi_timings->tCLH_min ||
> > +		    spec_timings->tCLR_min > onfi_timings->tCLR_min ||
> > +		    spec_timings->tCLS_min > onfi_timings->tCLS_min ||
> > +		    spec_timings->tCOH_min > onfi_timings->tCOH_min ||
> > +		    spec_timings->tCS_min > onfi_timings->tCS_min ||
> > +		    spec_timings->tDH_min > onfi_timings->tDH_min ||
> > +		    spec_timings->tDS_min > onfi_timings->tDS_min ||
> > +		    spec_timings->tIR_min > onfi_timings->tIR_min ||
> > +		    spec_timings->tRC_min > onfi_timings->tRC_min ||
> > +		    spec_timings->tREH_min > onfi_timings->tREH_min ||
> > +		    spec_timings->tRHOH_min > onfi_timings->tRHOH_min ||
> > +		    spec_timings->tRHW_min > onfi_timings->tRHW_min ||
> > +		    spec_timings->tRLOH_min > onfi_timings->tRLOH_min ||
> > +		    spec_timings->tRP_min > onfi_timings->tRP_min ||
> > +		    spec_timings->tRR_min > onfi_timings->tRR_min ||
> > +		    spec_timings->tWC_min > onfi_timings->tWC_min ||
> > +		    spec_timings->tWH_min > onfi_timings->tWH_min ||
> > +		    spec_timings->tWHR_min > onfi_timings->tWHR_min ||
> > +		    spec_timings->tWP_min > onfi_timings->tWP_min ||
> > +		    spec_timings->tWW_min > onfi_timings->tWW_min)  
> 
> Just nitpicking but you could just do the opposite test ('<=' instead of
> '>' and '&&' instead of '||') and return mode directly, so you don't  
> need this continue.

I did it because I wanted the continue; statement to be called as soon
as one test was "true" (ie. wrong in this case) but actually it would
work the same with a <= and a &&, so I'll switch.

> I didn't check if all the _min timings were tested, but assuming that's
> the case, you can add

I copy/pasted the entire structure definition so unless I messed with
it, it should be fine.

> 
> Reviewed-by: Boris Brezillon <boris.brezillon@collabora.com>
> 
> > +			continue;
> > +
> > +		return mode;
> > +	}
> > +
> > +	return 0;
> > +}
> > +
> >  /**
> >   * onfi_fill_data_interface - Initialize a data interface from a given ONFI mode
> >   * @chip: The NAND chip  
> 


______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/

  reply	other threads:[~2020-05-27  7:42 UTC|newest]

Thread overview: 62+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-26 19:16 [PATCH v5 00/28] Allow vendor drivers to propose their own timings Miquel Raynal
2020-05-26 19:16 ` [PATCH v5 01/28] mtd: rawnand: Use unsigned types for nand_chip unsigned values Miquel Raynal
2020-05-26 19:16 ` [PATCH v5 02/28] mtd: rawnand: Only use u8 instead of uint8_t in nand_chip structure Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 03/28] mtd: rawnand: Create a nand_chip operations structure Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 04/28] mtd: rawnand: Rename the manufacturer structure Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 05/28] mtd: rawnand: Declare the nand_manufacturer structure out of nand_chip Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 06/28] mtd: rawnand: Reorganize the nand_chip structure Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 07/28] mtd: rawnand: Compare the actual timing values Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 08/28] mtd: rawnand: Use the data interface mode entry when relevant Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 09/28] mtd: rawnand: Rename nand_has_setup_data_interface() Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 10/28] mtd: rawnand: Fix nand_setup_data_interface() description Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 11/28] mtd: rawnand: Rename nand_init_data_interface() Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 12/28] mtd: rawnand: timings: Update onfi_fill_data_interface() kernel doc Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 13/28] mtd: rawnand: timings: Provide onfi_fill_data_interface() with a data interface Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 14/28] mtd: rawnand: timings: Add a helper to find the closest ONFI mode Miquel Raynal
2020-05-26 21:42   ` Boris Brezillon
2020-05-27  7:42     ` Miquel Raynal [this message]
2020-05-26 19:17 ` [PATCH v5 15/28] mtd: rawnand: timings: Avoid redefining tR_max and tCCS_min Miquel Raynal
2020-05-26 20:33   ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 16/28] mtd: rawnand: timings: Use default values for tPROG_max and tBERS_max Miquel Raynal
2020-05-26 20:32   ` Boris Brezillon
2020-05-26 21:25   ` Boris Brezillon
2020-05-27  7:17     ` Miquel Raynal
2020-05-27  7:22       ` Miquel Raynal
2020-05-27  7:28         ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 17/28] mtd: rawnand: Define a unique reset data interface Miquel Raynal
2020-05-26 21:23   ` Boris Brezillon
2020-05-27  7:20     ` Miquel Raynal
2020-05-27  8:10       ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 18/28] mtd: rawnand: marvell: Use a helper to access the timings Miquel Raynal
2020-05-26 21:26   ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 19/28] mtd: rawnand: legacy: " Miquel Raynal
2020-05-26 21:28   ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 20/28] mtd: rawnand: Hide the chip->data_interface indirection Miquel Raynal
2020-05-26 21:36   ` Boris Brezillon
2020-05-27  7:36     ` Miquel Raynal
2020-05-27  8:14       ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 21/28] mtd: rawnand: Introduce nand_choose_best_sdr_timings() Miquel Raynal
2020-05-26 21:50   ` Boris Brezillon
2020-05-27  7:45     ` Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 22/28] mtd: rawnand: Add the ->choose_data_interface() hook Miquel Raynal
2020-05-26 21:52   ` Boris Brezillon
2020-05-27  7:46     ` Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 23/28] mtd: rawnand: toshiba: Implement ->choose_data_interface() for TC58TEG5DCLTA00 Miquel Raynal
2020-05-26 21:54   ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 24/28] mtd: rawnand: toshiba: Implement ->choose_data_interface() for TC58NVG0S3E Miquel Raynal
2020-05-26 22:02   ` Boris Brezillon
2020-05-27  7:47     ` Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 25/28] mtd: rawnand: hynix: Implement ->choose_data_interface() for H27UCG8T2ATR-BC Miquel Raynal
2020-05-26 22:06   ` Boris Brezillon
2020-05-27  7:50     ` Miquel Raynal
2020-05-26 19:17 ` [PATCH v5 26/28] mtd: rawnand: toshiba: Choose the data interface for TH58NVG2S3HBAI4 Miquel Raynal
2020-05-26 22:10   ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 27/28] mtd: rawnand: Get rid of the default ONFI timing mode Miquel Raynal
2020-05-26 22:13   ` Boris Brezillon
2020-05-26 19:17 ` [PATCH v5 28/28] mtd: rawnand: Allocate the best data interface structure dynamically Miquel Raynal
2020-05-26 22:28   ` Boris Brezillon
2020-05-27  7:57     ` Miquel Raynal
2020-05-27  8:35       ` Boris Brezillon
2020-05-27  8:49         ` Miquel Raynal
2020-05-27  8:57           ` Boris Brezillon
2020-05-27  9:34             ` Miquel Raynal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200527094213.49f59069@xps13 \
    --to=miquel.raynal@bootlin.com \
    --cc=Tudor.Ambarus@microchip.com \
    --cc=boris.brezillon@collabora.com \
    --cc=linux-mtd@lists.infradead.org \
    --cc=richard@nod.at \
    --cc=rickaran@axis.com \
    --cc=vigneshr@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).