linux-mtd.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
 messages from 2019-03-04 13:29:54 to 2019-03-17 20:40:43 UTC [more...]

[PATCH 0/5] fscrypt: d_revalidate fixes and cleanups
 2019-03-17 20:38 UTC  (7+ messages)
` [PATCH 1/5] fscrypt: clean up and improve dentry revalidation
` [PATCH 2/5] fscrypt: fix race allowing rename() and link() of ciphertext dentries
` [PATCH 3/5] fs, fscrypt: clear DCACHE_ENCRYPTED_NAME when unaliasing directory
` [PATCH 4/5] fscrypt: only set dentry_operations on ciphertext dentries
` [PATCH 5/5] fscrypt: fix race where ->lookup() marks plaintext dentry as ciphertext

[RFC PATCH nand-next 0/2] meson-nand: support for older SoCs
 2019-03-16 10:55 UTC  (7+ messages)

[PATCH v5 01/12] dt-bindings: mtd: ingenic: Add compatible strings for JZ4740 and JZ4725B
 2019-03-15 23:25 UTC  (15+ messages)
` [PATCH v5 02/12] dt-bindings: mtd: ingenic: Change 'BCH' to 'ECC' in documentation
` [PATCH v5 03/12] dt-bindings: mtd: ingenic: Use standard ecc-engine property
` [PATCH v5 04/12] mtd: rawnand: Move drivers for Ingenic SoCs to subfolder
` [PATCH v5 05/12] mtd: rawnand: ingenic: Use SPDX license notifiers
` [PATCH v5 06/12] mtd: rawnand: ingenic: Rename jz4780_nand driver to ingenic_nand
` [PATCH v5 07/12] mtd: rawnand: ingenic: Rename jz4780_bch_init to jz4780_bch_reset
` [PATCH v5 08/12] mtd: rawnand: ingenic: Separate top-level and SoC specific code
` [PATCH v5 09/12] mtd: rawnand: ingenic: Make use of ecc-engine property
` [PATCH v5 10/12] mtd: rawnand: ingenic: Add support for the JZ4740
` [PATCH v5 11/12] mtd: rawnand: ingenic: Add support for the JZ4725B
` [PATCH v5 12/12] mtd: rawnand: ingenic: Add ooblayout for the Qi Ben Nanonote

[PATCH] ubifs: remove unnecessary #ifdef around fscrypt_ioctl_get_policy()
 2019-03-15 21:08 UTC  (2+ messages)

[PATCH] ubifs: remove unnecessary calls to set up directory key
 2019-03-15 21:05 UTC  (2+ messages)

[PATCH] spi: rspi: Fix register initialization while runtime-suspended
 2019-03-15 17:19 UTC  (3+ messages)
` Applied "spi: rspi: Fix register initialization while runtime-suspended" to the spi tree

[PATCH 0/2] spi: spi-mem: stm32-qspi: add suspend support and fix
 2019-03-15 17:19 UTC  (5+ messages)
` [PATCH 1/2] spi: spi-mem: stm32-qspi: avoid memory corruption at low frequency
  ` Applied "spi: spi-mem: stm32-qspi: avoid memory corruption at low frequency" to the spi tree
` [PATCH 2/2] spi: spi-mem: stm32-qspi: add suspend/resume support
  ` Applied "spi: spi-mem: stm32-qspi: add suspend/resume support" to the spi tree

[RFC] fscrypt_key_required mount option
 2019-03-15 13:59 UTC  (14+ messages)
  ` [PATCH 1/4] fscrypt: Implement FS_CFLG_OWN_D_OPS
  ` [PATCH 2/4] fscrypt: Export fscrypt_d_ops
  ` [PATCH 3/4] ubifs: Simplify fscrypt_get_encryption_info() error handling
  ` [PATCH 4/4] ubifs: Implement new mount option, fscrypt_key_required

[PATCH v3 0/9] mtd: rawnand: denali: exec_op(), controller/chip separation, and cleanups
 2019-03-15  8:34 UTC  (19+ messages)
` [PATCH v3 1/9] mtd: rawnand: denali: use nand_chip pointer more for internal functions
` [PATCH v3 2/9] mtd: rawnand: denali: refactor syndrome layout handling for raw access
` [PATCH v3 3/9] mtd: rawnand: denali: remove unneeded casts in denali_{read, write}_pio
` [PATCH v3 4/9] mtd: rawnand: denali: switch over to ->exec_op() from legacy hooks
` [PATCH v3 5/9] mtd: rawnand: denali: use bool type instead of int where appropriate
` [PATCH v3 6/9] mtd: rawnand: denali_pci: rename goto labels
` [PATCH v3 7/9] mtd: rawnand: denali: decouple controller and NAND chips
` [PATCH v3 8/9] mtd: rawnand: denali: remove DENALI_NR_BANKS macro
` [PATCH v3 9/9] mtd: rawnand: denali: clean up coding style

[PATCH] jffs2: do not use __constant_cpu_to_xx
 2019-03-14  8:37 UTC 

[PATCH] mtd: physmap_of_gemini: remove extranous __xipram annotation
 2019-03-13 21:22 UTC  (2+ messages)

[GIT PULL] UBI/UBIFS updates for 5.1-rc1
 2019-03-13 16:50 UTC  (5+ messages)

[GIT PULL] UBI/UBIFS updates for 5.1-rc1 (kernel.org edition)
 2019-03-13 14:18 UTC 

[PATCH v2] mtd: spi-nor: Return error when nor->addr_width does not match the device size
 2019-03-13 13:45 UTC 

[PATCH] mtd: spi-nor: Return error when nor->addr_width not match the device size
 2019-03-13 13:20 UTC  (6+ messages)
      `  "
        `  "

[PATCH v4 1/9] dt-bindings: mtd: ingenic: Add compatible strings for JZ4740 and JZ4725B
 2019-03-13 13:12 UTC  (25+ messages)
` [PATCH v4 2/9] dt-bindings: mtd: ingenic: Change 'BCH' to 'ECC' in documentation
` [PATCH v4 6/9] mtd: rawnand: ingenic: Separate top-level and SoC specific code
` [PATCH v4 7/9] mtd: rawnand: ingenic: Add support for the JZ4740
` [PATCH v4 8/9] mtd: rawnand: ingenic: Add support for the JZ4725B

[PATCH v3] spi-nor: intel-spi: Avoid crossing 4K address boundary on read/write
 2019-03-13 10:56 UTC  (2+ messages)

[RFC PATCH 2/2] spi: spi-mem: Add support for Zynq QSPI controller
 2019-03-13  9:53 UTC  (8+ messages)

[PATCH v2 0/3] spi-nor block protection
 2019-03-12 19:27 UTC  (10+ messages)
` [PATCH v2 1/3] mtd: spi-nor: always respect write-protect input
` [PATCH v2 3/3] mtd: spi-nor: allow setting the BPNV (default locked) bit

[PATCH 0/2] Untangle Spansion S25F{L|S}512S chip IDs
 2019-03-12 11:02 UTC  (6+ messages)
` [PATCH 2/2] mtd: spi-nor: refine Spansion S25FL512S ID

[PATCH] mtd: spi-nor: Print all JEDEC ID bytes on error
 2019-03-12 10:45 UTC 

[LINUX PATCH v13] rawnand: pl353: Add basic driver for arm pl353 smc nand interface
 2019-03-11  4:36 UTC  (4+ messages)

[PATCH v1 0/1] mtd: devices: add ACPI support for non-jedec m25p80
 2019-03-07 17:50 UTC  (4+ messages)
` [PATCH v1 1/1] "

atmel nand bindings vs. actual dts files
 2019-03-07 16:25 UTC  (2+ messages)

[PATCH] mtdram: Add module parameter name
 2019-03-07 15:11 UTC  (5+ messages)

mtd: fsl-quadspi: kernel panic in fsl_qspi_nor_write() due to access across page boundary
 2019-03-06 14:08 UTC 

i.MX28 nand driver broken in Linux 4.18
 2019-03-06 13:59 UTC  (5+ messages)

[PATCH v2 0/6] mtd: nand: 6th batch of cleanups (Kconfig)
 2019-03-06  9:52 UTC  (9+ messages)
` [PATCH v2 1/6] mtd: nand: omap: Fix comment in platform data using wrong Kconfig symbol
` [PATCH v2 2/6] mtd: nand: Clarify Kconfig entry for software BCH ECC algorithm
` [PATCH v2 3/6] mtd: nand: Clarify Kconfig entry for software Hamming ECC entries
` [PATCH v2 4/6] mtd: rawnand: Change Kconfig titles and re-order a bit the list
` [PATCH v2 5/6] mtd: rawnand: Clarify Kconfig entry MTD_NAND
` [PATCH v2 6/6] mtd: nand: Remove useless line in Kconfig

[PATCH v2 0/2] mtd: nand: Add Cadence NAND controller driver
 2019-03-05 18:09 UTC  (3+ messages)
` [PATCH v2 1/2] "

[PATCH v2 00/10] mtd: rawnand: denali: exec_op(), controller/chip separation, and cleanups
 2019-03-05 17:55 UTC  (11+ messages)
` [PATCH v2 02/10] mtd: rawnand: denali: refactor syndrome layout handling for raw access
` [PATCH v2 04/10] mtd: rawnand: denali: switch over to ->exec_op() from legacy hooks
` [PATCH v2 05/10] mtd: rawnand: denali: use more precise timeout for NAND_OP_WAITRDT_INSTR

[GIT PULL] mtd: Changes for 5.1
 2019-03-05  3:40 UTC  (2+ messages)

[PATCH v2 00/36] Introduce the generic ECC engine abstraction
 2019-03-04 22:28 UTC  (37+ messages)
` [PATCH v2 01/36] mtd: nand: Move nand_device forward declaration to the top
` [PATCH v2 02/36] mtd: nand: Add an extra level in the Kconfig hierarchy
` [PATCH v2 03/36] mtd: nand: Drop useless 'depends on' in Kconfig
` [PATCH v2 04/36] mtd: rawnand: Use the NAND core
` [PATCH v2 05/36] mtd: nand: Add a NAND page I/O request type
` [PATCH v2 06/36] mtd: nand: Rename a core structure
` [PATCH v2 07/36] mtd: rawnand: Avoid a typedef
` [PATCH v2 08/36] mtd: rawnand: Add an invalid ECC mode to discriminate with valid ones
` [PATCH v2 09/36] mtd: rawnand: Clarify the values for invalid ECC mode/algo
` [PATCH v2 10/36] mtd: nand: Introduce the ECC engine abstraction
` [PATCH v2 11/36] mtd: Fix typo in mtd_ooblayout_set_databytes() description
` [PATCH v2 12/36] mtd: nand: Move standard OOB layouts to the generic ECC core
` [PATCH v2 13/36] mtd: nand: Move ECC specific functions to ecc/engine.c
` [PATCH v2 14/36] mtd: nand: ecc: Move BCH code into the ecc/ directory
` [PATCH v2 15/36] mtd: nand: ecc: Use SPDX license identifier for the software BCH code
` [PATCH v2 16/36] mtd: nand: ecc: Turn the software BCH implementation generic
` [PATCH v2 17/36] mtd: rawnand: Get rid of chip->ecc.priv
` [PATCH v2 18/36] mtd: nand: ecc: Move Hamming code into the ecc/ directory
` [PATCH v2 19/36] mtd: nand: ecc: Use SPDX license identifier for the software Hamming code
` [PATCH v2 20/36] mtd: nand: ecc: Clarify the software Hamming introductory line
` [PATCH v2 21/36] mtd: nand: ecc: Turn the software Hamming implementation generic
` [PATCH v2 22/36] mtd: nand: Remove useless include about software Hamming ECC
` [PATCH v2 23/36] mtd: nand: ecc: Let the software BCH ECC engine be a module
` [PATCH v2 24/36] mtd: nand: ecc: Let the software Hamming ECC engine be unselected
` [PATCH v2 25/36] mtd: nand: ecc: Create the software BCH engine instance
` [PATCH v2 26/36] mtd: nand: ecc: Create the software Hamming "
` [PATCH v2 27/36] mtd: nand: Let software ECC engines be retrieved from the NAND core
` [PATCH v2 28/36] mtd: spinand: Fix typo in comment
` [PATCH v2 29/36] mtd: spinand: Move ECC related definitions earlier in the driver
` [PATCH v2 30/36] mtd: spinand: Instantiate a SPI-NAND on-die ECC engine
` [PATCH v2 31/36] mtd: nand: Let on-die ECC engines be retrieved from the NAND core
` [PATCH v2 32/36] mtd: rawnand: Fill a default ECC provider/algorithm
` [PATCH v2 33/36] mtd: spinand: "
` [PATCH v2 34/36] mtd: nand: Add helpers to manage ECC engines and configurations
` [PATCH v2 35/36] mtd: spinand: Use the external ECC engine logic
` [PATCH v2 36/36] mtd: spinand: Propagate ECC information to the MTD structure

[PATCH v2 00/15] mtd: rawnand: 5th batch of cleanups
 2019-03-04 20:15 UTC  (16+ messages)
` [PATCH v2 01/15] mtd: nand: Add max_bad_eraseblocks_per_lun info to memorg
` [PATCH v2 02/15] mtd: nand: Add a helper returning the number of eraseblocks per target
` [PATCH v2 03/15] mtd: nand: Add a helper to retrieve the number of pages "
` [PATCH v2 04/15] mtd: spinand: Implement mtd->_max_bad_blocks
` [PATCH v2 05/15] mtd: rawnand: Use nand_to_mtd() in nand_{set, get}_flash_node()
` [PATCH v2 06/15] mtd: rawnand: Prepare things to reuse the generic NAND layer
` [PATCH v2 07/15] mtd: rawnand: Fill memorg during detection
` [PATCH v2 08/15] mtd: rawnand: Initialize the nand_device object
` [PATCH v2 09/15] mtd: rawnand: Provide a helper to get chip->data_buf
` [PATCH v2 10/15] mtd: rawnand: Move all page cache related fields to a sub-struct
` [PATCH v2 11/15] mtd: rawnand: Use nanddev_mtd_max_bad_blocks()
` [PATCH v2 12/15] mtd: rawnand: Get rid of chip->bits_per_cell
` [PATCH v2 13/15] mtd: rawnand: Get rid of chip->chipsize
` [PATCH v2 14/15] mtd: rawnand: Get rid of chip->numchips
` [PATCH v2 15/15] mtd: rawnand: Get rid of chip->ecc_{strength, step}_ds

[PATCH 2/2] mtd: spinand: micron: Support for all Micron SPI NAND flashes
 2019-03-04 18:13 UTC  (4+ messages)
  ` [EXT] "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).